summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-03-07 20:40:50 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-03-07 20:55:01 +0100
commitf259b085677a44a0c3d0ddf2cba95e4cdb427034 (patch)
tree2a0d968010c6b1f3f2be59264290450642240a98 /media-libs/libvpl
parentmedia-libs/libvpl: add 2.10.2, drop 2.10.2 (diff)
downloadgentoo-f259b085677a44a0c3d0ddf2cba95e4cdb427034.tar.gz
gentoo-f259b085677a44a0c3d0ddf2cba95e4cdb427034.tar.bz2
gentoo-f259b085677a44a0c3d0ddf2cba95e4cdb427034.zip
media-libs/oneVPL: move to media-libs/libvpl
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-libs/libvpl')
-rw-r--r--media-libs/libvpl/Manifest1
-rw-r--r--media-libs/libvpl/libvpl-2.10.2.ebuild82
-rw-r--r--media-libs/libvpl/metadata.xml19
3 files changed, 102 insertions, 0 deletions
diff --git a/media-libs/libvpl/Manifest b/media-libs/libvpl/Manifest
new file mode 100644
index 000000000000..91c8f3fb2356
--- /dev/null
+++ b/media-libs/libvpl/Manifest
@@ -0,0 +1 @@
+DIST libvpl-2.10.2.tar.gz 11872075 BLAKE2B 6d9b6ba66b1e1c191a309ff26ec54a5bb62fa542ca9eab042a437eca9a82cf9d7e3056247a8110b49e28388bdbd8e4c0793dda8dd84d229937524faa96b10f37 SHA512 e4f6e1656371a8edb54a3a67726439d97dd5e8225fa37fdfc309602dd83c51e4a2b4e72bdb18b81dc6691f666a8857b460c45392cf030a8309abd368037be49d
diff --git a/media-libs/libvpl/libvpl-2.10.2.ebuild b/media-libs/libvpl/libvpl-2.10.2.ebuild
new file mode 100644
index 000000000000..c9eddbfedb17
--- /dev/null
+++ b/media-libs/libvpl/libvpl-2.10.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib optfeature
+
+DESCRIPTION="Intel Video Processing Library, dispatcher, tools, and examples"
+HOMEPAGE="https://github.com/intel/libvpl/"
+SRC_URI="https://github.com/intel/libvpl//archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libvpl-${PV}"
+
+LICENSE="MIT"
+SLOT="0/2"
+KEYWORDS="~amd64"
+
+IUSE="dri drm examples experimental tools test vaapi wayland X"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+ dri? ( X drm )
+ X? ( vaapi )
+ wayland? ( drm )
+"
+
+RDEPEND="
+ x11-libs/libpciaccess[${MULTILIB_USEDEP}]
+ vaapi? ( media-libs/libva[X?,wayland?,drm(+)?,${MULTILIB_USEDEP}] )
+ drm? ( x11-libs/libdrm[${MULTILIB_USEDEP}] )
+ wayland? (
+ dev-libs/wayland[${MULTILIB_USEDEP}]
+ )
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ wayland? (
+ dev-libs/wayland-protocols
+ )
+"
+BDEPEND="virtual/pkgconfig"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_DISPATCHER=ON
+ # Headers, cmake and pkgconfig files
+ -DBUILD_DEV=ON
+ -DBUILD_EXAMPLES="$(usex examples)"
+ -DINSTALL_EXAMPLE_CODE="$(usex examples)"
+ -DBUILD_PREVIEW="$(usex experimental)"
+ -DBUILD_DISPATCHER_ONEVPL_EXPERIMENTAL="$(usex experimental)"
+ # Fails to build with experimental tools off if tools on
+ -DBUILD_TOOLS_ONEVPL_EXPERIMENTAL="$(multilib_native_usex tools)"
+ -DBUILD_TESTS="$(usex test)"
+ # Tools fails to compile for 32 bit
+ -DBUILD_TOOLS="$(multilib_native_usex tools)"
+ -DENABLE_WAYLAND="$(usex wayland)"
+ -DENABLE_X11="$(usex X)"
+ -DENABLE_DRI3="$(usex dri)"
+ -DENABLE_VA="$(usex vaapi)"
+ -DENABLE_DRM="$(usex drm)"
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
+ )
+ cmake_src_configure
+}
+
+multilib_src_install() {
+ cmake_src_install
+ # Remove these license files
+ rm -r "${ED}/usr/share/vpl/licensing" || die
+}
+
+pkg_postinst() {
+ optfeature_header "This package provides only the dispatcher, to use it install one or more implementations"
+ optfeature "CPUs" media-libs/oneVPL-cpu
+ optfeature "Intel GPUs newer then, and including, Intel Xe" media-libs/oneVPL-intel-gpu
+ optfeature "Intel GPUs older then Intel Xe" media-libs/intel-mediasdk
+}
diff --git a/media-libs/libvpl/metadata.xml b/media-libs/libvpl/metadata.xml
new file mode 100644
index 000000000000..77f4c9b27db9
--- /dev/null
+++ b/media-libs/libvpl/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">intel/libvpl</remote-id>
+ </upstream>
+ <use>
+ <flag name="drm">Build with DRM support</flag>
+ <flag name="experimental">Build dispatcher with experimental APIs</flag>
+ <flag name="tools">Build decode/encode/analyse/inspect tools</flag>
+ </use>
+</pkgmetadata>