summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-05-05 00:52:03 -0400
committerSam James <sam@gentoo.org>2024-05-05 12:47:11 +0100
commit7eea00cab392d029ac574c691fa0149b77c743f4 (patch)
tree016420c1f8305d676eb0cec8871c0fef21d146ba /media-libs/liblo
parentmedia-libs/libltc: run elibtoolize in non-live ebuild (diff)
downloadgentoo-7eea00cab392d029ac574c691fa0149b77c743f4.tar.gz
gentoo-7eea00cab392d029ac574c691fa0149b77c743f4.tar.bz2
gentoo-7eea00cab392d029ac574c691fa0149b77c743f4.zip
media-libs/liblo: replace useless sed with configure option
* SED: the following did not cause any changes * sed -i '/^SUBDIRS =/s/examples//' Makefile.am || die; * no-op: -e /^SUBDIRS =/s/examples// In 2014, the Makefile.am was reworked (in version 0.29): https://sourceforge.net/p/liblo/git/ci/02f7754e245080626a590e43c190dfd4abe0d72f/ This was a side effect of making it into a configure option, which means patching is no longer needed. As a result, the intended goal of this sed hasn't worked for a decade -- the examples were compiled by portage and then discarded as they aren't installed. It is "just" wasted work. But we can avoid that... Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/liblo')
-rw-r--r--media-libs/liblo/liblo-0.32.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/media-libs/liblo/liblo-0.32.ebuild b/media-libs/liblo/liblo-0.32.ebuild
index b5b1eaac6230..26f501ffc99b 100644
--- a/media-libs/liblo/liblo-0.32.ebuild
+++ b/media-libs/liblo/liblo-0.32.ebuild
@@ -24,9 +24,6 @@ PATCHES=(
src_prepare() {
default
- # don't build examples by default
- sed -i '/^SUBDIRS =/s/examples//' Makefile.am || die
-
eautoreconf
}
@@ -35,6 +32,8 @@ src_configure() {
# switching threads on/off breaks ABI, bugs #473282, #473286 and #473356
local myeconfargs=(
+ # don't build examples by default
+ --disable-examples
--enable-threads
--disable-network-tests
$(use_enable test tests)