summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libXcm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libXcm')
-rw-r--r--media-libs/libXcm/Manifest2
-rw-r--r--media-libs/libXcm/libXcm-0.5.2-r1.ebuild31
-rw-r--r--media-libs/libXcm/libXcm-0.5.3.ebuild31
-rw-r--r--media-libs/libXcm/libXcm-9999.ebuild31
-rw-r--r--media-libs/libXcm/metadata.xml9
5 files changed, 104 insertions, 0 deletions
diff --git a/media-libs/libXcm/Manifest b/media-libs/libXcm/Manifest
new file mode 100644
index 000000000000..93d3f4cfee6c
--- /dev/null
+++ b/media-libs/libXcm/Manifest
@@ -0,0 +1,2 @@
+DIST libXcm-0.5.2.tar.bz2 301813 SHA256 1ed2750e55dd3c8c9e1597de577bdc3a72d37e976979926d973ea9e3583afcd5 SHA512 4d67218206ba319cb768c055c44a0537468232c12fa463525993c578b5a5a8ee82fc55463ef5e34e85dda221facd2517372bc1920bd025e951337fa84c72f6ab WHIRLPOOL 72ebdb1883065d4c42ed4caee6ad018df7f43f03aab241af576e8e8b91d6a8b03b082da94179f35508b720ff4660ebd533dc5bfc243b8c86faa6766905444790
+DIST libXcm-0.5.3.tar.bz2 303829 SHA256 04bda6aa4e8b1ef61815ebfc7760277856a5fd3b347948e0d99cf0ec78b03050 SHA512 af5ccb3d6834ceb34b25a6ec0362a0d111e5fde91fe41f7ff8ea3000d2031573f477f1074eada1bc67a2fe920d7d63f272996b3ad3678a010e0d0092351ea5e4 WHIRLPOOL 259367e279c53bbc91c468046a7e5c8a646739f3499b91834082167af82fc134658f6826cf2ef94c775a1c36b7eec2b30386d0e23a8b70b33ab966aaf92f68c5
diff --git a/media-libs/libXcm/libXcm-0.5.2-r1.ebuild b/media-libs/libXcm/libXcm-0.5.2-r1.ebuild
new file mode 100644
index 000000000000..c5d4bd0d28f7
--- /dev/null
+++ b/media-libs/libXcm/libXcm-0.5.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-multilib
+
+DESCRIPTION="reference implementation of the net-color spec"
+HOMEPAGE="http://www.oyranos.org/libxcm/"
+SRC_URI="mirror://sourceforge/oyranos/${PN}/${PN}-0.4.x/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="X static-libs"
+
+RDEPEND="X? ( >=x11-libs/libXmu-1.1.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-silent-rules
+ $(use_with X x11)
+ $(use_enable static-libs static)
+ )
+ autotools-multilib_src_configure
+}
diff --git a/media-libs/libXcm/libXcm-0.5.3.ebuild b/media-libs/libXcm/libXcm-0.5.3.ebuild
new file mode 100644
index 000000000000..6c66071380ba
--- /dev/null
+++ b/media-libs/libXcm/libXcm-0.5.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-multilib
+
+DESCRIPTION="reference implementation of the net-color spec"
+HOMEPAGE="http://www.oyranos.org/libxcm/"
+SRC_URI="mirror://sourceforge/oyranos/${PN}/${PN}-0.4.x/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X static-libs"
+
+RDEPEND="X? ( >=x11-libs/libXmu-1.1.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-silent-rules
+ $(use_with X x11)
+ $(use_enable static-libs static)
+ )
+ autotools-multilib_src_configure
+}
diff --git a/media-libs/libXcm/libXcm-9999.ebuild b/media-libs/libXcm/libXcm-9999.ebuild
new file mode 100644
index 000000000000..4c70f928984b
--- /dev/null
+++ b/media-libs/libXcm/libXcm-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-multilib git-2
+
+DESCRIPTION="reference implementation of the net-color spec"
+HOMEPAGE="http://www.oyranos.org/libxcm/"
+EGIT_REPO_URI="git://www.oyranos.org/git/xcolor"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="X static-libs"
+
+RDEPEND="X? ( >=x11-libs/libXmu-1.1.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-silent-rules
+ $(use_with X x11)
+ $(use_enable static-libs static)
+ )
+ autotools-multilib_src_configure
+}
diff --git a/media-libs/libXcm/metadata.xml b/media-libs/libXcm/metadata.xml
new file mode 100644
index 000000000000..59acc2cc580e
--- /dev/null
+++ b/media-libs/libXcm/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
+