summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2023-04-05 07:32:59 -0500
committerBen Kohler <bkohler@gentoo.org>2023-04-05 08:03:43 -0500
commitd00a4cce8a2a24d5cdeaf765ad3491c2cbe81685 (patch)
tree3ed50d30d1e520efdd55ece3eed8ade589752952 /media-gfx
parentdev-python/sphinx-basic-ng: Stabilize 1.0.0_beta1 sparc, #903836 (diff)
downloadgentoo-d00a4cce8a2a24d5cdeaf765ad3491c2cbe81685.tar.gz
gentoo-d00a4cce8a2a24d5cdeaf765ad3491c2cbe81685.tar.bz2
gentoo-d00a4cce8a2a24d5cdeaf765ad3491c2cbe81685.zip
media-gfx/fotoxx: add 23.31
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/fotoxx/Manifest1
-rw-r--r--media-gfx/fotoxx/fotoxx-23.31.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/media-gfx/fotoxx/Manifest b/media-gfx/fotoxx/Manifest
index cce6c28e6bfe..f40ddb2c9345 100644
--- a/media-gfx/fotoxx/Manifest
+++ b/media-gfx/fotoxx/Manifest
@@ -2,3 +2,4 @@ DIST fotoxx-22.35.tar.gz 8675173 BLAKE2B 0d0c709da603a59f432b184b0477cc3a65166c3
DIST fotoxx-23.0.tar.gz 9258345 BLAKE2B 96510f43c2b8a289191a1194adf13b255d29ebd8aae4e286f2fcc180bb1ecefe5df7ab9251a55e83010a527d455117ddd99dea7df189a38bc82e5b233806307e SHA512 b40025f90561c10ebb107edf26863be154c0b699c811275f2de71f9da417921704fb2215266d725a7f84b19327da54b3f9be2d00db6dfb9738739a2e9ffc1903
DIST fotoxx-23.1.tar.gz 9198469 BLAKE2B a14064c1b240badcfe5c24970528956e2f7acfbcb6720c7f376447bb65b26db7f50ceedbe3ad8c36d7439e56dae074d4e6feee315a746e911a1d2fb9b77dabcd SHA512 5adf8501bb5ce232668b8dd551ccfac591f23dbb33dec4c303b37b1f4f7fd6c43dab67f3dc38a8647260b32e51f9778cb6dcaba5aaa91a2565d1f810afca7353
DIST fotoxx-23.2-source.tar.gz 9233622 BLAKE2B 425c6f20210c62d08ee14f53436f3256e829a6fa3453047fe07ee0357fa277cdfe37340a6c19d0c39c2885b5ab6478d4791eb00631447f0b8d6ee53436750d5b SHA512 6193c99f11034609fdc052cf29184835644c76fd37270d8a8e9a76524d7bec7ea6ddc8e0c0ad7874d6997eba5c8c81f0f1a355a06a1220600380931aab10759b
+DIST fotoxx-23.31-source.tar.gz 9273695 BLAKE2B e300b24122c1b7b1cd48f2264cd3ee73602542ef119cf0e20f0618bd79e3ee5332331792f6c3f0b1d1b3ba78f12c2d2bd484d9b7af80850793a16a761c905426 SHA512 008a9c264546698ba765c09141f7d1c0cce80f36171aaf8136b9fa462920463134752c7dc3d58c38f2afde858707385410e9d72216a01b28ca0e70985df5ec31
diff --git a/media-gfx/fotoxx/fotoxx-23.31.ebuild b/media-gfx/fotoxx/fotoxx-23.31.ebuild
new file mode 100644
index 000000000000..f3a0d0447279
--- /dev/null
+++ b/media-gfx/fotoxx/fotoxx-23.31.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature xdg-utils
+
+DESCRIPTION="Program for improving image files made with a digital camera"
+HOMEPAGE="https://kornelix.net/fotoxx/fotoxx.html"
+SRC_URI="https://kornelix.net/downloads/downloads/${P}-source.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+# For required dependencies read doc/README, for required tools read
+# data/userguide [INSTALLATION]. xdg-open (x11-misc/xdg-utils) is an
+# alternative to firefox and chromium-browser. `grep '"which ' * -R`
+# is helpful to report some required tools run via the shell.
+
+DEPEND="
+ media-libs/clutter
+ media-libs/clutter-gtk
+ media-libs/lcms:2
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:=
+ media-libs/tiff:=
+ media-libs/libchamplain[gtk]
+ x11-libs/gtk+:3"
+RDEPEND="
+ ${DEPEND}
+ media-gfx/dcraw
+ media-libs/exiftool
+ x11-misc/xdg-utils
+"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}/${PN}-22.18-documentation.patch" )
+
+DOCS=()
+HTML_DOCS=()
+
+src_prepare() {
+ sed -i -e "/^DOCDIR/ s/${PN}$/${PF}/" Makefile || die
+ sed -i -e "/^Icon/ s/\.png$//" fotoxx.desktop || die
+ default
+}
+
+src_install() {
+ # For the Help menu items to work, *.html must be in /usr/share/doc/${PF},
+ # and README, changelog, copyright, license, etc. must not be compressed.
+ emake DESTDIR="${D}" install
+ rm -f "${D}"/usr/share/doc/${PF}/*.man || die
+ docompress -x /usr/share/doc
+}
+
+pkg_postinst() {
+ optfeature "HEIC & AVIF file support" media-libs/libheif
+ optfeature "additional RAW file support" media-gfx/rawtherapee
+ optfeature "additional RAW file support" media-gfx/darktable
+ optfeature "video thumbnails & playback" media-video/ffmpeg
+ optfeature "copying images to optical media" app-cdr/dvd+rw-tools
+ optfeature "WEBP file support" media-libs/libwebp
+
+ elog
+ elog "Please read the Help > User Guide for details. The source location is"
+ elog "/usr/share/fotoxx/data/userguide and after running fotoxx a copy will"
+ elog "be placed at /home/<user>/.fotoxx/userguide."
+ elog
+ elog "To play videos, in Tools > Preferences set 'Video File Play Command'."
+ elog
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}