summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2024-05-07 14:36:18 -0500
committerBen Kohler <bkohler@gentoo.org>2024-05-07 14:36:55 -0500
commit9f9623b47fa74125bab59655b129e266e7585117 (patch)
tree4c18a42fbd9d61585f8cbdcbb8fb8db4967b87a9 /media-gfx
parentnet-misc/dropbox: add 198.4.7615 (diff)
downloadgentoo-9f9623b47fa74125bab59655b129e266e7585117.tar.gz
gentoo-9f9623b47fa74125bab59655b129e266e7585117.tar.bz2
gentoo-9f9623b47fa74125bab59655b129e266e7585117.zip
media-gfx/fotocx: add 24.30
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/fotocx/Manifest1
-rw-r--r--media-gfx/fotocx/fotocx-24.30.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/media-gfx/fotocx/Manifest b/media-gfx/fotocx/Manifest
index 3c1868cea93e..c299d7cf60b6 100644
--- a/media-gfx/fotocx/Manifest
+++ b/media-gfx/fotocx/Manifest
@@ -1 +1,2 @@
DIST fotocx-24.21-source.tar.gz 16618357 BLAKE2B 43029d080cc843a03475b474c0807e0f2192bc6c64d20c5d41e90218f0b1f88db48aefb7622e8b521f06792a57a9d685d9c57107a309becc39d710ff5aa720a3 SHA512 2945fbaab800a115a1e0c718019ee1e66816cadf794a01db4f8238e7ba74ea033b6e9f24b4e42fe8105242f6df8861de7b00d32e81aae73577f5aa7f38c07f7f
+DIST fotocx-24.30-source.tar.gz 16103870 BLAKE2B 3261b9f4fb0345b37b146e443216e21d57ab9b11a1b77be9b9d94247cc8ae74442b75219fbf3d12f67ba16cee0cf772d3ba83d9e2b5ae38ddbbfd5bd42ea9c52 SHA512 39a4c8526e8fe7e49f4c85953e843243577b9a5b34b89030c452336f51c0ca6e381c38ba60ee39e6ee58b528d824240a821487e5e95a04dd44dabfe38e43f131
diff --git a/media-gfx/fotocx/fotocx-24.30.ebuild b/media-gfx/fotocx/fotocx-24.30.ebuild
new file mode 100644
index 000000000000..8eee122865a7
--- /dev/null
+++ b/media-gfx/fotocx/fotocx-24.30.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature xdg-utils
+
+DESCRIPTION="Program for improving image files made with a digital camera"
+HOMEPAGE="https://kornelix.net/fotocx/fotocx.html"
+SRC_URI="https://kornelix.net/downloads/downloads/${P}-source.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# For required dependencies read doc/README, for required tools read
+# data/userguide [INSTALLATION]. xdg-open (x11-misc/xdg-utils) is an
+# alternative to firefox and chromium-browser. `grep '"which ' * -R`
+# is helpful to report some required tools run via the shell.
+
+DEPEND="
+ media-libs/clutter
+ media-libs/clutter-gtk
+ media-libs/lcms:2
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:=
+ media-libs/tiff:=
+ media-libs/libchamplain[gtk]
+ x11-libs/gtk+:3"
+RDEPEND="
+ ${DEPEND}
+ media-gfx/dcraw
+ media-libs/exiftool
+ x11-misc/xdg-utils
+"
+
+PATCHES=( "${FILESDIR}/${PN}-24.20-documentation.patch" )
+
+DOCS=()
+HTML_DOCS=()
+
+src_prepare() {
+ sed -i -e "/^DOCDIR/ s/${PN}$/${PF}/" Makefile || die
+ sed -i -e "/^Icon/ s/\.png$//" ${PN}.desktop || die
+ default
+}
+
+src_install() {
+ # For the Help menu items to work, *.html must be in /usr/share/doc/${PF},
+ # and README, changelog, copyright, license, etc. must not be compressed.
+ emake DESTDIR="${D}" PREFIX="/usr" install
+ rm -f "${D}"/usr/share/doc/${PF}/*.man || die
+ docompress -x /usr/share/doc
+}
+
+pkg_postinst() {
+ optfeature "HEIC & AVIF file support" media-libs/libheif
+ optfeature "additional RAW file support" media-gfx/rawtherapee
+ optfeature "additional RAW file support" media-gfx/darktable
+ optfeature "video thumbnails & playback" media-video/ffmpeg
+ optfeature "copying images to optical media" app-cdr/dvd+rw-tools
+ optfeature "WEBP file support" media-libs/libwebp
+
+ elog
+ elog "Please read the Help > User Guide for details. The source location is"
+ elog "/usr/share/fotocx/data/userguide and after running fotocx a copy will"
+ elog "be placed at /home/<user>/.fotocx/userguide."
+ elog
+ elog "To play videos, in Tools > Preferences set 'Video File Play Command'."
+ elog
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}