summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2024-11-07 09:02:56 -0600
committerBen Kohler <bkohler@gentoo.org>2024-11-07 09:08:58 -0600
commit49a458d7015fa0e0b9a72fecbb80313557b6558a (patch)
tree38e6b7c0b762eed18e135c89a64ed42e3e7eb19a /media-gfx
parentapp-editors/zed: remove 0.158.1 (diff)
downloadgentoo-49a458d7015fa0e0b9a72fecbb80313557b6558a.tar.gz
gentoo-49a458d7015fa0e0b9a72fecbb80313557b6558a.tar.bz2
gentoo-49a458d7015fa0e0b9a72fecbb80313557b6558a.zip
media-gfx/fotocx: add 24.70
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/fotocx/Manifest1
-rw-r--r--media-gfx/fotocx/fotocx-24.70.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/media-gfx/fotocx/Manifest b/media-gfx/fotocx/Manifest
index b79409e7262d..fbc2a2f18eb0 100644
--- a/media-gfx/fotocx/Manifest
+++ b/media-gfx/fotocx/Manifest
@@ -1,2 +1,3 @@
DIST fotocx-24.50-source.tar.gz 16197289 BLAKE2B 468a3cd7ef2cee5a65d2a06283732e0994f9eeb823ed2fd02e319c68f7cb4686a33fbc61e85eaeb8bdd2c7455d1cebada49d0da6004007ad15333b1c39050768 SHA512 3f30b4efb43313980a1be8b92e66c8260484e10a3e50c5351d5462004fe6e5685ecd39be263fbd85bde495a5f1c539bd262124478516d8ddcd40420fa6de699e
DIST fotocx-24.60-source.tar.gz 15771741 BLAKE2B 89ab212cdaeb414637ad0b3c9833b0caea6c805422e3fccdd027912f1d32ed141cedaeb5826212e36e5b40591e40c85816ecc5d3cff7915693e11e78b962b890 SHA512 6a04e0d749865000b67497b897f691a5882c0d63dda8c64ffe824215582db051f9cc0ca528490112f26db41a58f1673affe2e2e55c90dbb9e6f24cef77e4d5d6
+DIST fotocx-24.70-source.tar.gz 15771508 BLAKE2B 74343ee57a0611b470794ae211ac4923744ab5619895234b50ccf00e88d9fe4f15aa94a83112acbf160a5e0c2befbef070da258500d17f240f8ccd467784c8e5 SHA512 1b7b160ede154a80251ffd6935b8a10767e70fcb87e2071899ee1a8228c8d816323d947a631320d525f6a37768c32bcc2a998a30ee2ac4e1769354a85a0f7f27
diff --git a/media-gfx/fotocx/fotocx-24.70.ebuild b/media-gfx/fotocx/fotocx-24.70.ebuild
new file mode 100644
index 000000000000..8eee122865a7
--- /dev/null
+++ b/media-gfx/fotocx/fotocx-24.70.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature xdg-utils
+
+DESCRIPTION="Program for improving image files made with a digital camera"
+HOMEPAGE="https://kornelix.net/fotocx/fotocx.html"
+SRC_URI="https://kornelix.net/downloads/downloads/${P}-source.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# For required dependencies read doc/README, for required tools read
+# data/userguide [INSTALLATION]. xdg-open (x11-misc/xdg-utils) is an
+# alternative to firefox and chromium-browser. `grep '"which ' * -R`
+# is helpful to report some required tools run via the shell.
+
+DEPEND="
+ media-libs/clutter
+ media-libs/clutter-gtk
+ media-libs/lcms:2
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:=
+ media-libs/tiff:=
+ media-libs/libchamplain[gtk]
+ x11-libs/gtk+:3"
+RDEPEND="
+ ${DEPEND}
+ media-gfx/dcraw
+ media-libs/exiftool
+ x11-misc/xdg-utils
+"
+
+PATCHES=( "${FILESDIR}/${PN}-24.20-documentation.patch" )
+
+DOCS=()
+HTML_DOCS=()
+
+src_prepare() {
+ sed -i -e "/^DOCDIR/ s/${PN}$/${PF}/" Makefile || die
+ sed -i -e "/^Icon/ s/\.png$//" ${PN}.desktop || die
+ default
+}
+
+src_install() {
+ # For the Help menu items to work, *.html must be in /usr/share/doc/${PF},
+ # and README, changelog, copyright, license, etc. must not be compressed.
+ emake DESTDIR="${D}" PREFIX="/usr" install
+ rm -f "${D}"/usr/share/doc/${PF}/*.man || die
+ docompress -x /usr/share/doc
+}
+
+pkg_postinst() {
+ optfeature "HEIC & AVIF file support" media-libs/libheif
+ optfeature "additional RAW file support" media-gfx/rawtherapee
+ optfeature "additional RAW file support" media-gfx/darktable
+ optfeature "video thumbnails & playback" media-video/ffmpeg
+ optfeature "copying images to optical media" app-cdr/dvd+rw-tools
+ optfeature "WEBP file support" media-libs/libwebp
+
+ elog
+ elog "Please read the Help > User Guide for details. The source location is"
+ elog "/usr/share/fotocx/data/userguide and after running fotocx a copy will"
+ elog "be placed at /home/<user>/.fotocx/userguide."
+ elog
+ elog "To play videos, in Tools > Preferences set 'Video File Play Command'."
+ elog
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}