summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2023-12-09 10:07:52 +0000
committerMatthew Smith <matthew@gentoo.org>2023-12-09 10:08:10 +0000
commit5faf13345574251d3e32e8ae50dbd501b3572c6c (patch)
tree4460685c5a322cf239097397a294d86b601ee483 /media-gfx/renderdoc
parentjava-pkg-opt-2.eclass: Drop redundant EAPI conditional (diff)
downloadgentoo-5faf13345574251d3e32e8ae50dbd501b3572c6c.tar.gz
gentoo-5faf13345574251d3e32e8ae50dbd501b3572c6c.tar.bz2
gentoo-5faf13345574251d3e32e8ae50dbd501b3572c6c.zip
media-gfx/renderdoc: add 1.30
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'media-gfx/renderdoc')
-rw-r--r--media-gfx/renderdoc/Manifest2
-rw-r--r--media-gfx/renderdoc/renderdoc-1.30.ebuild202
2 files changed, 204 insertions, 0 deletions
diff --git a/media-gfx/renderdoc/Manifest b/media-gfx/renderdoc/Manifest
index 1b633938f478..da5b3bd3a16c 100644
--- a/media-gfx/renderdoc/Manifest
+++ b/media-gfx/renderdoc/Manifest
@@ -2,4 +2,6 @@ DIST renderdoc-1.27.tar.gz 47445907 BLAKE2B 58be926cb1282fe5bb2ba195cf71fabd9a5f
DIST renderdoc-1.27.tar.gz.asc 833 BLAKE2B fdfbd1ce367e9757e080e1263651444cd4001fe3d8580672a476923e2cf56b030b568c90566f258b1fd485c15c9d6c5a0b91cfb2c72c831677aa088acb9d4c15 SHA512 a74517747bf19a16d8db241a795e16d1213c745d3ff29236844433937202c91da1e580daac6ec7a54322b215163b0ebf492bef9b77eb603720503e4d3a4849df
DIST renderdoc-1.29.tar.gz 50717466 BLAKE2B 492b32140c8ad1ab3e753158cfede64ea0b580a2df03094aeeff2d4eac659fbedc62971f65d3fe024e0282de39d5f122b512be2fc6a28ac7abf794b58f116322 SHA512 cbb6a2bd4a7d0c4347296f0e6f49d90b40ba11949e1bc5d777104f067c70999c5b124c44eb180a37363331832afb890f7a83fac521d306dd99cdab92b0d09106
DIST renderdoc-1.29.tar.gz.asc 833 BLAKE2B b8fe64653153ed09b9e03eb255747d8476f6a6badea0bd834808d4e982750b627dc736b71ddacb96ac82e0136500cdb6c54dc4e7ab49529b2044b8e6512a1822 SHA512 ed7b12376e189df421ba69e6b1c14790045491195bdf1197c7c7a6fdc20d72046ae441d057a01e283a7e2ff85b4b341ec6bf45a28e8b04a9f48b441b42699cfd
+DIST renderdoc-1.30.tar.gz 50938458 BLAKE2B 2e9364a8eabca64384e066709c98be8df0ed3c970c173074f9d38eea21d4dc31a50b862818879ccb9f32be8b839643c2d01ddda70d9da8c338c2fc305549eaa9 SHA512 33437f7420d6a79f2b02536ae63bc31537cfab83cdac2d44efdef377e93db7c0c15f2e46ecc67a6ea780f36b162f04d7a00ac3fe5d382fe761fa986664aceb60
+DIST renderdoc-1.30.tar.gz.asc 833 BLAKE2B c829329806de5cfc672c2cc976596a5c126cd5f24bef189f6832de8f8f3721461e56688823d562e82eae89792c5fc4a500037cc97c2cce2b762b211a951c1d19 SHA512 f68a04aec4e304df0eba3dcba2876f99182fecff82b6b600d621e48c15bce42c07f20aebc811fd36aff5c04f550a51483af2b499051700a2c5bc936311a534de
DIST swig-renderdoc-7.tar.gz 4006241 BLAKE2B 619f41239f4aef496264d61f44ae042cf80d3ff28491d452cf11ad07e898554c4a32df6119ee0e8e3de36e6bee61855358cd968ad01c9281976e24e9a6cac839 SHA512 5285a65924c069cfb9f73104ad8a95251badac4001293a1757b97ebead5953730c03289159741f82da4c5afe4f61f7c826b105eaf82df044ed2fa21810242c86
diff --git a/media-gfx/renderdoc/renderdoc-1.30.ebuild b/media-gfx/renderdoc/renderdoc-1.30.ebuild
new file mode 100644
index 000000000000..8243f501a89a
--- /dev/null
+++ b/media-gfx/renderdoc/renderdoc-1.30.ebuild
@@ -0,0 +1,202 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# The swig fork is required for compatibility with both provided and
+# 3rd-party Python scripts. Required patch was sent to upstream in
+# 2014: https://github.com/swig/swig/pull/251
+MY_SWIG_VER=7
+MY_SWIG=swig-${PN}-${MY_SWIG_VER}
+
+AUTOTOOLS_AUTO_DEPEND="no"
+DOCS_BUILDER="sphinx"
+DOCS_DIR="docs"
+PYTHON_COMPAT=( python3_{9..11} )
+inherit autotools cmake flag-o-matic optfeature python-single-r1 docs qmake-utils verify-sig xdg
+
+DESCRIPTION="A stand-alone graphics debugging tool"
+HOMEPAGE="https://renderdoc.org https://github.com/baldurk/renderdoc"
+SRC_URI="
+ https://github.com/baldurk/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ qt5? ( https://github.com/baldurk/swig/archive/${PN}-modified-${MY_SWIG_VER}.tar.gz -> ${MY_SWIG}.tar.gz )
+ verify-sig? ( https://github.com/baldurk/renderdoc/releases/download/v${PV}/v${PV}.tar.gz.asc -> ${P}.tar.gz.asc )
+"
+
+# renderdoc: MIT
+# + cmdline: BSD (not compatible with upstream lib)
+# + farm fresh icons: CC-BY-3.0
+# + half: MIT (not compatible with system dev-libs/half)
+# + include-bin ZLIB (upstream doesn't exist anymore, maintained in tree)
+# + md5: public-domain
+# + plthook: BSD-2
+# + pugixml: MIT
+# + radeon gpu analyzer: MIT
+# + source code pro: OFL-1.1
+# + stb: public-domain
+# + tinyfiledialogs: ZLIB
+# + docs? ( sphinx.paramlinks: MIT )
+# swig: GPL-3+ BSD BSD-2
+LICENSE="BSD BSD-2 CC-BY-3.0 GPL-3+ MIT OFL-1.1 public-domain ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="pyside2 qt5"
+REQUIRED_USE="doc? ( qt5 ) pyside2? ( qt5 ) qt5? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ app-arch/lz4:=
+ app-arch/zstd:=
+ dev-libs/miniz:=
+ >=dev-util/glslang-1.3.231:=
+ x11-libs/libX11
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-keysyms
+ virtual/opengl
+ pyside2? (
+ $(python_gen_cond_dep '
+ dev-python/pyside2[${PYTHON_USEDEP}]
+ ')
+ )
+ qt5? (
+ ${PYTHON_DEPS}
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ )
+"
+DEPEND="${RDEPEND}"
+# qtcore provides qmake, which is required to build the qrenderdoc gui.
+BDEPEND="
+ x11-base/xorg-proto
+ virtual/pkgconfig
+ qt5? (
+ ${AUTOTOOLS_DEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/libpcre
+ dev-qt/qtcore:5
+ sys-devel/bison
+ )
+ verify-sig? ( sec-keys/openpgp-keys-baldurkarlsson )
+"
+
+PATCHES=(
+ # The analytics seem very reasonable, and even without this patch
+ # they are NOT sent before the user accepts. But default the
+ # selection to off, just in case.
+ "${FILESDIR}"/${PN}-1.18-analytics-off.patch
+
+ # Only search for PySide2 if pyside2 USE flag is set.
+ # Bug #833627
+ "${FILESDIR}"/${PN}-1.18-conditional-pyside.patch
+
+ # Pass CXXFLAGS and LDFLAGS through to qmake when qrenderdoc is
+ # built.
+ "${FILESDIR}"/${PN}-1.18-system-flags.patch
+
+ # Needed to prevent sandbox violations during build.
+ "${FILESDIR}"/${PN}-1.27-env-home.patch
+
+ "${FILESDIR}"/${PN}-1.29-r2-system-glslang.patch
+ "${FILESDIR}"/${PN}-1.29-r2-system-compress.patch
+)
+
+DOCS=( util/LINUX_DIST_README )
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/baldurkarlsson.gpg
+
+pkg_setup() {
+ use qt5 && python-single-r1_pkg_setup
+}
+
+src_unpack() {
+ if use verify-sig; then
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.gz{,.asc}
+ fi
+
+ # Do not unpack the swig sources here. CMake will do that if
+ # required.
+ unpack ${P}.tar.gz
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Ensure that we use the system glslang headers instead of the
+ # vendored copy.
+ rm -r renderdoc/3rdparty/glslang || die 'rm vendored glslang failed'
+
+ # Remove the calls to install the documentation files. Instead,
+ # install them with einstalldocs.
+ sed -i '/share\/doc\/renderdoc/d' \
+ "${S}"/CMakeLists.txt "${S}"/qrenderdoc/CMakeLists.txt \
+ || die 'sed remove doc install failed'
+
+ # Assumes that the build directory is "${S}"/build, which it is not.
+ sed -i "s|../build/lib|${BUILD_DIR}/lib|" \
+ "${S}"/docs/conf.py \
+ || die 'sed patch doc sys.path failed'
+
+ # Bug #836235
+ sed -i '/#include <stdarg/i #include <time.h>' \
+ "${S}"/renderdoc/os/os_specific.h \
+ || die 'sed include time.h failed'
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # Build system does not know that this is a tagged release, as
+ # we just have the tarball and not the git repository.
+ -DBUILD_VERSION_STABLE=ON
+
+ -DENABLE_EGL=ON
+ -DENABLE_GL=ON
+ -DENABLE_GLES=ON
+ -DENABLE_PYRENDERDOC=$(usex qt5)
+ -DENABLE_QRENDERDOC=$(usex qt5)
+ -DENABLE_VULKAN=ON
+
+ # Upstream says that this option is unsupported and should not
+ # be used yet.
+ -DENABLE_UNSUPPORTED_EXPERIMENTAL_POSSIBLY_BROKEN_WAYLAND=OFF
+
+ -DENABLE_XCB=ON
+ -DENABLE_XLIB=ON
+
+ # Path to glslang*.cmake.
+ -DGLSLANG_TARGET_DIR="${ESYSROOT}"/usr/$(get_libdir)/cmake
+
+ # renderdoc_capture.json is installed here
+ -DVULKAN_LAYER_FOLDER="${EPREFIX}"/etc/vulkan/implicit_layer.d
+ )
+
+ use qt5 && mycmakeargs+=(
+ -DPython3_EXECUTABLE="${PYTHON}"
+ -DRENDERDOC_SWIG_PACKAGE="${DISTDIR}"/${MY_SWIG}.tar.gz
+
+ # Needed after qtchooser removal, bug #836474.
+ -DQMAKE_QT5_COMMAND="$(qt5_get_bindir)"/qmake
+
+ -DQRENDERDOC_ENABLE_PYSIDE2=$(usex pyside2)
+ )
+
+ use pyside2 && mycmakeargs+=( -DPYTHON_CONFIG_SUFFIX=-${EPYTHON} )
+
+ # Lots of type mismatch issues.
+ filter-lto
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ docs_compile
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "android remote contexts" dev-util/android-tools
+ optfeature "vulkan contexts" media-libs/vulkan-loader
+}