summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2024-03-05 19:23:15 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2024-03-07 09:39:24 +0100
commitfcc5686c0934bb43405ec6be95cbe37c0ed51e55 (patch)
tree007d976b87a42ece1ce93913c9bb4476b55618f9 /media-gfx/libbgcode
parentwww-apps/hugo: add 0.123.7 (diff)
downloadgentoo-fcc5686c0934bb43405ec6be95cbe37c0ed51e55.tar.gz
gentoo-fcc5686c0934bb43405ec6be95cbe37c0ed51e55.tar.bz2
gentoo-fcc5686c0934bb43405ec6be95cbe37c0ed51e55.zip
media-gfx/libbgcode: fix dependencies
Closes: https://bugs.gentoo.org/924385 Signed-off-by: Chris Mayo <aklhfex@gmail.com> Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-gfx/libbgcode')
-rw-r--r--media-gfx/libbgcode/libbgcode-0.0.20240220-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-gfx/libbgcode/libbgcode-0.0.20240220-r1.ebuild b/media-gfx/libbgcode/libbgcode-0.0.20240220-r1.ebuild
new file mode 100644
index 000000000000..d317371d29ee
--- /dev/null
+++ b/media-gfx/libbgcode/libbgcode-0.0.20240220-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+LIBBGCODE_COMMIT=33a1eebfb8e65f333c057c13734f3a838e31d433
+
+DESCRIPTION="Prusa Block & Binary G-code reader / writer / converter"
+HOMEPAGE="https://github.com/prusa3d/libbgcode"
+SRC_URI="https://github.com/prusa3d/libbgcode/archive/${LIBBGCODE_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/${PN}-${LIBBGCODE_COMMIT}"
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/heatshrink-0.4.1
+ >=sys-libs/zlib-1.0
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ test? ( =dev-cpp/catch-2*:0 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DLibBGCode_BUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}