summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBranko Grubic <bitlord0xff@gmail.com>2024-05-27 22:51:22 +0200
committerSam James <sam@gentoo.org>2024-05-28 02:04:30 +0100
commitd265543f19147b95fa12ddb4ad4b131213116400 (patch)
tree708b205c4f6f3d8d3d8bd8495c56f8ed44667162 /media-gfx/hugin
parentsys-apps/moar: add 1.23.15 (diff)
downloadgentoo-d265543f19147b95fa12ddb4ad4b131213116400.tar.gz
gentoo-d265543f19147b95fa12ddb4ad4b131213116400.tar.bz2
gentoo-d265543f19147b95fa12ddb4ad4b131213116400.zip
media-gfx/hugin: Fixes build with boost >=1.85
Closes: https://bugs.gentoo.org/932315 Signed-off-by: Branko Grubic <bitlord0xff@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36855 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/hugin')
-rw-r--r--media-gfx/hugin/files/boost-1.85-932315.patch25
-rw-r--r--media-gfx/hugin/hugin-2023.0.0-r1.ebuild3
2 files changed, 28 insertions, 0 deletions
diff --git a/media-gfx/hugin/files/boost-1.85-932315.patch b/media-gfx/hugin/files/boost-1.85-932315.patch
new file mode 100644
index 000000000000..e8fc5c2daa1f
--- /dev/null
+++ b/media-gfx/hugin/files/boost-1.85-932315.patch
@@ -0,0 +1,25 @@
+# HG changeset patch
+# User tmodes
+# Date 1710260877 -3600
+# Tue Mar 12 17:27:57 2024 +0100
+# Node ID 4d081490b48aaff820cee7601b8624b37b652c06
+# Parent 4b55f17c4e72d6c2f8b4930e3367ff52e1741b45
+Fixed deprecated boost::filesystem::copy_option enum
+
+diff -r 4b55f17c4e72 -r 4d081490b48a src/hugin_base/hugin_utils/filesystem.h
+--- a/src/hugin_base/hugin_utils/filesystem.h Tue Mar 12 17:27:29 2024 +0100
++++ b/src/hugin_base/hugin_utils/filesystem.h Tue Mar 12 17:27:57 2024 +0100
+@@ -64,6 +64,12 @@
+ #endif
+ #include <boost/filesystem.hpp>
+ namespace fs = boost::filesystem;
+- #define OVERWRITE_EXISTING boost::filesystem::copy_option::overwrite_if_exists
++ #if BOOST_VERSION>=107400
++ // in Boost 1.74 and later filesystem::copy_option is deprecated
++ // use filesystem::copy_options instead
++ #define OVERWRITE_EXISTING boost::filesystem::copy_options::overwrite_existing
++ #else
++ #define OVERWRITE_EXISTING boost::filesystem::copy_option::overwrite_if_exists
++ #endif
+ #endif
+ #endif // _HUGIN_UTILS_FILESYSTEM_H
diff --git a/media-gfx/hugin/hugin-2023.0.0-r1.ebuild b/media-gfx/hugin/hugin-2023.0.0-r1.ebuild
index 4587f91ae7d5..40c4d46a93f6 100644
--- a/media-gfx/hugin/hugin-2023.0.0-r1.ebuild
+++ b/media-gfx/hugin/hugin-2023.0.0-r1.ebuild
@@ -62,6 +62,9 @@ pkg_setup() {
}
src_prepare() {
+ # Fix build with boost >=1.85
+ eapply "${FILESDIR}/boost-1.85-932315.patch"
+
sed -i \
-e "/COMMAND.*GZIP/d" \
-e "s/\.gz//g" \