summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-07-29 12:02:37 +0200
committerPacho Ramos <pacho@gentoo.org>2023-07-29 12:13:05 +0200
commit8dd70d61f3f6c73aecf5c36b8026f1f8016a0f8e (patch)
treed208123671502e2201f0906cf6ce3c966c011d8a /media-fonts
parentprofiles: desktop: Set dev-qt/qtmultimedia:5[widgets] by default (diff)
downloadgentoo-8dd70d61f3f6c73aecf5c36b8026f1f8016a0f8e.tar.gz
gentoo-8dd70d61f3f6c73aecf5c36b8026f1f8016a0f8e.tar.bz2
gentoo-8dd70d61f3f6c73aecf5c36b8026f1f8016a0f8e.zip
media-fonts/urw-fonts: add 20230503
New upstream. It uses the latest snapshot as it includes patches other distributions are applying over the older 2020 version. Legacy fonts dropped for now as they add extra complexity to the ebuild, some distros killed them years ago without issues and the reverse deps I have tried still work fine without them. If some old stuff breaks, feel free to report and we will see how to proceed with them. Bug: https://bugs.gentoo.org/589890 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-fonts')
-rw-r--r--media-fonts/urw-fonts/Manifest1
-rw-r--r--media-fonts/urw-fonts/urw-fonts-20230503.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/media-fonts/urw-fonts/Manifest b/media-fonts/urw-fonts/Manifest
index 0742931e8886..fd204fe02ed3 100644
--- a/media-fonts/urw-fonts/Manifest
+++ b/media-fonts/urw-fonts/Manifest
@@ -1 +1,2 @@
DIST urw-fonts-2.4-9.fc13.src.rpm 3198315 BLAKE2B 9f4c026af2ee6b472454be43b4e1d11616770cb63841fe022762f18a7c71abc37e442102a3d54b880a6a34117442cf45b2d65133ef9cca564e55a26ac1179824 SHA512 cd8c9eb9e56480e70129c14cc744b944fe51fc616b8b5da46b7251520c84486c6c4354afdd7517569ba7874255c00b755aace076dc2cf1a1d8bdd30e41322d4b
+DIST urw-fonts-20230503.tar.gz 11194541 BLAKE2B 552de1079ef2dbce3e7fe352ef9f81a5f55fb34d71a11bc25895174804e0ef5b4424981204d46753cf83e014d786c27625ef3389745126e55b7ca1df9d01bc46 SHA512 0d192664a2371a0746b10d639a9140d8620cc99058ff7930b94a8b9bd22a5c858e5315d40dd310de07d1c5eb5015f8132b772682b544ac3cadee56c7de2e7386
diff --git a/media-fonts/urw-fonts/urw-fonts-20230503.ebuild b/media-fonts/urw-fonts/urw-fonts-20230503.ebuild
new file mode 100644
index 000000000000..3def35683df5
--- /dev/null
+++ b/media-fonts/urw-fonts/urw-fonts-20230503.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit font
+
+DESCRIPTION="(URW)++ base 35 font set"
+HOMEPAGE="https://github.com/ArtifexSoftware/urw-base35-fonts"
+COMMIT="3c0ba3b5687632dfc66526544a4e811fe0ec0cd9"
+SRC_URI="https://github.com/ArtifexSoftware/urw-base35-fonts/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+S="${WORKDIR}/urw-base35-fonts-${COMMIT}"
+
+FONT_S="${S}/fonts"
+FONT_SUFFIX="afm otf ttf"
+FONT_PRIORITY="61" # Same as in Fedora
+FONT_CONF=(
+ fontconfig/${FONT_PRIORITY}-urw-bookman.conf
+ fontconfig/${FONT_PRIORITY}-urw-c059.conf
+ fontconfig/${FONT_PRIORITY}-urw-d050000l.conf
+ fontconfig/${FONT_PRIORITY}-urw-fallback-backwards.conf
+ fontconfig/${FONT_PRIORITY}-urw-fallback-generics.conf
+ fontconfig/${FONT_PRIORITY}-urw-fallback-specifics.conf
+ fontconfig/${FONT_PRIORITY}-urw-gothic.conf
+ fontconfig/${FONT_PRIORITY}-urw-nimbus-mono-ps.conf
+ fontconfig/${FONT_PRIORITY}-urw-nimbus-roman.conf
+ fontconfig/${FONT_PRIORITY}-urw-nimbus-sans-narrow.conf
+ fontconfig/${FONT_PRIORITY}-urw-nimbus-sans.conf
+ fontconfig/${FONT_PRIORITY}-urw-p052.conf
+ fontconfig/${FONT_PRIORITY}-urw-standard-symbols-ps.conf
+ fontconfig/${FONT_PRIORITY}-urw-z003.conf
+)
+
+src_prepare() {
+ default
+ cd "${S}"/fontconfig
+ for f in *.conf ; do
+ mv "${f}" "${FONT_PRIORITY}-${f}"
+ done
+}
+
+src_install() {
+ font_src_install
+ insinto /usr/share/metainfo
+ doins appstream/*.xml
+}