summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-11-08 20:06:22 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-11-08 20:07:24 +0200
commit884c5548a2b969f8be9253f53d351a7886450a91 (patch)
treeb3edb445df4b84b191967d261d0636243db21682 /mail-client
parentdev-lang/spidermonkey: switch from llvm-as to "clang -c" (diff)
downloadgentoo-884c5548a2b969f8be9253f53d351a7886450a91.tar.gz
gentoo-884c5548a2b969f8be9253f53d351a7886450a91.tar.bz2
gentoo-884c5548a2b969f8be9253f53d351a7886450a91.zip
mail-client/thunderbird: switch from llvm-as to "clang -c"
Closes: https://bugs.gentoo.org/879177 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/thunderbird/thunderbird-102.4.0.ebuild4
-rw-r--r--mail-client/thunderbird/thunderbird-102.4.2.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/mail-client/thunderbird/thunderbird-102.4.0.ebuild b/mail-client/thunderbird/thunderbird-102.4.0.ebuild
index 50477ea0ed9b..eb9b1b7dc0fe 100644
--- a/mail-client/thunderbird/thunderbird-102.4.0.ebuild
+++ b/mail-client/thunderbird/thunderbird-102.4.0.ebuild
@@ -574,7 +574,7 @@ src_configure() {
have_switched_compiler=yes
fi
AR=llvm-ar
- AS=llvm-as
+ AS="clang -c"
CC=${CHOST}-clang
CXX=${CHOST}-clang++
NM=llvm-nm
@@ -599,7 +599,7 @@ src_configure() {
# Ensure we use correct toolchain
export HOST_CC="$(tc-getBUILD_CC)"
export HOST_CXX="$(tc-getBUILD_CXX)"
- tc-export CC CXX LD AR NM OBJDUMP RANLIB PKG_CONFIG
+ tc-export CC CXX LD AR AS NM OBJDUMP RANLIB PKG_CONFIG
# Pass the correct toolchain paths through cbindgen
if tc-is-cross-compiler ; then
diff --git a/mail-client/thunderbird/thunderbird-102.4.2.ebuild b/mail-client/thunderbird/thunderbird-102.4.2.ebuild
index 0eb9f754ddff..831f69b6d8f2 100644
--- a/mail-client/thunderbird/thunderbird-102.4.2.ebuild
+++ b/mail-client/thunderbird/thunderbird-102.4.2.ebuild
@@ -574,7 +574,7 @@ src_configure() {
have_switched_compiler=yes
fi
AR=llvm-ar
- AS=llvm-as
+ AS="clang -c"
CC=${CHOST}-clang
CXX=${CHOST}-clang++
NM=llvm-nm
@@ -599,7 +599,7 @@ src_configure() {
# Ensure we use correct toolchain
export HOST_CC="$(tc-getBUILD_CC)"
export HOST_CXX="$(tc-getBUILD_CXX)"
- tc-export CC CXX LD AR NM OBJDUMP RANLIB PKG_CONFIG
+ tc-export CC CXX LD AR AS NM OBJDUMP RANLIB PKG_CONFIG
# Pass the correct toolchain paths through cbindgen
if tc-is-cross-compiler ; then