summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-25 15:52:30 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-25 16:52:15 +0200
commit8d1d62c64b66bfce3107bc20b3cedf8e189bac82 (patch)
tree87be3b570a957c50e3f8972c0e2ec6fda11ccfc3 /kde-plasma/plasma-nm
parentnet-misc/smb4k: Drop 3.0.0-r1 (diff)
downloadgentoo-8d1d62c64b66bfce3107bc20b3cedf8e189bac82.tar.gz
gentoo-8d1d62c64b66bfce3107bc20b3cedf8e189bac82.tar.bz2
gentoo-8d1d62c64b66bfce3107bc20b3cedf8e189bac82.zip
kde-plasma: Add KDE Plasma 5.16.2
Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-nm')
-rw-r--r--kde-plasma/plasma-nm/Manifest1
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.16.2.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/Manifest b/kde-plasma/plasma-nm/Manifest
index 838a41abe5d0..69791225f3b3 100644
--- a/kde-plasma/plasma-nm/Manifest
+++ b/kde-plasma/plasma-nm/Manifest
@@ -1,2 +1,3 @@
DIST plasma-nm-5.15.5.tar.xz 777140 BLAKE2B d75ad6c04587f5bc115268f2bef50e0f6dd2b8b86957ab1f43e284988039fb7d9530cb03d86f5c49bdf6747bbb6ad123c7bc527643fe7461ed91efc93c63e563 SHA512 f3f78f40b754de5afbd63c5713e684fe3d37ae25af5a9e6ba808647e0d7d4f23456ed4b94aa8138e1fab99e7f7d7e0dffb697e0e46c99bd312bad5e2a7b9833f
DIST plasma-nm-5.16.1.tar.xz 783080 BLAKE2B 2786f050893480b38e6008bccede00ce4b397aa4aa76721d62b2732a72ca4ee9a3009f2e1ad85bac8b6931385f657380e20d2c55f1e53f609240fcde75246949 SHA512 536eb45c4f6621a266f128717728f91b10cc0ab9ce583e574dd1eb082e65ffaf543aee11c273d40cbafa7cd215fabba52978dfc1c6507bd7dc8ce621685629de
+DIST plasma-nm-5.16.2.tar.xz 784788 BLAKE2B 99bdb59638fd5024e3caa23347552af8cef4949b52d24e1b7a22216fc9244c35a6211ed5bd644ef8e8678b7270d4e23c7d94721faba9bb4d419370a7ee4a0fed SHA512 e8f6cfdeb2545c813c6d312f3a6d1f102905bdaf4728cd89da078f2c468fb53bf1788db113a85844b5d06571e8d776290dc8401330041220e45cc21987596fcc
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.16.2.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.16.2.ebuild
new file mode 100644
index 000000000000..995f4b6b6b89
--- /dev/null
+++ b/kde-plasma/plasma-nm/plasma-nm-5.16.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="KDE Plasma applet for NetworkManager"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="modemmanager openconnect teamd"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep networkmanager-qt 'teamd=')
+ $(add_frameworks_dep plasma)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ >=app-crypt/qca-2.1.1:2[qt5(+)]
+ net-misc/networkmanager[teamd=]
+ modemmanager? (
+ $(add_frameworks_dep modemmanager-qt)
+ $(add_qt_dep qtxml)
+ net-misc/mobile-broadband-provider-info
+ )
+ openconnect? (
+ $(add_qt_dep qtxml)
+ net-vpn/networkmanager-openconnect
+ net-vpn/openconnect:=
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_MODEMMANAGER_SUPPORT=$(usex !modemmanager)
+ $(cmake-utils_use_find_package modemmanager KF5ModemManagerQt)
+ $(cmake-utils_use_find_package openconnect OpenConnect)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-plasma/plasma-workspace:5"; then
+ elog "${PN} is not terribly useful without kde-plasma/plasma-workspace:5."
+ elog "However, the networkmanagement KCM can be called from either systemsettings"
+ elog "or manually: $ kcmshell5 kcm_networkmanagement"
+ fi
+}