summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-12 14:15:08 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-12 14:15:49 +0100
commit422daa2f216e7442fa74759e58761083afe150b2 (patch)
treec87945f5e4c64780d78e5599e48c58237173e5af /kde-plasma/plasma-nm
parentsys-devel/clang-runtime: Bump to 8.0.0rc5 (diff)
downloadgentoo-422daa2f216e7442fa74759e58761083afe150b2.tar.gz
gentoo-422daa2f216e7442fa74759e58761083afe150b2.tar.bz2
gentoo-422daa2f216e7442fa74759e58761083afe150b2.zip
kde-plasma: Add KDE Plasma 5.15.3
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'kde-plasma/plasma-nm')
-rw-r--r--kde-plasma/plasma-nm/Manifest1
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.15.3.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/Manifest b/kde-plasma/plasma-nm/Manifest
index 9e0c804616b5..1eaa908e66f0 100644
--- a/kde-plasma/plasma-nm/Manifest
+++ b/kde-plasma/plasma-nm/Manifest
@@ -1,2 +1,3 @@
DIST plasma-nm-5.14.5.tar.xz 721144 BLAKE2B f9537e742be74b50ffeecee007ef91d93d108b566cf081cb4d25bc4d62c98847a74e7e69ec01b2f10e4e75eac4bc75cef90a3a47ad5ad199cec9f20c31bdaf20 SHA512 54667ff01db16bfadc1663dcf51668aed4eabcb70c3903538044bb478aeb4625d27777df13867cdf03048b6575a540de5c7baaef9e2dc2c41f458d2800daba96
DIST plasma-nm-5.15.2.tar.xz 771292 BLAKE2B 940ec6086fb483a569c3633c1335d58848c6aa7d83eed0290fcd9947dec1b648394261f2b930d4427bd7ee92cc46a2b56ef813bcd73f374350667f0968a461e6 SHA512 aa4635bb40b2e25715ab3f393f1a466403cb2a2154aa64230b9eac93de6cb7c71c7e93b20881e02993359bd2ed4451d2f881882ec3a0bc537db77c4190eeaa45
+DIST plasma-nm-5.15.3.tar.xz 771904 BLAKE2B dc25cfe840797442e64a0033e9982f7fc26919c5d33d0d7a16e5ea661256bd50f59fb7f52ef89da0f806e47dbb654cf019f5457667c0d111b4971cf7d92cf674 SHA512 357d8fac2e13daee846d685de28f79de9bc95b159dd9fcc2b960b4af37f3838f1c8682c694430999f175bd88a096d927622b407db541f75cfa07d9c1e3339637
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.15.3.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.15.3.ebuild
new file mode 100644
index 000000000000..995f4b6b6b89
--- /dev/null
+++ b/kde-plasma/plasma-nm/plasma-nm-5.15.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="KDE Plasma applet for NetworkManager"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="modemmanager openconnect teamd"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep networkmanager-qt 'teamd=')
+ $(add_frameworks_dep plasma)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ >=app-crypt/qca-2.1.1:2[qt5(+)]
+ net-misc/networkmanager[teamd=]
+ modemmanager? (
+ $(add_frameworks_dep modemmanager-qt)
+ $(add_qt_dep qtxml)
+ net-misc/mobile-broadband-provider-info
+ )
+ openconnect? (
+ $(add_qt_dep qtxml)
+ net-vpn/networkmanager-openconnect
+ net-vpn/openconnect:=
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_MODEMMANAGER_SUPPORT=$(usex !modemmanager)
+ $(cmake-utils_use_find_package modemmanager KF5ModemManagerQt)
+ $(cmake-utils_use_find_package openconnect OpenConnect)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-plasma/plasma-workspace:5"; then
+ elog "${PN} is not terribly useful without kde-plasma/plasma-workspace:5."
+ elog "However, the networkmanagement KCM can be called from either systemsettings"
+ elog "or manually: $ kcmshell5 kcm_networkmanagement"
+ fi
+}