summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-05-01 19:58:26 +0200
committerJohannes Huber <johu@gentoo.org>2018-05-01 20:03:50 +0200
commitc785928c12e0c416551c28f7bd3f889f9d73d100 (patch)
treee4fee8436ce85a53d26792d85d049c1453cbf176 /kde-plasma/plasma-integration
parentkde-plasma: Version bump KDE Plasma 5.12.5 (diff)
downloadgentoo-c785928c12e0c416551c28f7bd3f889f9d73d100.tar.gz
gentoo-c785928c12e0c416551c28f7bd3f889f9d73d100.tar.bz2
gentoo-c785928c12e0c416551c28f7bd3f889f9d73d100.zip
kde-plasma: Remove KDE Plasma 5.12.4
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/files/plasma-integration-5.12.4-remote-dir-selection.patch62
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.12.4-r1.ebuild45
3 files changed, 0 insertions, 108 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index 362ffd55a338..7c566051fe50 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,3 +1,2 @@
DIST plasma-integration-5.11.5.tar.xz 55856 BLAKE2B 4c1d56f9de0007d369eeca5f7a992f95ac9a7853ad30f80b86a762b2ba88a5c87cd0861590e640466314edc4436052063be7e9718754a73388eb60baa253285f SHA512 2e14b0bae19e344dd0ddd27b48ddf9f9075b773c295b58a35b05d0c9d11c1573821ec1c25ae33da4e3a4091386301aef15c51f4d1163aa195a1de5f3ea1844c4
-DIST plasma-integration-5.12.4.tar.xz 53488 BLAKE2B 47b20e5fbf6e340882cc9a610828df3a4c404f9cd496400356e1941128136eb4d402f725959a8734225e9ede98995efa2ff3a883f9913e36a5ab86246241cbcf SHA512 4bbdecf88425459dc10dcae96b2d4aef8d63b7a3c9c6c6ce39b7815881007b580dcada974636f2549ee79aa106512c89b4a4b3ce22c4ef78af63276d9bf06810
DIST plasma-integration-5.12.5.tar.xz 53664 BLAKE2B e37d44a0a33116ab1b2b1f1edb74a8616ba33aa41438b93f9bf2f45abe5bb49cda57a579b35b8af94a171074387178888f5b80909e50e9c2be4a7a11a1eb0198 SHA512 5ae667a11ea85c6e9f353939bc22d84c36cbb53f053244a93e7c1d185d20452a7fc3d2afed65427ef938910fa537648006c2dda77346419a6a4492a2e292c787
diff --git a/kde-plasma/plasma-integration/files/plasma-integration-5.12.4-remote-dir-selection.patch b/kde-plasma/plasma-integration/files/plasma-integration-5.12.4-remote-dir-selection.patch
deleted file mode 100644
index a3c6d931e2b7..000000000000
--- a/kde-plasma/plasma-integration/files/plasma-integration-5.12.4-remote-dir-selection.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From bfd41a95530f90ee8d44cbcfd1fa8c62978334a2 Mon Sep 17 00:00:00 2001
-From: Alex Richardson <Alexander.Richardson@cl.cam.ac.uk>
-Date: Sun, 8 Apr 2018 11:06:32 +0100
-Subject: KDEPlatformFileDialog: Fix initial directory selection for remote
- files
-
-Summary:
-Previously KDEPlatformFileDialogHelper::selectFile() would change
-options()->initialDirectory() unconditionally even if it was already
-set by the QFileDialog code. Since Qt 5.7.1 it is no longer necessary
-to derive initialDirectory from the selectFile() call. In fact it is
-actuall harmful since it will now override the correct initial directory
-that was set by Qt. Without this patch I got the following debug output:
-
-```
-KDEPlatformFileDialogHelper::setDirectory QUrl("sftp://server/home/alr48/cheri/build_sdk.sh")
-KDEPlatformFileDialogHelper::setDirectory QUrl("sftp://server/home/alr48/cheri/build_sdk.sh")
-KDEPlatformFileDialogHelper::selectFile QUrl("file:///home/alex/build_sdk.sh")
-KDEPlatformFileDialogHelper::setDirectory QUrl("file:///home/alex/)
-```
-The final setDirectory() call is actually a call to
-`setDirectory(options->initialDirectory())` which was set in `selectFile()`.
-
-We now depend on Qt 5.9 so we can remove this code without a check for
-version >= 5.7.1.
-
-BUG: 374913
-
-Test Plan: Remote directory is now opened correctly (tested with Qt 5.10.0)
-
-Reviewers: #plasma, elvisangelaccio
-
-Reviewed By: elvisangelaccio
-
-Subscribers: ngraham, krzyc, anthonyfieroni, elvisangelaccio, graesslin, plasma-devel
-
-Tags: #plasma
-
-Differential Revision: https://phabricator.kde.org/D4193
----
- src/platformtheme/kdeplatformfiledialoghelper.cpp | 5 -----
- 1 file changed, 5 deletions(-)
-
-diff --git a/src/platformtheme/kdeplatformfiledialoghelper.cpp b/src/platformtheme/kdeplatformfiledialoghelper.cpp
-index 1a2b1b5..d4ea0cd 100644
---- a/src/platformtheme/kdeplatformfiledialoghelper.cpp
-+++ b/src/platformtheme/kdeplatformfiledialoghelper.cpp
-@@ -409,11 +409,6 @@ QUrl KDEPlatformFileDialogHelper::directory() const
- void KDEPlatformFileDialogHelper::selectFile(const QUrl &filename)
- {
- m_dialog->selectFile(filename);
--
-- // Qt 5 at least <= 5.8.0 does not derive the directory from the passed url
-- // and set the initialDirectory option accordingly, also not for known schemes
-- // like file://, so we have to do it ourselves
-- options()->setInitialDirectory(m_dialog->directory());
- }
-
- void KDEPlatformFileDialogHelper::setDirectory(const QUrl &directory)
---
-cgit v0.11.2
-
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.12.4-r1.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.12.4-r1.ebuild
deleted file mode 100644
index d9391f82d7d3..000000000000
--- a/kde-plasma/plasma-integration/plasma-integration-5.12.4-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-VIRTUALX_REQUIRED="test"
-inherit kde5
-
-DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
-LICENSE="LGPL-2+"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE=""
-
-DEPEND="
- $(add_frameworks_dep kcompletion)
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kconfigwidgets)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep kiconthemes)
- $(add_frameworks_dep kio)
- $(add_frameworks_dep kjobwidgets)
- $(add_frameworks_dep knotifications)
- $(add_frameworks_dep kwayland)
- $(add_frameworks_dep kwidgetsaddons)
- $(add_frameworks_dep kwindowsystem)
- $(add_frameworks_dep kxmlgui)
- $(add_plasma_dep breeze)
- $(add_qt_dep qtdbus)
- $(add_qt_dep qtgui 'dbus' '' '5=')
- $(add_qt_dep qtquickcontrols2)
- $(add_qt_dep qtwidgets)
- $(add_qt_dep qtx11extras)
- x11-libs/libXcursor
- x11-libs/libxcb
-"
-RDEPEND="${DEPEND}
- media-fonts/hack
- media-fonts/noto
-"
-
-# requires running kde environment
-RESTRICT+=" test"
-
-PATCHES=( "${FILESDIR}/${P}-remote-dir-selection.patch" )