summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-02 12:18:30 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-02 18:46:41 +0200
commit9d18a4c7e3200a773f3d1495ed6858c89d6bfa6b (patch)
tree9359cd6a3ff3e26249ec02349c85fc520f4eac25 /kde-plasma/ksshaskpass
parentkde-plasma/kscreenlocker: 5.22.5 version bump (diff)
downloadgentoo-9d18a4c7e3200a773f3d1495ed6858c89d6bfa6b.tar.gz
gentoo-9d18a4c7e3200a773f3d1495ed6858c89d6bfa6b.tar.bz2
gentoo-9d18a4c7e3200a773f3d1495ed6858c89d6bfa6b.zip
kde-plasma/ksshaskpass: 5.22.5 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.22.5.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 9f386c4aba00..9da9007ff282 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.21.5.tar.xz 24148 BLAKE2B 8cae47375a883948cfff373b1bf113359ce4c1d548c982dc6c9d8a9a28c16661813c1d8077f463a6ec1dc80c69b2736391c56382bf3ff2b7d2f3da24d6e64f2b SHA512 c342723383d13b8df977bb4ab3c6b50c15007d12fdd27c0e51ad41cf77bbc5ddae404a9fe10669ea22933140a55bc293e7296d8e3e488cbce36158475403d7ff
DIST ksshaskpass-5.22.4.tar.xz 24088 BLAKE2B 9a7c2a5e52d5cd166ac03dcf91f36af3b7bc6c55b1225293c6ba2c8252132ca75a9d54d3f28c9264403f8c5598bccaf29628e6c7c1b620782993e6b551b56a40 SHA512 529ff46dc3398e954b2a885fbe14c735b7ff2eb3827797dfb27708624cb5b3aa85064f2ff2924167db80c7515b6a70f1cf1c7fb72f5aabe6d4beb9e5f8a9c1d4
+DIST ksshaskpass-5.22.5.tar.xz 24076 BLAKE2B 2625d07b18b5e1ccd98f5b34e402a4ea201190f3be240ea596e8b4c70f0a15204e7d5ea559a0b17bc253247eca41a988f65bb2e29ee07c2e35600d8a1f761b34 SHA512 35f430882aa735f1b9d7a1874f83fa67074cfb720bbba377d0b38baab2f3eaeddc1598f6f7b9c79479b95d22fdc661d7dfd6835b98a78ea159c68d64abc81a67
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.22.5.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.22.5.ebuild
new file mode 100644
index 000000000000..5d53a4f81076
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.22.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.82.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 5,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+
+ # Clean up pre-5.17.4 dirs
+ rmdir -v "${EROOT}"/etc/plasma{/startup,} 2> /dev/null
+}