summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-15 14:28:05 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-15 14:46:30 +0100
commit8c924e2dfea18dde4f21ecf59cea227c7802acf0 (patch)
tree39ca6865ad85b1db40dec2f71b31f777e734f3e1 /kde-frameworks
parentkde-frameworks/kimageformats: Patchset with various kf5 branch fixes (diff)
downloadgentoo-8c924e2dfea18dde4f21ecf59cea227c7802acf0.tar.gz
gentoo-8c924e2dfea18dde4f21ecf59cea227c7802acf0.tar.bz2
gentoo-8c924e2dfea18dde4f21ecf59cea227c7802acf0.zip
kde-frameworks/kio: KFilePlacesItem: Use Solid to find home mount point
See also: https://invent.kde.org/frameworks/kio/-/merge_requests/1722 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/kio/files/kio-5.116.0-use-solid-for-home-mountpoint.patch38
-rw-r--r--kde-frameworks/kio/kio-5.116.0-r3.ebuild101
2 files changed, 139 insertions, 0 deletions
diff --git a/kde-frameworks/kio/files/kio-5.116.0-use-solid-for-home-mountpoint.patch b/kde-frameworks/kio/files/kio-5.116.0-use-solid-for-home-mountpoint.patch
new file mode 100644
index 000000000000..9dcfc45b3aa5
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-5.116.0-use-solid-for-home-mountpoint.patch
@@ -0,0 +1,38 @@
+From 93f53971adfbb9269b589fcce268560b49cd1f83 Mon Sep 17 00:00:00 2001
+From: Kai Uwe Broulik <kai.uwe.broulik@basyskom.com>
+Date: Thu, 19 Sep 2024 12:10:32 +0000
+Subject: [PATCH] KFilePlacesItem: Use Solid to find home mount point
+
+KMountPoints potentially parses MTAB which can be slow.
+Instead, use Solid which already has a cache of all the devices.
+
+The impact on a typical system is negligible but real-world
+testing on a system with lots of network shares showed a
+speed-up of over 80% in this code path.
+
+Signed-off-by: Kiriakos Antoniadis <kiriakos.antoniadis@advantest.com>
+
+(cherry picked from commit b5d45a857e6fdb3fb7b08e44753eef203ea605c6)
+---
+ src/filewidgets/kfileplacesitem.cpp | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/src/filewidgets/kfileplacesitem.cpp b/src/filewidgets/kfileplacesitem.cpp
+index 4aa562a4f9..3af8a0f1d4 100644
+--- a/src/filewidgets/kfileplacesitem.cpp
++++ b/src/filewidgets/kfileplacesitem.cpp
+@@ -531,8 +531,9 @@ void KFilePlacesItem::onAccessibilityChanged(bool isAccessible)
+ if (m_access->filePath() == QDir::rootPath()) {
+ m_isTeardownAllowed = false;
+ } else {
+- KMountPoint::Ptr mountPoint = KMountPoint::currentMountPoints().findByPath(QDir::homePath());
+- if (mountPoint && m_access->filePath() == mountPoint->mountPoint()) {
++ const auto homeDevice = Solid::Device::storageAccessFromPath(QDir::homePath());
++ const auto *homeAccess = homeDevice.as<Solid::StorageAccess>();
++ if (homeAccess && m_access->filePath() == homeAccess->filePath()) {
+ m_isTeardownAllowed = false;
+ }
+ }
+--
+GitLab
+
diff --git a/kde-frameworks/kio/kio-5.116.0-r3.ebuild b/kde-frameworks/kio/kio-5.116.0-r3.ebuild
new file mode 100644
index 000000000000..a3b7804f211c
--- /dev/null
+++ b/kde-frameworks/kio/kio-5.116.0-r3.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_DESIGNERPLUGIN="true"
+ECM_HANDBOOK="optional"
+ECM_HANDBOOK_DIR="docs"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org xdg-utils
+
+DESCRIPTION="Framework providing transparent file and data management"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="acl kerberos +kwallet X"
+
+# tests hang
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5[ssl]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ =kde-frameworks/kauth-${PVCUT}*:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kbookmarks-${PVCUT}*:5
+ =kde-frameworks/kcodecs-${PVCUT}*:5
+ =kde-frameworks/kcompletion-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kcrash-${PVCUT}*:5
+ =kde-frameworks/kdbusaddons-${PVCUT}*:5
+ =kde-frameworks/kguiaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kitemviews-${PVCUT}*:5
+ =kde-frameworks/kjobwidgets-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/ktextwidgets-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5[X?]
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
+ =kde-frameworks/solid-${PVCUT}*:5
+ sys-power/switcheroo-control
+ acl? (
+ sys-apps/attr
+ virtual/acl
+ )
+ handbook? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ =kde-frameworks/kdoctools-${PVCUT}*:5
+ )
+ kerberos? ( virtual/krb5 )
+ kwallet? ( =kde-frameworks/kwallet-${PVCUT}*:5 )
+ X? ( >=dev-qt/qtx11extras-${QTMIN}:5 )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ test? ( sys-libs/zlib )
+"
+RDEPEND="${COMMON_DEPEND}
+ || (
+ kde-apps/kio-extras:6
+ kde-frameworks/kio-trash-desktop-file:5
+ )
+"
+PDEPEND=">=kde-frameworks/kded-${PVCUT}:5"
+
+PATCHES=( "${FILESDIR}/${P}-use-solid-for-home-mountpoint.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DKF6_COMPAT_BUILD=ON
+ -DKIO_NO_PUBLIC_QTCONCURRENT=ON
+ $(cmake_use_find_package acl ACL)
+ $(cmake_use_find_package kerberos GSSAPI)
+ $(cmake_use_find_package kwallet KF5Wallet)
+ -DWITH_X11=$(usex X)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ ecm_pkg_postrm
+ xdg_desktop_database_update
+}