summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-17 00:24:39 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-17 08:09:45 +0200
commitf573d19bc059eacd037d2ea656b67e14dcaafa2d (patch)
tree3abe7b53ee35cfb7527bdfc70b129ee28a63802d /kde-frameworks/kwallet
parentkde-misc/latte-dock: 0.8.8 version bump (diff)
downloadgentoo-f573d19bc059eacd037d2ea656b67e14dcaafa2d.tar.gz
gentoo-f573d19bc059eacd037d2ea656b67e14dcaafa2d.tar.bz2
gentoo-f573d19bc059eacd037d2ea656b67e14dcaafa2d.zip
kde-frameworks: Add KDE Frameworks 5.57.0
Package-Manager: Portage-2.3.63, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kwallet')
-rw-r--r--kde-frameworks/kwallet/Manifest1
-rw-r--r--kde-frameworks/kwallet/kwallet-5.57.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/Manifest b/kde-frameworks/kwallet/Manifest
index ddedc68dea9c..e455efab9d65 100644
--- a/kde-frameworks/kwallet/Manifest
+++ b/kde-frameworks/kwallet/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-5.54.0.tar.xz 307696 BLAKE2B 9d1f8b719edcd708b780127ea5294abe8c3e2bb4081eaabefb28fce787cdd8b528aee37ff661744b0db1b33d586f022f94f15d2717428ce24238699147985d67 SHA512 f30ceda97180a562853923a0ad1cefbadbed51bbbf4b29405bbe85ccae3dc815053903367ba3638e7a7293eda7fbb7df88f527d6176fc6c2286088c38ce0069a
DIST kwallet-5.56.0.tar.xz 307700 BLAKE2B 747f1196c4223f515a133c63f066744d8a384e9a05bb768fb842dccbda002bce0a7fb7581fd1bd69330ba4dbde646d096eb8348182b7e0a43e53a9bee0235ce8 SHA512 29a6699e490b3f8289cc983f14b2e99f1d157e68b2310f02cf2d2dc888ae5d6ed3029029cff0cbe3b9ccc2d5d36a9271e0826fcbc62a297fc40f30171ff8fa13
+DIST kwallet-5.57.0.tar.xz 308036 BLAKE2B d2da2e0bf99b455946973dd7ec00008affdf31abd03d5eae0509383c2309ce3d5d86ec65d8a9757d15ea04269525296ce9ffc505ba3f669a012e33463465fac3 SHA512 7a3809d6563dbd46c1a8de6f9fe7f1665ede884430ac83782cfed4e02f4fc9ecd275293f8c09463a42054d071a545308c8353ddb447e8b0acab5a9c6e47966f2
diff --git a/kde-frameworks/kwallet/kwallet-5.57.0.ebuild b/kde-frameworks/kwallet/kwallet-5.57.0.ebuild
new file mode 100644
index 000000000000..817d760a27ff
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-5.57.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="gpg +man"
+
+BDEPEND="
+ man? ( $(add_frameworks_dep kdoctools) )
+"
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dev-libs/libgcrypt:0=
+ gpg? ( >=app-crypt/gpgme-1.7.1[cxx,qt5] )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package gpg Gpgmepp)
+ $(cmake-utils_use_find_package man KF5DocTools)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ if ! has_version "kde-plasma/kwallet-pam" || ! has_version "kde-apps/kwalletmanager:5" ; then
+ elog
+ elog "Install kde-plasma/kwallet-pam for auto-unlocking after account login."
+ elog "Install kde-apps/kwalletmanager:5 to manage your kwallet."
+ elog
+ fi
+ if has_version "kde-apps/kwalletd"; then
+ elog "Starting with 5.34.0-r1, ${PN} is able to serve applications"
+ elog "that still require old kwalletd4. After migration has finished,"
+ elog "kde-apps/kwalletd can be removed."
+ fi
+ elog "For more information, read https://wiki.gentoo.org/wiki/KDE#KWallet"
+}