summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-15 12:12:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-15 13:58:34 +0100
commitb5f0806e00fadca2d0c9819e9ab46b0d4c2da58f (patch)
tree651d11303c1a4fdb7aae0dd382ce043ffb840404 /kde-frameworks/kdesu/kdesu-5.65.0.ebuild
parentapp-emulation/qemu: bump up to 4.2.0, bug #702036 (diff)
downloadgentoo-b5f0806e00fadca2d0c9819e9ab46b0d4c2da58f.tar.gz
gentoo-b5f0806e00fadca2d0c9819e9ab46b0d4c2da58f.tar.bz2
gentoo-b5f0806e00fadca2d0c9819e9ab46b0d4c2da58f.zip
kde-frameworks: Add KDE Frameworks 5.65
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kdesu/kdesu-5.65.0.ebuild')
-rw-r--r--kde-frameworks/kdesu/kdesu-5.65.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-frameworks/kdesu/kdesu-5.65.0.ebuild b/kde-frameworks/kdesu/kdesu-5.65.0.ebuild
new file mode 100644
index 000000000000..d4abf139a139
--- /dev/null
+++ b/kde-frameworks/kdesu/kdesu-5.65.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-2)
+inherit ecm kde.org
+
+DESCRIPTION="Framework to handle super user actions"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="X"
+
+RDEPEND="
+ >=kde-frameworks/kconfig-${PVCUT}:5
+ >=kde-frameworks/kcoreaddons-${PVCUT}:5
+ >=kde-frameworks/ki18n-${PVCUT}:5
+ >=kde-frameworks/kpty-${PVCUT}:5
+ >=kde-frameworks/kservice-${PVCUT}:5
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package X X11)
+ )
+
+ ecm_src_configure
+}