summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-07-14 13:46:10 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-14 13:46:10 +0200
commit82d39affe7c0394f58b7dbda11a4df2d233e86d1 (patch)
tree0c87d649221962703f877bfcae356c45a4d72b6c /kde-frameworks/kcompletion
parentkde-apps/kde-dev-utils: Fix build with KF-5.48 (diff)
downloadgentoo-82d39affe7c0394f58b7dbda11a4df2d233e86d1.tar.gz
gentoo-82d39affe7c0394f58b7dbda11a4df2d233e86d1.tar.bz2
gentoo-82d39affe7c0394f58b7dbda11a4df2d233e86d1.zip
kde-frameworks: Add KDE Frameworks 5.48
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'kde-frameworks/kcompletion')
-rw-r--r--kde-frameworks/kcompletion/Manifest1
-rw-r--r--kde-frameworks/kcompletion/kcompletion-5.48.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/kde-frameworks/kcompletion/Manifest b/kde-frameworks/kcompletion/Manifest
index b0be2276a646..9b4ee44597a0 100644
--- a/kde-frameworks/kcompletion/Manifest
+++ b/kde-frameworks/kcompletion/Manifest
@@ -1,2 +1,3 @@
DIST kcompletion-5.46.0.tar.xz 115636 BLAKE2B 282461dcd9c29ced94f43ef3c5f3b345669a0c3cb70e0c37b3292146ad9e050e9880aafcd8d33b95dd74abffd1e51597a888842231e24c194e65fa34ad143913 SHA512 7c958ba845a89745472ae8c40c95f43f78fbab420c394b81014335f004d3b40f7c4f44263cd5b99c5a448fde99e3f9da607fe01f539eba18a68a28c88d4b0d27
DIST kcompletion-5.47.0.tar.xz 115524 BLAKE2B ff5d2f3ae3cc3a89006b1889db4c3f2046fcb5ea4b033d38bd7078020280a46275128b37beeca7ad6f863d44356f1aa5945ca45ce8914e549effaa591a38fe5b SHA512 8d5d74f7f312466ad2898bbd8c40512e53a0e5d86883fd99429f29be52dd4b80c7b4e539ed07a08d8e9bdfc4a4b61fd6822a36b31159c8aaa47eb1fcbd379204
+DIST kcompletion-5.48.0.tar.xz 115688 BLAKE2B b5c9cb15c61c93926ccc50314dc084c78d511ac4df2aacf1096c43d3116f0117062762d71af678def63ac4ae7ed990b089b7aeb4513b90d6350070b05ab36a5d SHA512 efd00a2ec90acc14bd717a1fca375da9741386e346aebb47eb41d65552675d2a7834763d5362190c0c8b8918b0e9a1eea25c37f72b2bc7c3734aa1e28ae44a99
diff --git a/kde-frameworks/kcompletion/kcompletion-5.48.0.ebuild b/kde-frameworks/kcompletion/kcompletion-5.48.0.ebuild
new file mode 100644
index 000000000000..89c636704e5b
--- /dev/null
+++ b/kde-frameworks/kcompletion/kcompletion-5.48.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for common completion tasks such as filename or URL completion"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"