summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-11-14 13:33:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-11-14 15:16:21 +0100
commit4e8c5ecc54af6df0f17f0fa99be0ab893db3fe2d (patch)
tree42cc600982eb31ccb88d2cc8a61f76a6849a2a56 /kde-frameworks/frameworkintegration
parentdev-python/pyotherside: add 1.6.0 (diff)
downloadgentoo-4e8c5ecc54af6df0f17f0fa99be0ab893db3fe2d.tar.gz
gentoo-4e8c5ecc54af6df0f17f0fa99be0ab893db3fe2d.tar.bz2
gentoo-4e8c5ecc54af6df0f17f0fa99be0ab893db3fe2d.zip
kde-frameworks/frameworkintegration: 5.100.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.100.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 6c881890cc16..1d1284251439 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
+DIST frameworkintegration-5.100.0.tar.xz 1759992 BLAKE2B 78763937667e22c352356b43c50dc48bd6c658dd8cc475ec98ce7d0e180e7c30bde48d88924ed7bf65bdbf634dd46aaf22d9be02e7a2fc1017bfb1dbd74fd529 SHA512 f99bfbb8476bd3b14c6611f8557b000257c1464b6c21dcbbb1e69f27e8371f64e45ea4f2817b8c3514de13c9e69888dbad905e7d3ed8f1b4cac82c3205f9a873
DIST frameworkintegration-5.96.0.tar.xz 1759604 BLAKE2B 24d4806432487e35e01645da97195f700e086c68c6d2f39e7e5e86d00f10a982224fff2fa2eb7d7808fadad4d7524fd2318f67f8d47759e2533a261aa8589470 SHA512 cdc521ff7ba5d3c37d239fb7575a8c1e5b66b1bcba9e315da857b3ddd25b9a7cabc3dc0338186b23b9606badef7c7153c117b92618b626eb54b95c540cc2e680
DIST frameworkintegration-5.99.0.tar.xz 1760344 BLAKE2B 7f7802fb0b3e552bfde6815d4159b1b89fea03e2032eb139a9ed1cf46196d0668131ebac1d6315bf41ae061f565641dfdb04fa72c7db0547221660fe53f1d865 SHA512 3799ea9587d2c7d2e869a094ccc9a420cb8b1fdbf263d5dd3c4b186464bf34457ac9f91eb469c612f75a6f5235407bd2f52aa9927f447327147ccb6f2c5cdc20
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.100.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.100.0.ebuild
new file mode 100644
index 000000000000..e4e34fce95e5
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.100.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}