summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-08-17 20:21:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-08-17 20:58:09 +0200
commitc1063afea17a29bb75dbbbf0121fa5c8ad948574 (patch)
treec62ccf9ec787742c39c2afd14ac1198894802629 /kde-apps/kolourpaint
parentmedia-libs/libqaccessibilityclient: New package (diff)
downloadgentoo-c1063afea17a29bb75dbbbf0121fa5c8ad948574.tar.gz
gentoo-c1063afea17a29bb75dbbbf0121fa5c8ad948574.tar.bz2
gentoo-c1063afea17a29bb75dbbbf0121fa5c8ad948574.zip
kde-apps: Add KDE Applications 17.08.0
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'kde-apps/kolourpaint')
-rw-r--r--kde-apps/kolourpaint/Manifest1
-rw-r--r--kde-apps/kolourpaint/kolourpaint-17.08.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-apps/kolourpaint/Manifest b/kde-apps/kolourpaint/Manifest
index f53ea1fbec5b..4ed89850b2aa 100644
--- a/kde-apps/kolourpaint/Manifest
+++ b/kde-apps/kolourpaint/Manifest
@@ -1 +1,2 @@
DIST kolourpaint-17.04.3.tar.xz 5548196 SHA256 12f648bdedf3148613a9af640c36b340a2ac50e35e808755dd9f4ac5eb2ec9f7 SHA512 d0fa2accf79b4a7c1e39c6d936ec71714464c6da9185643072744e94469465cff2e69e12855b77e29fa7736fd14390c081d78a94028bccae6903bdccb54d2576 WHIRLPOOL 627dfeeaa1fbe3f3ea38ecf0f7d345ba0bf1306bbd2f244619661d15ee1ce38bceb18a0d34fe04a4267c1e44b99d031f59bfa25ae8a49bd324797fd80ea058ff
+DIST kolourpaint-17.08.0.tar.xz 5546440 SHA256 89754188a72bf600986363ee375c3fdd49a8a1bc38ae6b8c267889951c4cb597 SHA512 46ced6620e3419c05a2e10bb391405baa607914cc9c3bd76a03aa52a8787b1d5d742abd568f14febdc4e549c516205ed8bdf28bf5bdbde451b8dba9f046a70f4 WHIRLPOOL c6afdb376878edbdda922fe38dcbb684279304a9641d3c8e0d42c3125c701bd8a846716659645616832a582eaf8d49c35f14ec457adfd245e3dd93e72c463efb
diff --git a/kde-apps/kolourpaint/kolourpaint-17.08.0.ebuild b/kde-apps/kolourpaint/kolourpaint-17.08.0.ebuild
new file mode 100644
index 000000000000..69dda0e51a86
--- /dev/null
+++ b/kde-apps/kolourpaint/kolourpaint-17.08.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="true"
+inherit kde5
+
+DESCRIPTION="Paint Program by KDE"
+HOMEPAGE="https://www.kde.org/applications/graphics/kolourpaint/"
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD-2 LGPL-2 LGPL-2+ || ( LGPL-2.1 LGPL-3 ) GPL-2 handbook? ( FDL-1.2 )"
+IUSE="scanner"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ scanner? ( $(add_kdeapps_dep libksane) )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package scanner KF5Sane)
+ )
+
+ kde5_src_configure
+}