summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-08-11 06:56:04 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-08-11 07:33:57 -0400
commit1b1adc2831bb487ccac122a01a358bda206d3af4 (patch)
tree38caf83e2a70f14efbafb02024cbb2459204bbfb /gui-libs
parentx11-misc/wmctrl: EAPI7->8 with minor adjustments (diff)
downloadgentoo-1b1adc2831bb487ccac122a01a358bda206d3af4.tar.gz
gentoo-1b1adc2831bb487ccac122a01a358bda206d3af4.tar.bz2
gentoo-1b1adc2831bb487ccac122a01a358bda206d3af4.zip
gui-libs/egl-wayland: add 1.1.10_p20220805
Includes a hopefully better fix for resize issues than the revert defer resizes patch. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/egl-wayland/Manifest1
-rw-r--r--gui-libs/egl-wayland/egl-wayland-1.1.10_p20220805.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/gui-libs/egl-wayland/Manifest b/gui-libs/egl-wayland/Manifest
index a509c388dc4f..ce969c6ed6b9 100644
--- a/gui-libs/egl-wayland/Manifest
+++ b/gui-libs/egl-wayland/Manifest
@@ -1,3 +1,4 @@
DIST egl-wayland-1.1.10.tar.gz 60058 BLAKE2B c24cc0d6e45e43868140d4e16ad5092a951bebb71fa0d65e11ef8d4273d85589a435e6d29b73b665630b5a7e28fdbd8e1e02e5eb43eed7d06862caabae7146e9 SHA512 163ee1ae1e629c5d32ffdf335b35ba309d35c009f93a8391e78dcb710a86f64e017a37c1e77325c6f4782c8a5fe048ae44ad1456bd3a20ea651b4192c9102e3c
+DIST egl-wayland-1.1.10_p20220805.tar.gz 60283 BLAKE2B 14c272e4cc084892cc9eb822b85168e420c7cfd5472c9f24fd9aa6cc6a5aef2c75411c8c06e148c48e45c6ee4aa3179784b9e432905f41753840bf1ef576e634 SHA512 ce7aa6cc738dc392dfa9a6cf2c24253968404e011b4e921c6e3bf723fd4bc0eae63ef2050bef025a0726601e5ce2a08987293fd1674fb6c6b6c207969fd15bcb
DIST egl-wayland-1.1.7.tar.gz 48681 BLAKE2B eebbd0e36045c50b39ef70292156f5cd137a51af2169b56a35d318d90ade3d4a5b94206d86246d52fda0c6c093ff25e389b1a3ccbe60595dc9661d199e30f33b SHA512 edc81d9f2c617587044d5f9d35b3e355db8544e8fa1d861c1b92a5a11bc1af7d994ca8abd49ce6f462a1971f20296b4c757bdf1df0d2bfc981cdafaa839f12af
DIST egl-wayland-1.1.9_p20211123.tar.gz 58900 BLAKE2B a5a08df06e302b573f1036264495e7b29ec4d3def9be0e9b8037206a42aab5c18d78b79cc3f3ffeede9708916e644f8090fadf34318429cf0040c3623da28ce1 SHA512 8de18c8c0c38ca672688a5197be20534cc90b0fecae9ea2f3d3bc851d5b50d3f148a4ce97b835a9576251c8273ea21f82f2c9694cf2b7bba28fa3b53850c43b2
diff --git a/gui-libs/egl-wayland/egl-wayland-1.1.10_p20220805.ebuild b/gui-libs/egl-wayland/egl-wayland-1.1.10_p20220805.ebuild
new file mode 100644
index 000000000000..48773892aa79
--- /dev/null
+++ b/gui-libs/egl-wayland/egl-wayland-1.1.10_p20220805.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+EGLWAYLAND_HASH="885f0a5e91fe9cfbfbcd98ff01f6b83503decef3"
+
+DESCRIPTION="EGLStream-based Wayland external platform"
+HOMEPAGE="https://github.com/NVIDIA/egl-wayland"
+SRC_URI="https://github.com/NVIDIA/egl-wayland/archive/${EGLWAYLAND_HASH}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${EGLWAYLAND_HASH}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-libs/wayland
+ !<x11-drivers/nvidia-drivers-470.57.02[wayland(-)]"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+ gui-libs/eglexternalplatform
+ >=media-libs/libglvnd-1.3.4
+ x11-libs/libdrm"
+BDEPEND="dev-util/wayland-scanner"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.6-remove-werror.patch
+)
+
+src_install() {
+ meson_src_install
+
+ insinto /usr/share/egl/egl_external_platform.d
+ doins "${FILESDIR}"/10_nvidia_wayland.json
+}
+
+pkg_postinst() {
+ if has_version "<x11-drivers/nvidia-drivers-391"; then
+ ewarn "<=nvidia-drivers-390.xx may not work properly with this version of"
+ ewarn "egl-wayland, it is recommended to use nouveau drivers for wayland."
+ fi
+}