summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-08-03 20:35:04 -0400
committerMatt Turner <mattst88@gentoo.org>2022-08-03 20:36:11 -0400
commit4c32ae5a18e97a8ec9b0133f1d00b367f50c0dc9 (patch)
tree73716694aa0c83cdfc858795e517d3a0dc94500a /gui-libs/libwpe
parentdev-lang/go: drop 1.18.4 (diff)
downloadgentoo-4c32ae5a18e97a8ec9b0133f1d00b367f50c0dc9.tar.gz
gentoo-4c32ae5a18e97a8ec9b0133f1d00b367f50c0dc9.tar.bz2
gentoo-4c32ae5a18e97a8ec9b0133f1d00b367f50c0dc9.zip
gui-libs/libwpe: Version bump to 1.12.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gui-libs/libwpe')
-rw-r--r--gui-libs/libwpe/Manifest1
-rw-r--r--gui-libs/libwpe/libwpe-1.12.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/gui-libs/libwpe/Manifest b/gui-libs/libwpe/Manifest
index 5e77c8345fe1..3abb71cb92e3 100644
--- a/gui-libs/libwpe/Manifest
+++ b/gui-libs/libwpe/Manifest
@@ -1 +1,2 @@
DIST libwpe-1.12.0.tar.xz 54548 BLAKE2B d2eb3f410ba0691c6e9ad4638de517be36d5b9729c7b09c44a316d91822071b527c1ea4a4fda5248d623bf61250cc398cffdf19ec47059621323ed726a5d0889 SHA512 d85865fd6f2dd907589a4d2c1b956d9a2093f72f5b7f755ab2bef040f7f26a73ddadd47a607a78578dec6eb6d59f44e18fa8b96a71f7bd19f3d62073f3ca6fee
+DIST libwpe-1.12.2.tar.xz 55416 BLAKE2B ac0d1f824b3cb82f1068cf4536b2481be6e1fb243582b3bc48afaa2b15450dbeeb374e52cf607ca3c758f314382a5090d5376be9b7ccf07bb06b654afa99844d SHA512 ff09d80ef896c22091169d62f25cf03213149b592a65029c4e1190c48068f023a81cb8191c7f4e6e27dedf8ba3dd6c28588dac6c6571cf634b3f3093115d6562
diff --git a/gui-libs/libwpe/libwpe-1.12.2.ebuild b/gui-libs/libwpe/libwpe-1.12.2.ebuild
new file mode 100644
index 000000000000..c7b2ec058f58
--- /dev/null
+++ b/gui-libs/libwpe/libwpe-1.12.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Platform-agnostic interfaces for WPE WebKit"
+HOMEPAGE="https://wpewebkit.org/"
+SRC_URI="https://wpewebkit.org/releases/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="1.0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ media-libs/mesa[egl(+)]
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbuild-docs=false # hotdoc not packaged
+ )
+ meson_src_configure
+}