summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnustep-libs/performance
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnustep-libs/performance')
-rw-r--r--gnustep-libs/performance/Manifest1
-rw-r--r--gnustep-libs/performance/metadata.xml6
-rw-r--r--gnustep-libs/performance/performance-0.4.0.ebuild25
3 files changed, 32 insertions, 0 deletions
diff --git a/gnustep-libs/performance/Manifest b/gnustep-libs/performance/Manifest
new file mode 100644
index 000000000000..31761711e417
--- /dev/null
+++ b/gnustep-libs/performance/Manifest
@@ -0,0 +1 @@
+DIST Performance-0.4.0.tar.gz 48527 SHA256 e55c1a8d9e6f1e3ba146490d1b0cf7b84e124410a50070ab3b27ecfc4aab6a1c SHA512 0c590508f2c58501969e8a1233663521274833d0915a671b1f81daf283770b0e98892e5ec447a07e0ede767b1c4f2bf2f2ac52bc6c48b413ff02085ced34a22c WHIRLPOOL 9b353d649fb7c280c370ed76d467b7dea1d70c6ed5dd265c56987744c0029a89cba1aebd17802e595cbd9338f6a36de62f97013df9eed211f4ebcfad18e06c9d
diff --git a/gnustep-libs/performance/metadata.xml b/gnustep-libs/performance/metadata.xml
new file mode 100644
index 000000000000..f35a090c8e6c
--- /dev/null
+++ b/gnustep-libs/performance/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnustep</herd>
+ <longdescription>A collection of classes to help improve/tune performance of your software </longdescription>
+</pkgmetadata>
diff --git a/gnustep-libs/performance/performance-0.4.0.ebuild b/gnustep-libs/performance/performance-0.4.0.ebuild
new file mode 100644
index 000000000000..7cebee545dd3
--- /dev/null
+++ b/gnustep-libs/performance/performance-0.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit gnustep-2
+
+MY_P=${P/p/P}
+DESCRIPTION="Help improve the performance of GNUstep applications"
+HOMEPAGE="http://wiki.gnustep.org/index.php/Performance"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${MY_P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="LGPL-3"
+SLOT="0"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ if ! use doc; then
+ # Remove doc target
+ sed -i -e '/documentation\.make/d' GNUmakefile \
+ || die "doc sed failed"
+ fi
+}