summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnustep-apps/projectcenter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnustep-apps/projectcenter')
-rw-r--r--gnustep-apps/projectcenter/Manifest2
-rw-r--r--gnustep-apps/projectcenter/metadata.xml8
-rw-r--r--gnustep-apps/projectcenter/projectcenter-0.6.1.ebuild20
-rw-r--r--gnustep-apps/projectcenter/projectcenter-0.6.2.ebuild20
4 files changed, 50 insertions, 0 deletions
diff --git a/gnustep-apps/projectcenter/Manifest b/gnustep-apps/projectcenter/Manifest
new file mode 100644
index 000000000000..d785adf63389
--- /dev/null
+++ b/gnustep-apps/projectcenter/Manifest
@@ -0,0 +1,2 @@
+DIST ProjectCenter-0.6.1.tar.gz 490466 SHA256 3dc72d29bb40bdea9382266045b419ae3c7d117329ea9e0263cf4553e1794ed2 SHA512 6c858f810c6563a185334e75fe7a3a3c58db51d69751b8d685d28e43bb311d7310c702435ab889eb7e53b6e46b8130bde51009f82c012b9cc7c7a2f74efd280b WHIRLPOOL 4e11e30db29c3de55faafd95bf8c94fae79849204b1430c69107e4e76b76a1c6f89976f4a6d6a934932bd88368c2f71221991768719977b1d3e0c129e37e40b6
+DIST ProjectCenter-0.6.2.tar.gz 492409 SHA256 c5104ae18511260f900c6de6cca0bcf39361da1866499102bf2a90e2f05d9473 SHA512 91e6712fa03fcb7b6e8239f64ddf89dabb1b4c54f4799204e8e535c9c6ad430a5e98644e28af5b9727a0b5b57a866b4e0837f09e8aedfac863673508a7c67a78 WHIRLPOOL 930e7405570a70eb564852e68573e847f684a2f64715fe8448fcf0d3b4220f154a9cd947bc0fb2e7a0755f572130d0f83346c3e4cad912b744988491d0846140
diff --git a/gnustep-apps/projectcenter/metadata.xml b/gnustep-apps/projectcenter/metadata.xml
new file mode 100644
index 000000000000..d0502643f038
--- /dev/null
+++ b/gnustep-apps/projectcenter/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnustep</herd>
+<longdescription>
+ProjectCenter is GNUstep's integrated developement environment (IDE). It is based in part on NeXT's original Project Builder. It assists you in starting new projects and lets you manage your project files using a intuitive and well ordered graphical user interface.
+</longdescription>
+</pkgmetadata>
diff --git a/gnustep-apps/projectcenter/projectcenter-0.6.1.ebuild b/gnustep-apps/projectcenter/projectcenter-0.6.1.ebuild
new file mode 100644
index 000000000000..a270bca513d4
--- /dev/null
+++ b/gnustep-apps/projectcenter/projectcenter-0.6.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit gnustep-2
+
+MY_P=${P/projectc/ProjectC}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="An IDE for GNUstep"
+HOMEPAGE="http://www.gnustep.org/experience/ProjectCenter.html"
+SRC_URI="http://ftpmain.gnustep.org/pub/gnustep/dev-apps/${MY_P}.tar.gz"
+
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-devel/gdb-6.0"
diff --git a/gnustep-apps/projectcenter/projectcenter-0.6.2.ebuild b/gnustep-apps/projectcenter/projectcenter-0.6.2.ebuild
new file mode 100644
index 000000000000..e4612e583897
--- /dev/null
+++ b/gnustep-apps/projectcenter/projectcenter-0.6.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit gnustep-2
+
+MY_P=${P/projectc/ProjectC}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="An IDE for GNUstep"
+HOMEPAGE="http://www.gnustep.org/experience/ProjectCenter.html"
+SRC_URI="http://ftpmain.gnustep.org/pub/gnustep/dev-apps/${MY_P}.tar.gz"
+
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-devel/gdb-6.0"