summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-08-21 17:00:03 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-23 01:21:28 -0400
commit709ff5b9a5bf18168a8fae46e2704d3954377a82 (patch)
tree92226823cb9722b669abb2811c29a208848aa105 /gnome-extra
parentgnome-extra/cinnamon-settings-daemon: conditionalize wayland on wacom (diff)
downloadgentoo-709ff5b9a5bf18168a8fae46e2704d3954377a82.tar.gz
gentoo-709ff5b9a5bf18168a8fae46e2704d3954377a82.tar.bz2
gentoo-709ff5b9a5bf18168a8fae46e2704d3954377a82.zip
gnome-extra/cinnamon-settings-daemon: avoid automagic deps on gtk+[X,wayland]
Currently, one is forced to compile c-s-d and gtk with the same value of USE=wayland which makes it difficult to provide generically reusable binaries. It is better than automagically depending on wayland and then lacking it, but not ideal. Preferable would be for c-s-d[wayland] to require gtk+[wayland] but when built without wayland support, to not care whether gtk itself is. We now support a mechanism for packages to opt out of gtk providing the API, for use by packages that don't provide a `-D wayland=true` but autodetect whether gtk was built with it. Use that mechanism. Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/cinnamon-settings-daemon/cinnamon-settings-daemon-6.2.0-r1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnome-extra/cinnamon-settings-daemon/cinnamon-settings-daemon-6.2.0-r1.ebuild b/gnome-extra/cinnamon-settings-daemon/cinnamon-settings-daemon-6.2.0-r1.ebuild
index 7abe049b1722..701215fbc2c5 100644
--- a/gnome-extra/cinnamon-settings-daemon/cinnamon-settings-daemon-6.2.0-r1.ebuild
+++ b/gnome-extra/cinnamon-settings-daemon/cinnamon-settings-daemon-6.2.0-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..13} )
-inherit meson gnome2-utils python-any-r1 xdg
+inherit meson flag-o-matic gnome2-utils python-any-r1 xdg
DESCRIPTION="Cinnamon's settings daemon"
HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/cinnamon-settings-daemon"
@@ -43,7 +43,7 @@ RDEPEND="
app-admin/system-config-printer
net-print/cups-pk-helper )
input_devices_wacom? (
- >=x11-libs/gtk+-3.14.0:3[wayland=]
+ >=x11-libs/gtk+-3.24.41-r1:3[wayland?,X]
>=dev-libs/libwacom-0.7:=
>=gnome-base/librsvg-2.36.2
)
@@ -75,6 +75,12 @@ src_prepare() {
}
src_configure() {
+ # The only component that uses gdk backends is the wacom plugin
+ if use input_devices_wacom; then
+ # defang automagic dependencies
+ use wayland || append-cflags -DGENTOO_GTK_HIDE_WAYLAND
+ fi
+
# gudev not optional on Linux platforms
local emesonargs=(
-Duse_gudev=enabled