summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/zeitgeist-explorer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/zeitgeist-explorer')
-rw-r--r--gnome-extra/zeitgeist-explorer/Manifest1
-rw-r--r--gnome-extra/zeitgeist-explorer/metadata.xml17
-rw-r--r--gnome-extra/zeitgeist-explorer/zeitgeist-explorer-0.2-r1.ebuild29
3 files changed, 47 insertions, 0 deletions
diff --git a/gnome-extra/zeitgeist-explorer/Manifest b/gnome-extra/zeitgeist-explorer/Manifest
new file mode 100644
index 000000000000..525438c63a92
--- /dev/null
+++ b/gnome-extra/zeitgeist-explorer/Manifest
@@ -0,0 +1 @@
+DIST zeitgeist-explorer-0.2.tar.gz 25503 SHA256 ac12e520713e86606f15335a182b5b5d3fbf6b132a0137940505e0af62153423 SHA512 05e16e4c6980ce0dd23fb3f74d0c45aad6e5a31d5b8982d04d20781c3527e4e1b768e75e67664fe5731202a3682c972fd759a71d58b420b31f72e3eb2dce7788 WHIRLPOOL 3a174ed5fc39f18a9ddb614f2cd1d75fd1a9988e85c2d73e0c862430b1e2c89f36399f02adf76a36ff2a0f9dd877e44d44a323ba08be8f8e98483616dd290ff0
diff --git a/gnome-extra/zeitgeist-explorer/metadata.xml b/gnome-extra/zeitgeist-explorer/metadata.xml
new file mode 100644
index 000000000000..fb630428e933
--- /dev/null
+++ b/gnome-extra/zeitgeist-explorer/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+Zeitgeist explorer is a tool which can be used to monitor and explore the
+events logged by zeitgeist. In the monitor mode is can show the events logged
+in real-time just like wireshark. In explore mode, it can fetch already
+logged events for a specific template
+</longdescription>
+ <upstream>
+ <remote-id type="launchpad">zeitgeist-explorer</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gnome-extra/zeitgeist-explorer/zeitgeist-explorer-0.2-r1.ebuild b/gnome-extra/zeitgeist-explorer/zeitgeist-explorer-0.2-r1.ebuild
new file mode 100644
index 000000000000..fd5b53f88020
--- /dev/null
+++ b/gnome-extra/zeitgeist-explorer/zeitgeist-explorer-0.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 versionator
+
+MY_PV="$(get_version_component_range 1-2)"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Monitor and inspect Zeitgeist's log at a low level - developer tool"
+HOMEPAGE="https://launchpad.net/zeitgeist-explorer/"
+SRC_URI="https://launchpad.net/${PN}/0.x/${MY_PV}/+download/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ gnome-extra/zeitgeist
+ x11-libs/gtk+:3[introspection]"
+DEPEND="${RDEPEND}
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]"
+
+DISTUTILS_NO_PARALLEL_BUILD=true