summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-05-18 11:00:50 +0200
committerPacho Ramos <pacho@gentoo.org>2024-05-18 11:23:04 +0200
commit07c2f2be80412e7d3bd9ae120a180187c84fd3e2 (patch)
treea11dbd5e03199953194c697e7b4c27a4abdf0cf1 /gnome-extra/gnome-shell-extension-alphabetical-grid
parentdev-ruby/rails: add 7.1.3.3 (diff)
downloadgentoo-07c2f2be80412e7d3bd9ae120a180187c84fd3e2.tar.gz
gentoo-07c2f2be80412e7d3bd9ae120a180187c84fd3e2.tar.bz2
gentoo-07c2f2be80412e7d3bd9ae120a180187c84fd3e2.zip
gnome-extra/gnome-shell-extension-alphabetical-grid: add 40.0
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-shell-extension-alphabetical-grid')
-rw-r--r--gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-40.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest b/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest
index f8e75576b8d3..fa2d5549f9da 100644
--- a/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest
+++ b/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest
@@ -1,2 +1,3 @@
DIST gnome-shell-extension-alphabetical-grid-38.0.tar.gz 216817 BLAKE2B bfb01e647b8545c70ce9e3b65910701ebce38d110a97c15e0413f10c0b68116b4624e98ad0d34961b701b2f2b43c20f1a15e31219edfb14a79321143be3e2c8d SHA512 4736a5e621c58adf635c468032233f54b9a2f93cdec9e65616a7272ee3368fe901401d051ed13674c815b73fdef9f7a4c38bc9e3e4c19ede7adc6782ae91cff1
DIST gnome-shell-extension-alphabetical-grid-39.0.tar.gz 216879 BLAKE2B 4fb6aa97f01350dbbe2992f5a45c1e85f1b32456869670261224516de15b7b735500af2e59622bf9a010cf9b1da32ddb5d641143c5b12e4fa51da4ed6449e38e SHA512 046662c32c5b5fdf22b770e437aab1cfc8462798966683749484f199de5c716d72789b0f4928c5d03f5139e5fd8182fee5335f6b50e6c79a32a6f1df7ee2aae8
+DIST gnome-shell-extension-alphabetical-grid-40.0.tar.gz 216967 BLAKE2B 5500f701d3b94cc68cfe2b0bebb7425889c26982ad5d7a11acc278c3fd5b9a90e372ddafa3f920e970ce83f8b497fb0f81de32632d8b804895c00a31372aa34d SHA512 62c22c8a926f446d234efb9363fbf667b1ec8a3967aeac58f3dd8d648945ba98269cde6d46dff47a50dd9c417c92c72ef35f44154773afa45ab56ee5cafc9c82
diff --git a/gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-40.0.ebuild b/gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-40.0.ebuild
new file mode 100644
index 000000000000..50291ca4a9f4
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-40.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils
+
+# Useful specially to prevent
+# https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/4684
+# https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/3180
+DESCRIPTION="Restore the alphabetical ordering of the app grid"
+HOMEPAGE="https://github.com/stuarthayhurst/alphabetical-grid-extension"
+SRC_URI="https://github.com/stuarthayhurst/alphabetical-grid-extension/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-45
+ gui-libs/libadwaita
+"
+DEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/alphabetical-grid-extension-${PV}"
+extension_uuid="AlphabeticalAppGrid@stuarthayhurst"
+
+# Tests are only useful for upstream
+RESTRICT="test"
+
+# Not useful for us
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ mv docs/icon.svg extension || die
+ cd extension || die
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf schemas || die
+ insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
+ doins -r *
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}