summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-12-12 22:01:33 -0500
committerMike Gilbert <floppym@gentoo.org>2020-12-14 11:45:17 -0500
commit46b2d4e7cd4e4859bb33eeb8863cd5b1e6a7ac4a (patch)
treec8412df9bcc7b07770c1a740dabe2375739aef58 /gnome-base
parentgnome-base/gnome-flashback: fix quoting for pkg-config (diff)
downloadgentoo-46b2d4e7cd4e4859bb33eeb8863cd5b1e6a7ac4a.tar.gz
gentoo-46b2d4e7cd4e4859bb33eeb8863cd5b1e6a7ac4a.tar.bz2
gentoo-46b2d4e7cd4e4859bb33eeb8863cd5b1e6a7ac4a.zip
gnome-base/gdm: fix quoting for pkg-config
Bug: https://bugs.gentoo.org/756238 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gdm/gdm-3.36.3.ebuild7
-rw-r--r--gnome-base/gdm/gdm-3.36.4.ebuild7
2 files changed, 8 insertions, 6 deletions
diff --git a/gnome-base/gdm/gdm-3.36.3.ebuild b/gnome-base/gdm/gdm-3.36.3.ebuild
index 7b8b1e592dca..93db1164a50e 100644
--- a/gnome-base/gdm/gdm-3.36.3.ebuild
+++ b/gnome-base/gdm/gdm-3.36.3.ebuild
@@ -5,7 +5,7 @@ EAPI=6
GNOME2_LA_PUNT="yes"
GNOME2_EAUTORECONF="yes"
-inherit eutils gnome2 pam readme.gentoo-r1 systemd udev user
+inherit eutils gnome2 pam readme.gentoo-r1 systemd toolchain-funcs udev user
DESCRIPTION="GNOME Display Manager for managing graphical display servers and user logins"
HOMEPAGE="https://wiki.gnome.org/Projects/GDM"
@@ -187,10 +187,11 @@ src_configure() {
)
if use elogind; then
+ local pkgconfig="$(tc-getPKG_CONFIG)"
myconf+=(
--with-initial-vt=7 # TODO: Revisit together with startDM.sh and other xinit talks; also ignores plymouth possibility
- SYSTEMD_CFLAGS=`pkg-config --cflags "libelogind" 2>/dev/null`
- SYSTEMD_LIBS=`pkg-config --libs "libelogind" 2>/dev/null`
+ SYSTEMD_CFLAGS="$(${pkgconfig} --cflags "libelogind")"
+ SYSTEMD_LIBS="$(${pkgconfig} --libs "libelogind")"
)
fi
diff --git a/gnome-base/gdm/gdm-3.36.4.ebuild b/gnome-base/gdm/gdm-3.36.4.ebuild
index 12a42230f315..8a86e224747e 100644
--- a/gnome-base/gdm/gdm-3.36.4.ebuild
+++ b/gnome-base/gdm/gdm-3.36.4.ebuild
@@ -5,7 +5,7 @@ EAPI=6
GNOME2_LA_PUNT="yes"
GNOME2_EAUTORECONF="yes"
-inherit eutils gnome2 pam readme.gentoo-r1 systemd udev user
+inherit eutils gnome2 pam readme.gentoo-r1 systemd toolchain-funcs udev user
DESCRIPTION="GNOME Display Manager for managing graphical display servers and user logins"
HOMEPAGE="https://wiki.gnome.org/Projects/GDM"
@@ -187,10 +187,11 @@ src_configure() {
)
if use elogind; then
+ local pkgconfig="$(tc-getPKG_CONFIG)"
myconf+=(
--with-initial-vt=7 # TODO: Revisit together with startDM.sh and other xinit talks; also ignores plymouth possibility
- SYSTEMD_CFLAGS=`pkg-config --cflags "libelogind" 2>/dev/null`
- SYSTEMD_LIBS=`pkg-config --libs "libelogind" 2>/dev/null`
+ SYSTEMD_CFLAGS="$(${pkgconfig} --cflags "libelogind")"
+ SYSTEMD_LIBS="$(${pkgconfig} --libs "libelogind")"
)
fi