summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-05-31 21:26:34 +0100
committerJames Le Cuirot <chewi@gentoo.org>2022-05-31 21:26:34 +0100
commit5b5a9275955833746b8f452d0e5ed8619a97cf56 (patch)
treeba731d56aeb137c4f7ec4dff37795de63d306fdc /games-util
parentwww-client/microsoft-edge-dev: remove old (diff)
downloadgentoo-5b5a9275955833746b8f452d0e5ed8619a97cf56.tar.gz
gentoo-5b5a9275955833746b8f452d0e5ed8619a97cf56.tar.bz2
gentoo-5b5a9275955833746b8f452d0e5ed8619a97cf56.zip
games-util/joycond: Call udev_reload when installing or removing
Closes: https://bugs.gentoo.org/847043 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/joycond/joycond-0.1.0_p20210730-r1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/games-util/joycond/joycond-0.1.0_p20210730-r1.ebuild b/games-util/joycond/joycond-0.1.0_p20210730-r1.ebuild
index 89a5d6774449..fb0deb654d53 100644
--- a/games-util/joycond/joycond-0.1.0_p20210730-r1.ebuild
+++ b/games-util/joycond/joycond-0.1.0_p20210730-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake linux-info
+inherit cmake linux-info udev
COMMIT="f9a66914622514c13997c2bf7ec20fa98e9dfc1d"
DESCRIPTION="Daemon that uses hid-nintendo evdev devices to implement joycon pairing"
@@ -41,3 +41,11 @@ src_install() {
newinitd "${FILESDIR}"/${PN}.initd ${PN}
doman doc/${PN}.1
}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}