summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-06-09 22:01:29 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-06-09 22:02:25 +0100
commitc67607be465bfa87de0483891f47fa36d4fc58c8 (patch)
treef8cc017747641e7abe075f8ddec8988284e5dcca /games-strategy
parentdev-lang/perl: drop inofficial SRC_URI (diff)
downloadgentoo-c67607be465bfa87de0483891f47fa36d4fc58c8.tar.gz
gentoo-c67607be465bfa87de0483891f47fa36d4fc58c8.tar.bz2
gentoo-c67607be465bfa87de0483891f47fa36d4fc58c8.zip
games-strategy/s25rttr: Fix boost compatibility issues with patch
Closes: https://bugs.gentoo.org/933411 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/s25rttr/files/s25rttr-0.9.5-boost.patch56
-rw-r--r--games-strategy/s25rttr/s25rttr-0.9.5.ebuild6
2 files changed, 59 insertions, 3 deletions
diff --git a/games-strategy/s25rttr/files/s25rttr-0.9.5-boost.patch b/games-strategy/s25rttr/files/s25rttr-0.9.5-boost.patch
new file mode 100644
index 000000000000..ace37abf9627
--- /dev/null
+++ b/games-strategy/s25rttr/files/s25rttr-0.9.5-boost.patch
@@ -0,0 +1,56 @@
+From d1c6739e93a788b7ea9da7915642b2c8d6ab0656 Mon Sep 17 00:00:00 2001
+From: Alexander Grund <alexander.grund@tu-dresden.de>
+Date: Fri, 3 Feb 2023 16:30:09 +0100
+Subject: [PATCH] Fix compatibility with Boost 1.74+
+
+This has turned into an error in Boost 1.81
+Fixes #1551
+---
+ libs/s25main/network/GameClient.cpp | 8 +++++++-
+ 3 files changed, 9 insertions(+), 3 deletions(-)
+
+diff --git a/libs/s25main/network/GameClient.cpp b/libs/s25main/network/GameClient.cpp
+index 84e351c08..0989d5877 100644
+--- a/libs/s25main/network/GameClient.cpp
++++ b/libs/s25main/network/GameClient.cpp
+@@ -119,7 +119,13 @@ bool GameClient::HostGame(const CreateServerInfo& csi, const boost::filesystem::
+ if(playedMapPath != map_path)
+ {
+ boost::system::error_code ignoredEc;
+- copy_file(map_path, playedMapPath, boost::filesystem::copy_option::overwrite_if_exists, ignoredEc);
++ constexpr auto overwrite_existing =
++#if BOOST_VERSION >= 107400
++ boost::filesystem::copy_options::overwrite_existing;
++#else
++ boost::filesystem::copy_option::overwrite_if_exists;
++#endif
++ copy_file(map_path, playedMapPath, overwrite_existing, ignoredEc);
+ }
+ return GAMESERVER.Start(csi, map_path, map_type, hostPw)
+ && Connect("localhost", hostPw, csi.type, csi.port, true, csi.ipv6);
+
+From 96978da4aba9280217a5b36731c303c35819220b Mon Sep 17 00:00:00 2001
+From: Alexander Grund <Flamefire@users.noreply.github.com>
+Date: Thu, 23 May 2024 19:35:14 +0200
+Subject: [PATCH] Fix Boost.Filesystem include
+
+The directory iterator seems to have move to a different include.
+Just include all of it.
+---
+ callbacks.cpp | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/external/s25edit/callbacks.cpp b/external/s25edit/callbacks.cpp
+index 52ec86d..095c1d6 100644
+--- a/external/s25edit/callbacks.cpp
++++ b/external/s25edit/callbacks.cpp
+@@ -18,8 +18,7 @@
+ #include "CSurface.h"
+ #include "globals.h"
+ #include "helpers/format.hpp"
+-#include <boost/filesystem/operations.hpp>
+-#include <boost/filesystem/path.hpp>
++#include <boost/filesystem.hpp>
+ #include <algorithm>
+
+ namespace bfs = boost::filesystem;
diff --git a/games-strategy/s25rttr/s25rttr-0.9.5.ebuild b/games-strategy/s25rttr/s25rttr-0.9.5.ebuild
index 4986896fd623..1184da066c3a 100644
--- a/games-strategy/s25rttr/s25rttr-0.9.5.ebuild
+++ b/games-strategy/s25rttr/s25rttr-0.9.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,6 +11,7 @@ MY_PN="s25client"
DESCRIPTION="Open source remake of The Settlers II: Gold Edition (needs original data files)"
HOMEPAGE="https://www.siedler25.org/"
SRC_URI="https://github.com/Return-To-The-Roots/${MY_PN}/releases/download/v${PV}/${MY_PN}_src_v${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}_v${PV}"
LICENSE="GPL-2+ GPL-3 Boost-1.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
@@ -42,10 +43,9 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-0.9.0_pre20200723-cmake_lua_version.patch
"${FILESDIR}"/${PN}-0.9.5-gcc-13.patch
+ "${FILESDIR}"/${PN}-0.9.5-boost.patch
)
-S="${WORKDIR}/${MY_PN}_v${PV}"
-
# Build type is checked but blank is valid.
CMAKE_BUILD_TYPE=