summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-11-30 02:40:59 +0000
committerSam James <sam@gentoo.org>2023-11-30 02:40:59 +0000
commit6593d60ce1741abae47adc48d7ebb194a50d6aba (patch)
treed7320f8c3604ca19e91b41526dcc6766ea47947f /games-strategy
parentdev-cpp/nlohmann_json: add 3.11.3 (diff)
downloadgentoo-6593d60ce1741abae47adc48d7ebb194a50d6aba.tar.gz
gentoo-6593d60ce1741abae47adc48d7ebb194a50d6aba.tar.bz2
gentoo-6593d60ce1741abae47adc48d7ebb194a50d6aba.zip
games-strategy/warzone2100: add 4.4.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/warzone2100/Manifest1
-rw-r--r--games-strategy/warzone2100/warzone2100-4.4.2.ebuild125
2 files changed, 126 insertions, 0 deletions
diff --git a/games-strategy/warzone2100/Manifest b/games-strategy/warzone2100/Manifest
index 9928dad6c330..d09ca25477fe 100644
--- a/games-strategy/warzone2100/Manifest
+++ b/games-strategy/warzone2100/Manifest
@@ -1,3 +1,4 @@
DIST warzone2100-4.3.5.tar.xz 320369492 BLAKE2B 526568cd25e7600e4f45714f4cd2a8ef9da8a1a3f6691d9cb07f4ed6c9367fc412f0fa77b4a547c4a4eac6d42624ac5b9d1e105e4606f801f773ce6028740286 SHA512 ec65f22a0aad9fe482c4ea916cb321d171b10f0a9b181fea7db2eb17bf54e32b3828c8259082fff266713e2cab4e32dcc455d0d5b923a5ca221fc77b11137062
DIST warzone2100-4.4.0.tar.xz 489899284 BLAKE2B 4b041bca3efeec4da9f24c835faba2d3fef3f175c4724c7d3946b2cda3bb464ec773ff96819a52621b53952677b0b042d2268875280f10e0ace26921e7ba8f1e SHA512 35f5e54007d6eeeacc451d6c62f6e6980a2e2e2462dfed16229e89f8e24636ae923dd2c1c4eb6cb84df0a3b96a6f3b7b91b7614a4bd3568380203244ac648396
+DIST warzone2100-4.4.2.tar.xz 490182768 BLAKE2B 4b8f6825072c8dd29e1d4699b21123ff015e87da9b4f5043e40398ec5ec41ba12d414bbb01dd616a9e7f74f45407341e87a071ef38eb7c191e3845016f8df330 SHA512 8edfae77853826fda4bafafc513d9c6d999861fc4a7f0cf22318df7ebf9df3d7f98c3859eec8e8eeb02f4243b7e2e152c8d46881f4f8d414787ef0d0735ea4e6
DIST warzone2100-videos-2.2.wz 571937134 BLAKE2B 60b70a71bd920e2d72ded5d519b17db2f3db4b0289edadeb58059a21aba7038b95219dc44cb807754461d1a9bdca60f0d7698be68622b8bd64a55efa949622d3 SHA512 ca1a1af51296afdaca137114821508c5783f077090e665eae0f6df895855f57c43f84434706309e819417f5f35d1c649bd14e96dc9fbbb1252d30a4f9a223cf6
diff --git a/games-strategy/warzone2100/warzone2100-4.4.2.ebuild b/games-strategy/warzone2100/warzone2100-4.4.2.ebuild
new file mode 100644
index 000000000000..42252a5e12cf
--- /dev/null
+++ b/games-strategy/warzone2100/warzone2100-4.4.2.ebuild
@@ -0,0 +1,125 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PLOCALES="af_ZA bg_BG ca_ES cs da de el en_GB eo es et_EE fa_IR fi fr fy ga he_IL hr hu id_ID id it ko la lt nb nl pl pt_BR pt ro ru sk sl tr tt_RU uk_UA zh_CN zh_TW"
+inherit cmake plocale xdg
+
+MY_PV=$(ver_cut 1-2)
+VIDEOS_PV=2.2
+VIDEOS_P=${PN}-videos-${VIDEOS_PV}.wz
+
+DESCRIPTION="3D real-time strategy game"
+HOMEPAGE="https://wz2100.net/"
+SRC_URI="
+ mirror://sourceforge/warzone2100/releases/${PV}/${PN}_src.tar.xz -> ${P}.tar.xz
+ videos? ( mirror://sourceforge/warzone2100/warzone2100/Videos/${VIDEOS_PV}/high-quality-en/sequences.wz -> ${VIDEOS_P} )
+"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0 public-domain vulkan? ( GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+# Upstream requested debug support
+IUSE="debug discord nls videos vulkan"
+
+COMMON_DEPEND="
+ dev-libs/fribidi
+ >=dev-games/physfs-2[zip]
+ dev-db/sqlite:3
+ >=dev-libs/libsodium-1.0.14:=
+ media-libs/freetype:2
+ media-libs/harfbuzz:=
+ media-libs/libogg
+ media-libs/libpng:=
+ media-libs/libsdl2[opengl,video,X]
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/opus
+ net-libs/miniupnpc:=
+ net-misc/curl
+ sys-libs/zlib
+ nls? ( virtual/libintl )
+ vulkan? ( media-libs/libsdl2:=[vulkan] )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ media-libs/fontconfig
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ media-fonts/dejavu
+"
+BDEPEND="
+ app-arch/zip
+ app-text/asciidoc
+ games-util/basis_universal
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+HTML_DOCS=( doc/quickstartguide.html doc/docbook-xsl.css doc/ScriptingManual.htm )
+DOCS=( README.md doc/images doc/Scripting.md doc/js-globals.md )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.1.3-no-compress-manpages.patch
+)
+
+src_unpack() {
+ unpack ${P}.tar.xz
+}
+
+src_prepare() {
+ sed -i -e 's/#top_builddir/top_builddir/' po/Makevars || die
+
+ # Delete translations we're not using
+ cleanup_po() {
+ local locale=${1}
+ einfo "Cleaning up disabled locale: ${locale}"
+ rm po/${locale}.po || die
+ }
+
+ plocale_for_each_disabled_locale cleanup_po
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # TODO: unbundle dev-cpp/nlohmann_json
+ # TODO: unbundle dev-libs/libfmt
+ # TODO: unbundle SQLiteCpp
+ # TODO: unbundle dev-libs/inih
+ local mycmakeargs=(
+ -DWZ_DISTRIBUTOR="Gentoo Linux"
+ -DWZ_ENABLE_WARNINGS_AS_ERRORS=OFF
+ -DWZ_ENABLE_BACKEND_VULKAN=$(usex vulkan)
+ -DBUILD_SHARED_LIBS=OFF
+ -DENABLE_NLS=$(usex nls)
+ -DENABLE_DISCORD=$(usex discord)
+
+ -DFMT_INSTALL=OFF
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ asciidoc -b html5 doc/quickstartguide.asciidoc || die
+}
+
+src_install() {
+ cmake_src_install
+
+ # We cover licencing within the ebuild itself
+ rm "${ED}"/usr/share/doc/${PF}/COPYING* \
+ "${ED}"/usr/share/doc/${PF}/copyright || die
+
+ if use videos ; then
+ insinto /usr/share/${PN}
+ newins "${DISTDIR}"/${VIDEOS_P} sequences.wz
+ fi
+}