summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-23 21:41:15 +0100
committerSam James <sam@gentoo.org>2020-08-23 21:50:37 +0100
commitc947c0af699d8206b1a9a0d904de690ac13100a0 (patch)
treef023dcb19462a173b86cae1525a659f0bf510c36 /games-simulation
parentnet-firewall/nftables: Stabilize 0.9.6 arm64, #738464 (diff)
downloadgentoo-c947c0af699d8206b1a9a0d904de690ac13100a0.tar.gz
gentoo-c947c0af699d8206b1a9a0d904de690ac13100a0.tar.bz2
gentoo-c947c0af699d8206b1a9a0d904de690ac13100a0.zip
games-simulation/corsix-th: bump to 0.64
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/corsix-th/Manifest1
-rw-r--r--games-simulation/corsix-th/corsix-th-0.64.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/games-simulation/corsix-th/Manifest b/games-simulation/corsix-th/Manifest
index 6ae73ede0f5c..ae594593e6fe 100644
--- a/games-simulation/corsix-th/Manifest
+++ b/games-simulation/corsix-th/Manifest
@@ -1 +1,2 @@
DIST corsix-th-0.63.tar.gz 4040119 BLAKE2B a700264c21377d53fb031c57428e5a50bbef426f32a3cd8bc4f83174a7f12b76d72050885ae257a6017a03f2f9611106cf9226c606ef726c1220b997eacbc5f1 SHA512 73a170bbf3da0e11ffe30fcbafb80f9e3852ce992dd6ecae2a2da332b9d4927a98efb0208e2056918a4100db54d1bdc564454cadae370cfab87625ca3f9889fd
+DIST corsix-th-0.64.tar.gz 4062048 BLAKE2B 2b807a5c712a19cac80bae613065dd8c9e1219573a3c288c1433b6fa857c3a93632e9c51ba126a70626b4044d469ca1ebc815257f291fa9f86ea94491aae35fe SHA512 c02d07ae4fb9a1ce008f32c4b9ea12a949316feddca4e2a29e860e0d88efdfa0440d372b00b9d3eda5e5c3ca739085510ebe8650790d06a7e91255b7d0990e6c
diff --git a/games-simulation/corsix-th/corsix-th-0.64.ebuild b/games-simulation/corsix-th/corsix-th-0.64.ebuild
new file mode 100644
index 000000000000..78a3d26cfd7a
--- /dev/null
+++ b/games-simulation/corsix-th/corsix-th-0.64.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg
+
+MY_PN="CorsixTH"
+MY_PV="$(ver_rs 2 -)"
+
+DESCRIPTION="Open source clone of Theme Hospital"
+HOMEPAGE="http://corsixth.com"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc +midi +sound +truetype +videos"
+
+RDEPEND="
+ >=dev-lang/lua-5.1:0
+ >=dev-lua/luafilesystem-1.5
+ >=dev-lua/lpeg-0.9
+ >=dev-lua/luasocket-3.0_rc1-r4
+ media-libs/libsdl2[opengl,video]
+ sound? ( media-libs/sdl2-mixer[midi?] )
+ truetype? ( >=media-libs/freetype-2.5.3:2 )
+ videos? ( >=media-video/ffmpeg-2.2.3:0= )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen[dot]
+ >=dev-lang/lua-5.1:0
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_AUDIO=$(usex sound)
+ -DWITH_FREETYPE2=$(usex truetype)
+ -DWITH_MOVIES=$(usex videos)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_src_compile doc
+}
+
+src_install() {
+ cmake_src_install
+ dodoc {changelog,CONTRIBUTING}.txt
+
+ docinto html
+ use doc && dodoc -r "${BUILD_DIR}"/doc/*
+}