summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/sumwars
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/sumwars')
-rw-r--r--games-rpg/sumwars/Manifest1
-rw-r--r--games-rpg/sumwars/metadata.xml21
-rw-r--r--games-rpg/sumwars/sumwars-0.5.8.ebuild99
3 files changed, 121 insertions, 0 deletions
diff --git a/games-rpg/sumwars/Manifest b/games-rpg/sumwars/Manifest
new file mode 100644
index 000000000000..f5f277e13b6e
--- /dev/null
+++ b/games-rpg/sumwars/Manifest
@@ -0,0 +1 @@
+DIST sumwars-0.5.8-src.tar.bz2 107811288 SHA256 2f432d5f84708447507f6686b847b8538de373cd951f5842cfec5a09aba0aabf SHA512 ccf156f4484b0aeb8984631321d6691dc180ad63fdfa59d92aaa05ada3e871fc10656f32f9ba1b65abe7342e1481e14ca01f025ffc0ec5797cd8e91d97240cf1 WHIRLPOOL 18658095acc19856f5f70e992ec81e66e86fc52a4480dc0b3b161cab9ed589e12717394f1859682954b5a62edb2241d6c005170a1a6ac0cd6c558f0f29bc1723
diff --git a/games-rpg/sumwars/metadata.xml b/games-rpg/sumwars/metadata.xml
new file mode 100644
index 000000000000..e35e8891bb2f
--- /dev/null
+++ b/games-rpg/sumwars/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>protogenes@web.de</email>
+ <name>Michael Kunz</name>
+ <description>Proxy maintainer. CC him on bugs</description>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <changelog>http://sumwars.org/mantis/changelog_page.php</changelog>
+ <bugs-to>https://sumwars.org/mantis/index.php</bugs-to>
+ <remote-id type="sourceforge">sumwars</remote-id>
+ </upstream>
+ <use>
+ <flag name="tools">Builds editor tools</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-rpg/sumwars/sumwars-0.5.8.ebuild b/games-rpg/sumwars/sumwars-0.5.8.ebuild
new file mode 100644
index 000000000000..ebfc09c717f0
--- /dev/null
+++ b/games-rpg/sumwars/sumwars-0.5.8.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils eutils flag-o-matic gnome2-utils games
+
+DESCRIPTION="a multi-player, 3D action role-playing game"
+HOMEPAGE="http://sumwars.org"
+SRC_URI="mirror://sourceforge/sumwars/${P//_/-}-src.tar.bz2"
+
+LICENSE="GPL-3 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+tools debug"
+
+LANGS="de en it pl pt ru uk"
+for L in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${L}"
+done
+unset L
+
+RDEPEND="
+ >=dev-games/cegui-0.8[ogre]
+ >=dev-games/ogre-1.7.4-r1[freeimage,opengl]
+ dev-games/ois
+ dev-games/physfs
+ >=dev-lang/lua-5.1
+ >=dev-libs/tinyxml-2.6.2-r2
+ media-libs/freealut
+ media-libs/openal
+ media-libs/libogg
+ media-libs/libvorbis
+ >=net-libs/enet-1.3.0
+ x11-libs/libX11
+ x11-libs/libXrandr
+ tools? ( dev-libs/boost )"
+DEPEND=${RDEPEND}
+
+S=${WORKDIR}/${PN}-${PV%_*}
+
+src_configure() {
+ # QA
+ append-flags -fno-strict-aliasing
+
+ use debug && CMAKE_BUILD_TYPE=Debug
+
+ local l langs
+ for l in ${LANGS}; do
+ if use linguas_${l}; then
+ langs="${langs} ${l}"
+ fi
+ done
+
+ [[ -z "${langs}" ]] && langs="en"
+
+ # configure sumwars with cmake
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX=""
+ -DSUMWARS_LANGUAGES="${langs}"
+ -DSUMWARS_NO_TINYXML=ON
+ -DSUMWARS_NO_ENET=ON
+ -DSUMWARS_DOC_DIR="/usr/share/doc/${PF}"
+ -DSUMWARS_EXECUTABLE_DIR="${GAMES_BINDIR}"
+ -DSUMWARS_SHARE_DIR="${GAMES_DATADIR}/${PN}"
+ -DSUMWARS_STANDALONE_MODE=OFF
+ -DSUMWARS_POST_BUILD_COPY=OFF
+ -DSUMWARS_PORTABLE_MODE=OFF
+ -DSUMWARS_RANDOM_REGIONS=ON
+ $(cmake-utils_use tools SUMWARS_BUILD_TOOLS)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ newicon -s 128 share/icon/SumWarsIcon_128x128.png ${PN}.png
+ make_desktop_entry ${PN} "Summoning Wars"
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}