summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/twindistress
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/twindistress')
-rw-r--r--games-puzzle/twindistress/Manifest1
-rw-r--r--games-puzzle/twindistress/files/twindistress-1.1.0-ldflags.patch11
-rw-r--r--games-puzzle/twindistress/files/twindistress-1.1.0-warnings.patch61
-rw-r--r--games-puzzle/twindistress/metadata.xml8
-rw-r--r--games-puzzle/twindistress/twindistress-1.1.0.ebuild60
5 files changed, 141 insertions, 0 deletions
diff --git a/games-puzzle/twindistress/Manifest b/games-puzzle/twindistress/Manifest
new file mode 100644
index 000000000000..3c301f2f2e7b
--- /dev/null
+++ b/games-puzzle/twindistress/Manifest
@@ -0,0 +1 @@
+DIST twind-1.1.0.tar.gz 2837845 SHA256 392a09e92862cf8a89a9b8c6f5ed7255c15c7f058a89d889c32f59ed8da73382 SHA512 f1b3be3e5706ce244dd291b6fba2160605593e51b60344521025daf882509e164aa5c201c8d696e56a64d6f3525d16ecd3fd78cc1b86f39f401d4137b615fe8f WHIRLPOOL bd6c54f7d558d7a099c26aaa420908b2cbaecec7244f7e4ed2e3b1703ce7f433af88e70201a856e55e2d9c8644298c4ae7adae91b467f50507e7cf61a9be4a71
diff --git a/games-puzzle/twindistress/files/twindistress-1.1.0-ldflags.patch b/games-puzzle/twindistress/files/twindistress-1.1.0-ldflags.patch
new file mode 100644
index 000000000000..0ac589d88368
--- /dev/null
+++ b/games-puzzle/twindistress/files/twindistress-1.1.0-ldflags.patch
@@ -0,0 +1,11 @@
+--- Makefile.old 2010-10-19 09:06:48.000000000 +0200
++++ Makefile 2010-10-19 09:06:59.000000000 +0200
+@@ -50,7 +50,7 @@
+ make twind MIXER_LIB= AUDIOFLAG=NOAUDIO
+
+ twind: twind.o
+- $(CC) twind.o $(LIBS) $(SDL_LIBS) $(MIXER_LIB) -o twind
++ $(CC) $(LDFLAGS) twind.o $(LIBS) $(SDL_LIBS) $(MIXER_LIB) -o twind
+
+ twind.o: twind.c
+ $(CC) $(CFLAGS) $(SDL_CFLAGS) -c twind.c
diff --git a/games-puzzle/twindistress/files/twindistress-1.1.0-warnings.patch b/games-puzzle/twindistress/files/twindistress-1.1.0-warnings.patch
new file mode 100644
index 000000000000..67ee19149ec8
--- /dev/null
+++ b/games-puzzle/twindistress/files/twindistress-1.1.0-warnings.patch
@@ -0,0 +1,61 @@
+diff -ru twind-1.1.0.orig/twind.c twind-1.1.0/twind.c
+--- twind-1.1.0.orig/twind.c 2004-07-15 21:44:50.000000000 -0400
++++ twind-1.1.0/twind.c 2010-10-19 03:32:44.372280497 -0400
+@@ -674,10 +674,10 @@
+ if (event.button.x >= MENULX && event.button.x < MENURX && event.button.y >= starty && event.button.y < (starty + height)) {
+ current_menu_high = (event.button.y - starty) / game.font[font].height;
+ /* re-assign current_menu_high if blank option */
+- if (menu_items[game.menu][current_menu_high] == "")
++ if (*menu_items[game.menu][current_menu_high] == '\0')
+ current_menu_high = game.last_menu_high;
+ if (game.last_menu_high != current_menu_high) {
+- if (menu_items[game.menu][current_menu_high] != "") {
++ if (*menu_items[game.menu][current_menu_high] != '\0') {
+ #ifndef NOAUDIO
+ if (game.audio_enabled) Mix_PlayChannel(MENU_OPTION, game.sound[MENU_OPTION], 0);
+ #endif
+@@ -697,7 +697,7 @@
+ if (event.button.x >= MENULX && event.button.x < MENURX && event.button.y >= starty && event.button.y < (starty + height)) {
+ current_menu_high = (event.button.y - starty) / game.font[font].height;
+ /* make sure the option isn't blank */
+- if (menu_items[game.menu][current_menu_high] != "") {
++ if (*menu_items[game.menu][current_menu_high] != '\0') {
+ #ifndef NOAUDIO
+ if (game.audio_enabled) Mix_PlayChannel(OPTION_CHOICE, game.sound[OPTION_CHOICE], 0);
+ #endif
+@@ -917,7 +917,7 @@
+ #endif
+ current_menu_high--;
+ /* if option blank, go to previous */
+- while (menu_items[game.menu][current_menu_high] == "")
++ while (*menu_items[game.menu][current_menu_high] == '\0')
+ current_menu_high--;
+ /* wrap around to the bottom entry */
+ if (current_menu_high == -1)
+@@ -930,7 +930,7 @@
+ #endif
+ current_menu_high++;
+ /* if option blank, go to next */
+- while (menu_items[game.menu][current_menu_high] == "")
++ while (*menu_items[game.menu][current_menu_high] == '\0')
+ current_menu_high++;
+ /* wrap around to the top entry */
+ if (current_menu_high == game.menu_item_cnt)
+@@ -1536,7 +1536,7 @@
+ if (level_time && game.stop_timer + game.added_time < game.best_time)
+ game.best_time = game.stop_timer + game.added_time;
+ /* subtract a set amount of time after level 11 */
+- if (game.current_level > 11)
++ if (game.current_level >= 11)
+ game.level_time -= 10;
+ else
+ game.level_time = times[level_time];
+@@ -1546,7 +1546,7 @@
+ break;
+ }
+ /* increase time for next level */
+- if (level_time != 12)
++ if (level_time != 10)
+ level_time++;
+ }
+ if (game.exit_game != NEW_GAME) {
diff --git a/games-puzzle/twindistress/metadata.xml b/games-puzzle/twindistress/metadata.xml
new file mode 100644
index 000000000000..18f5be0deaa6
--- /dev/null
+++ b/games-puzzle/twindistress/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">twind</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-puzzle/twindistress/twindistress-1.1.0.ebuild b/games-puzzle/twindistress/twindistress-1.1.0.ebuild
new file mode 100644
index 000000000000..c982c6481767
--- /dev/null
+++ b/games-puzzle/twindistress/twindistress-1.1.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+MY_P="twind-${PV}"
+DESCRIPTION="Match and remove all of the blocks before time runs out"
+HOMEPAGE="http://twind.sourceforge.net/"
+SRC_URI="mirror://sourceforge/twind/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]
+ media-libs/sdl-mixer
+ media-libs/sdl-image[png]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i \
+ -e '/^CC/d' \
+ -e "/^CFLAGS/s:-g:${CFLAGS}:" \
+ -e "/^DATA_PREFIX/s:/.*$:${GAMES_DATADIR}/${PN}/:" \
+ -e "/^HIGH_SCORE_PREFIX/s:/.*$:${GAMES_STATEDIR}/${PN}/:" \
+ Makefile || die "sed failed"
+ epatch \
+ "${FILESDIR}"/${P}-ldflags.patch \
+ "${FILESDIR}"/${P}-warnings.patch
+}
+
+src_install() {
+ dogamesbin twind
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r graphics music sound
+
+ doicon graphics/twind.png
+ make_desktop_entry twind "Twin Distress"
+
+ dodoc AUTHORS ChangeLog CREDITS NEWS README TODO
+
+ dodir "${GAMES_STATEDIR}/${PN}"
+ touch "${D}/${GAMES_STATEDIR}/${PN}/twind.hscr"
+ fperms 660 "${GAMES_STATEDIR}/${PN}/twind.hscr"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if ! has_version "media-libs/sdl-mixer[vorbis]" ; then
+ ewarn "Music support will be disabled since sdl-mixer"
+ ewarn "wasn't built with USE=vorbis"
+ fi
+}