summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/pauker
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/pauker')
-rw-r--r--games-puzzle/pauker/Manifest1
-rw-r--r--games-puzzle/pauker/files/pauker_bundledjars.patch14
-rw-r--r--games-puzzle/pauker/metadata.xml8
-rw-r--r--games-puzzle/pauker/pauker-1.8.ebuild70
4 files changed, 93 insertions, 0 deletions
diff --git a/games-puzzle/pauker/Manifest b/games-puzzle/pauker/Manifest
new file mode 100644
index 000000000000..4ecdb7c69ac1
--- /dev/null
+++ b/games-puzzle/pauker/Manifest
@@ -0,0 +1 @@
+DIST pauker-1.8.src.jar 33886665 SHA256 061be727408413696d148285d268a2cb37262a19d6d8a26b67d2233507545e05 SHA512 2d329571e857a05116ba499c4bd82669f0c99a748ca375ab06e701492a814b97fcc09bbf0ae4f48c52b05c67768a14d70a4217fee9680762424c96ab7f4341ae WHIRLPOOL fc3e6cbcc0164656337002e89f880b4f1f075892f62ef561deb25671b764f25872e438d54cf72e1ff701e0b8c9ceab621027d9b360eed65f2d3d23682f8d20e5
diff --git a/games-puzzle/pauker/files/pauker_bundledjars.patch b/games-puzzle/pauker/files/pauker_bundledjars.patch
new file mode 100644
index 000000000000..1ed79dbe4d86
--- /dev/null
+++ b/games-puzzle/pauker/files/pauker_bundledjars.patch
@@ -0,0 +1,14 @@
+--- build.xml.orig 2008-11-24 20:24:55.000000000 +1300
++++ build.xml 2008-11-24 20:25:33.000000000 +1300
+@@ -88,11 +88,6 @@
+ basedir="build/classes/"
+ includes="pauker/**,tools/**"
+ excludes="pauker/Changes.txt,pauker/TODO.txt,**/*BeanInfo*,**/GraphicalStatisticPanel.gif">
+- <zipfileset src="${libs.swing-layout.classpath}"/>
+- <zipfileset src="libs/jhall.jar" excludes="META-INF/**"/>
+- <zipfileset src="libs/lucene-core-2.4.0.jar" excludes="META-INF/**"/>
+- <zipfileset src="libs/BrowserLauncher2-1_3.jar"
+- excludes="META-INF/**,classes/,source/,package?cache/,.**,*.txt,build.xml"/>
+ <manifest>
+ <attribute name="Main-Class" value="pauker.program.gui.swing.PaukerFrame"/>
+ <attribute name="SplashScreen-Image" value="pauker/icons/Splash.png"/>
diff --git a/games-puzzle/pauker/metadata.xml b/games-puzzle/pauker/metadata.xml
new file mode 100644
index 000000000000..719168a735e3
--- /dev/null
+++ b/games-puzzle/pauker/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">pauker</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-puzzle/pauker/pauker-1.8.ebuild b/games-puzzle/pauker/pauker-1.8.ebuild
new file mode 100644
index 000000000000..54c6402ddd49
--- /dev/null
+++ b/games-puzzle/pauker/pauker-1.8.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+JAVA_PKG_IUSE="doc source"
+inherit eutils java-pkg-2 java-ant-2 games
+
+DESCRIPTION="A java based flashcard program"
+HOMEPAGE="http://pauker.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pauker/${P}.src.jar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+COMMON_DEP="dev-java/browserlauncher2:1.0
+ dev-java/javahelp
+ dev-java/lucene:2.4
+ dev-java/swing-layout:1"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip
+ ${COMMON_DEP}"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ games_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+src_prepare() {
+ find . -iname '*.jar' -delete
+
+ epatch "${FILESDIR}/${PN}_bundledjars.patch"
+
+ java-pkg_jar-from --into libs browserlauncher2-1.0 browserlauncher2.jar BrowserLauncher2-1_3.jar
+ java-pkg_jar-from --into libs javahelp jhall.jar
+ java-pkg_jar-from --into libs lucene-2.4 lucene-core.jar lucene-core-2.4.0.jar
+ java-pkg_jar-from --into libs swing-layout-1 swing-layout.jar
+}
+
+src_compile() {
+ eant -Dfile.reference.BrowserLauncher2-1_3.jar="libs/BrowserLauncher2-1_3.jar" \
+ -Dlibs.swing-layout.classpath="libs/swing-layout.jar" \
+ -Dplatforms.JDK_1.5.home="${JAVA_HOME}" jar $(use_doc javadoc)
+}
+
+#test depend on jemmy, a netbeans module. so unless it is packaged separately
+#tests cannot be build.
+
+src_install() {
+ java-pkg_jarinto "${GAMES_DATADIR}/${PN}"
+ java-pkg_newjar "dist/${P}.jar"
+
+ java-pkg_dolauncher ${PN} \
+ -into "${GAMES_PREFIX}" \
+ --pwd "${GAMES_DATADIR}"/${PN} \
+ --main pauker.program.gui.swing.PaukerFrame
+
+ use doc && java-pkg_dojavadoc dist/javadoc
+ use source && java-pkg_dosrc src
+
+ newicon src/pauker/icons/repeat.png ${PN}.png
+ make_desktop_entry pauker Pauker
+ prepgamesdirs
+}