summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-emulation/gxmame
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-emulation/gxmame')
-rw-r--r--games-emulation/gxmame/Manifest1
-rw-r--r--games-emulation/gxmame/files/gxmame-0.35_beta2-glib-single-include.patch13
-rw-r--r--games-emulation/gxmame/files/gxmame-0.35_beta2-ovflfix.patch29
-rw-r--r--games-emulation/gxmame/gxmame-0.35_beta2.ebuild67
-rw-r--r--games-emulation/gxmame/metadata.xml8
5 files changed, 118 insertions, 0 deletions
diff --git a/games-emulation/gxmame/Manifest b/games-emulation/gxmame/Manifest
new file mode 100644
index 000000000000..59f715e722cf
--- /dev/null
+++ b/games-emulation/gxmame/Manifest
@@ -0,0 +1 @@
+DIST gxmame-0.35beta2.tar.gz 697013 SHA256 6d0339bf334f40ff0b972cf5c4df14660c48a2f0bce10f23d6a0feb3d5c83622 SHA512 c2b47c1f3f76d86846302754b31954b81d5b7165f5778153c6e6285bdcc6040c5479009cd70dcf32c86afa245ae8b6fe98af781f0d51acfcb76c8deb76422fe2 WHIRLPOOL 1c9f8d9aca3b8b49edf435f9888dce917992c919c1a869b2da4102fca549bc851ab47ecd4f2b9b2325fa89c6dad8667824ca6bd48ab94da1d8be35d63bb4592e
diff --git a/games-emulation/gxmame/files/gxmame-0.35_beta2-glib-single-include.patch b/games-emulation/gxmame/files/gxmame-0.35_beta2-glib-single-include.patch
new file mode 100644
index 000000000000..83ef4aa075e5
--- /dev/null
+++ b/games-emulation/gxmame/files/gxmame-0.35_beta2-glib-single-include.patch
@@ -0,0 +1,13 @@
+Index: gxmame-0.35beta2/src/gxmame.c
+===================================================================
+--- gxmame-0.35beta2.orig/src/gxmame.c
++++ gxmame-0.35beta2/src/gxmame.c
+@@ -31,7 +31,7 @@
+ #include <unistd.h>
+ #include <signal.h>
+ #include <glib/gprintf.h>
+-#include <glib/gutils.h>
++#include <glib.h>
+ #include <gtk/gtkmain.h>
+ #include <gtk/gtkfilesel.h>
+
diff --git a/games-emulation/gxmame/files/gxmame-0.35_beta2-ovflfix.patch b/games-emulation/gxmame/files/gxmame-0.35_beta2-ovflfix.patch
new file mode 100644
index 000000000000..8831a3e09b61
--- /dev/null
+++ b/games-emulation/gxmame/files/gxmame-0.35_beta2-ovflfix.patch
@@ -0,0 +1,29 @@
+--- src/options.c.old 2010-12-01 10:48:45.000000000 +0100
++++ src/options.c 2010-12-01 10:53:55.000000000 +0100
+@@ -4245,7 +4245,7 @@
+ case XMAME_EXEC_SVGAFX:
+ target->fxgkeepaspect = gtk_toggle_button_get_active (GTK_TOGGLE_BUTTON (fxgkeepaspect_checkbutton));
+ used_text = gtk_editable_get_chars (GTK_EDITABLE (fx_entry), 0, -1);
+- strncpy (target->resolution, used_text, 20);
++ strncpy (target->resolution, used_text, sizeof(target->resolution));
+ g_free (used_text);
+ break;
+
+@@ -4330,7 +4330,7 @@
+ }
+
+ used_text = gtk_editable_get_chars (GTK_EDITABLE (soundfile_entry), 0, -1);
+- strncpy (target->soundfile, used_text, 50);
++ strncpy (target->soundfile, used_text, sizeof(target->soundfile));
+ g_free (used_text);
+
+ target->timer = gtk_toggle_button_get_active (GTK_TOGGLE_BUTTON (timer_checkbutton));
+@@ -4465,7 +4465,7 @@
+ target->skip_disclaimer = gtk_toggle_button_get_active (GTK_TOGGLE_BUTTON (disclaimer_checkbutton));
+ target->skip_gameinfo = gtk_toggle_button_get_active (GTK_TOGGLE_BUTTON (gameinfo_checkbutton));
+ used_text = gtk_editable_get_chars (GTK_EDITABLE (debug_size_combo_entry), 0, -1);
+- strncpy (target->debug_size, used_text, 20);
++ strncpy (target->debug_size, used_text, sizeof(target->debug_size));
+ g_free (used_text);
+ target->use_additional_options = gtk_toggle_button_get_active (GTK_TOGGLE_BUTTON (additional_options_checkbutton));
+ /* here I'm using directly the additional option because I don't know its length */
diff --git a/games-emulation/gxmame/gxmame-0.35_beta2.ebuild b/games-emulation/gxmame/gxmame-0.35_beta2.ebuild
new file mode 100644
index 000000000000..9f8c694f46d5
--- /dev/null
+++ b/games-emulation/gxmame/gxmame-0.35_beta2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils games
+
+MY_P="${PN}-${PV/_beta/beta}"
+DESCRIPTION="frontend for XMame using the GTK library"
+HOMEPAGE="http://gxmame.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gxmame/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE="nls joystick"
+
+RDEPEND="dev-libs/expat
+ >=x11-libs/gtk+-2.4:2
+ >=dev-libs/glib-2.4:2
+ x11-themes/gnome-icon-theme
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-glib-single-include.patch
+ epatch "${FILESDIR}"/${P}-ovflfix.patch
+ sed -i \
+ -e "s:-O2 -fomit-frame-pointer -ffast-math:${CFLAGS}:" \
+ -e "s:-O2:${CFLAGS}:" \
+ configure \
+ || die "sed failed"
+ sed -i \
+ -e 's:COPYING::' \
+ -e "s:^docdir = .*:docdir = /usr/share/doc/${PF}:" \
+ -e "s:^htmldir = .*:htmldir = /usr/share/doc/${PF}/html:" \
+ -e "s:^icondir = .*:icondir = /usr/share/icons:" \
+ -e "s:^pixmapdir = .*:pixmapdir = /usr/share/pixmaps:" \
+ -e "s:^gnulocaledir = .*:gnulocaledir = /usr/share/locale:" \
+ -e "s:^icon2dir = .*:icon2dir = /usr/share/icons/mini:" \
+ -e "s:^Graphicsdir = .*:Graphicsdir = /usr/share/applications:" \
+ -e "/DDATADIR/s:\$(datadir):/usr/share/pixmaps:" \
+ -e "/DPACKAGE_LOCALE_DIR/s:\$(datadir):/usr/share:" \
+ Makefile.in html/Makefile.in src/Makefile.in po/Makefile.in.in \
+ || die "sed failed"
+ sed -i \
+ -e 's/"gxmame"/""/' src/gui.c \
+ || die "sed failed"
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-xmame-dir="${GAMES_DATADIR}"/xmame \
+ $(use_enable nls) \
+ $(use_enable joystick)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+ prepgamesdirs
+}
diff --git a/games-emulation/gxmame/metadata.xml b/games-emulation/gxmame/metadata.xml
new file mode 100644
index 000000000000..3172373dc41a
--- /dev/null
+++ b/games-emulation/gxmame/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">gxmame</remote-id>
+ </upstream>
+</pkgmetadata>