summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-09-07 13:34:44 -0500
committerAustin English <wizardedit@gentoo.org>2016-09-07 13:37:33 -0500
commitd5715053ec00ff485fa2bf770563e37252e464e9 (patch)
treefd17628aac037ad7bd0eabde67e8bbfbd018cc3f /games-board
parentdev-db/postgresql: Bump to 9.6_rc1 (diff)
downloadgentoo-d5715053ec00ff485fa2bf770563e37252e464e9.tar.gz
gentoo-d5715053ec00ff485fa2bf770563e37252e464e9.tar.bz2
gentoo-d5715053ec00ff485fa2bf770563e37252e464e9.zip
games-board/gtkboard: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gtkboard/files/gtkboard-0.11_pre0-gcc41.patch8
-rw-r--r--games-board/gtkboard/files/gtkboard-0.11_pre0-gcc45.patch8
-rw-r--r--games-board/gtkboard/gtkboard-0.11_pre0-r1.ebuild52
3 files changed, 60 insertions, 8 deletions
diff --git a/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc41.patch b/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc41.patch
index 2e6a4c6f83ce..f14096e155d1 100644
--- a/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc41.patch
+++ b/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc41.patch
@@ -1,7 +1,7 @@
gcc-4.1 patch from debian.
---- src/board.c
-+++ src/board.c
+--- a/src/board.c
++++ b/src/board.c
@@ -74,7 +74,7 @@
//! default background
char board_default_colors [9] = {215, 215, 215, 215, 215, 215, 0, 0, 0};
@@ -11,8 +11,8 @@ gcc-4.1 patch from debian.
extern void ui_make_human_move (byte *move, int *rmove);
---- src/menu.c
-+++ src/menu.c
+--- a/src/menu.c
++++ b/src/menu.c
@@ -829,7 +829,7 @@
{
diff --git a/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc45.patch b/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc45.patch
index 300e528c9ef7..dd5a2f92a1e2 100644
--- a/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc45.patch
+++ b/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc45.patch
@@ -1,5 +1,5 @@
---- src/menu.c.old 2010-05-24 12:35:15.000000000 +0200
-+++ src/menu.c 2010-05-24 12:35:48.000000000 +0200
+--- a/src/menu.c 2010-05-24 12:35:15.000000000 +0200
++++ b/src/menu.c 2010-05-24 12:35:48.000000000 +0200
@@ -176,7 +176,7 @@
{
#if GTK_MAJOR_VERSION == 2
@@ -9,8 +9,8 @@
static char pixbufs [7][size*(size+1)];
char **pixmap_data;
static GdkPixmap *pixmaps[7];
---- src/wordtris.c.old 2010-05-24 12:36:50.000000000 +0200
-+++ src/wordtris.c 2010-05-24 12:38:30.000000000 +0200
+--- a/src/wordtris.c 2010-05-24 12:36:50.000000000 +0200
++++ b/src/wordtris.c 2010-05-24 12:38:30.000000000 +0200
@@ -122,7 +122,7 @@
// TODO: change this so that we only need to specify pixmaps for individual squares
diff --git a/games-board/gtkboard/gtkboard-0.11_pre0-r1.ebuild b/games-board/gtkboard/gtkboard-0.11_pre0-r1.ebuild
new file mode 100644
index 000000000000..4707667fefc5
--- /dev/null
+++ b/games-board/gtkboard/gtkboard-0.11_pre0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+MY_P=${P/_}
+DESCRIPTION="Board games system"
+HOMEPAGE="http://gtkboard.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gnome"
+
+RDEPEND="x11-libs/gtk+:2
+ media-libs/libsdl:0[sound]
+ media-libs/sdl-mixer[vorbis]
+ gnome? ( gnome-base/libgnomeui )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc41.patch
+ "${FILESDIR}"/${P}-gcc45.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e "/^LIBS/s:@LIBS@:@LIBS@ -lgmodule-2.0 -lm:" \
+ src/Makefile.in
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --enable-gtk2 \
+ --enable-sdl \
+ $(use_enable gnome)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doicon pixmaps/${PN}.png
+ make_desktop_entry ${PN} Gtkboard
+ dodoc AUTHORS ChangeLog TODO doc/index.html
+}