summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-07-20 23:05:47 -0400
committerDavid Seifert <soap@gentoo.org>2017-07-30 11:09:10 +0200
commit56f42357d0ae0208813406989a847c2fa5d9812d (patch)
tree3b63293790c96fd4f6c27d6b8b7ff20fa0f401fc /games-arcade
parentgames-strategy/asc: Fix building with -Werror=terminate (diff)
downloadgentoo-56f42357d0ae0208813406989a847c2fa5d9812d.tar.gz
gentoo-56f42357d0ae0208813406989a847c2fa5d9812d.tar.bz2
gentoo-56f42357d0ae0208813406989a847c2fa5d9812d.zip
games-arcade/criticalmass: Fix building with GCC-6
Bug: https://bugs.gentoo.org/show_bug.cgi?id=612758 Package-Manager: Portage-2.3.6, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/5156
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/criticalmass/criticalmass-1.0.2.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/games-arcade/criticalmass/criticalmass-1.0.2.ebuild b/games-arcade/criticalmass/criticalmass-1.0.2.ebuild
index dfb5bb085d9b..b3e5262bb5d1 100644
--- a/games-arcade/criticalmass/criticalmass-1.0.2.ebuild
+++ b/games-arcade/criticalmass/criticalmass-1.0.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit autotools eutils games
+inherit autotools eutils flag-o-matic games
DESCRIPTION="SDL/OpenGL space shoot'em up game"
HOMEPAGE="http://criticalmass.sourceforge.net/"
@@ -32,6 +32,11 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ append-cxxflags -std=gnu++98 # Bug 612758
+ default
+}
+
src_install() {
default
rm -f "${D}${GAMES_BINDIR}/Packer"