summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/apricots
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/apricots')
-rw-r--r--games-arcade/apricots/Manifest1
-rw-r--r--games-arcade/apricots/apricots-0.2.6-r1.ebuild65
-rw-r--r--games-arcade/apricots/files/apricots-0.2.6-freealut.patch65
-rw-r--r--games-arcade/apricots/files/apricots-0.2.6-ldflags.patch20
-rw-r--r--games-arcade/apricots/metadata.xml5
5 files changed, 156 insertions, 0 deletions
diff --git a/games-arcade/apricots/Manifest b/games-arcade/apricots/Manifest
new file mode 100644
index 000000000000..b61ec221d08b
--- /dev/null
+++ b/games-arcade/apricots/Manifest
@@ -0,0 +1 @@
+DIST apricots-0.2.6.tar.gz 768568 SHA256 9c408722abbb0cb925384f12a65fe4f6e2b3373d5ce5d0e5afe3aeb738b9cd8f SHA512 cf8a988d316382469e4b13a86315c760b702b3d490398cf2fe96f119ba743c1ff707c09228dbbf4eb601189fece708913a621b04c44e9d93162639ccbd502cf5 WHIRLPOOL e45b924f86494e16ea4340a292aabb624a0632801044250b082e6b449311b47a89c23386eb88c507053c3629af4ecb8db4bc4d7096887fa884d5395474f3e946
diff --git a/games-arcade/apricots/apricots-0.2.6-r1.ebuild b/games-arcade/apricots/apricots-0.2.6-r1.ebuild
new file mode 100644
index 000000000000..20093ee5eee1
--- /dev/null
+++ b/games-arcade/apricots/apricots-0.2.6-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils games
+
+DESCRIPTION="Fly a plane around bomb/shoot the enemy. Port of Planegame from Amiga"
+HOMEPAGE="http://www.fishies.org.uk/apricots.html"
+SRC_URI="http://www.fishies.org.uk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/openal
+ media-libs/freealut"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-freealut.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
+
+ cp admin/acinclude.m4.in acinclude.m4
+
+ sed -i \
+ -e 's:-DAP_PATH=\\\\\\"$prefix.*":-DAP_PATH=\\\\\\"${GAMES_DATADIR}/${PN}/\\\\\\"":' \
+ -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' \
+ configure.in || die
+ sed -i \
+ -e "s:filename(AP_PATH):filename(\"${GAMES_SYSCONFDIR}/${PN}/\"):" \
+ ${PN}/init.cpp || die
+ sed -i \
+ -e "s:apricots.cfg:${GAMES_SYSCONFDIR}/${PN}/apricots.cfg:" \
+ README apricots.html || die
+ sed -i \
+ -e 's/-Wmissing-prototypes//' \
+ acinclude.m4 || die
+ eautoreconf
+}
+
+src_compile() {
+ emake LIBTOOL="/usr/bin/libtool"
+}
+
+src_install() {
+ dodoc AUTHORS README TODO ChangeLog
+ dohtml apricots.html
+ cd ${PN}
+ dogamesbin apricots
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins *.wav *.psf *.shapes
+ insinto "${GAMES_SYSCONFDIR}"/${PN}
+ doins apricots.cfg
+ make_desktop_entry ${PN} Apricots
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "You can change the game options by editing:"
+ elog "${GAMES_SYSCONFDIR}/${PN}/apricots.cfg"
+}
diff --git a/games-arcade/apricots/files/apricots-0.2.6-freealut.patch b/games-arcade/apricots/files/apricots-0.2.6-freealut.patch
new file mode 100644
index 000000000000..4f663071340a
--- /dev/null
+++ b/games-arcade/apricots/files/apricots-0.2.6-freealut.patch
@@ -0,0 +1,65 @@
+--- apricots/apricots.cpp
++++ apricots/apricots.cpp
+@@ -16,6 +16,7 @@
+ int main(int, char**){
+ #endif
+
++atexit(SDL_Quit);
+ // Initialize data
+ gamedata g;
+ init_data(g);
+
+--- apricots/sampleio.cpp
++++ apricots/sampleio.cpp
+@@ -74,12 +74,9 @@
+ alListenerfv(AL_ORIENTATION, front );
+
+ // Load in samples
+- ALvoid* data = malloc(5 * (512 * 3) * 1024);
+ alGenBuffers(numsamples, samples);
+
+ for (int i = 0; i < numsamples; i++){
+- ALsizei freq;
+- ALboolean fileok;
+ // Evil OpenAL portability fix done here
+ #ifdef _WIN32
+ ALenum format;
+@@ -87,15 +84,12 @@
+ alutLoadWAVFile(filenames[i],&format,&data,&filelen,&freq,&trash);
+ fileok = (alGetError() == AL_NO_ERROR);
+ #else
+- ALsizei format;
+- ALsizei trash;
+- fileok = alutLoadWAV(filenames[i],&data,&format,&filelen,&trash,&freq);
++ samples[i] = alutCreateBufferFromFile(filenames[i]);
+ #endif
+- if (!fileok){
++ if (samples[i] == AL_NONE){
+ cerr << "sampleio: could not open " << filenames[i] << endl;
+ exit(1);
+ }
+- alBufferData(samples[i], format, data, filelen, freq);
+ }
+
+ // Generate Sources
+@@ -107,7 +101,6 @@
+ alSourcefv(sources[j], AL_ORIENTATION, back );
+ }
+
+- free(data);
+
+ }
+
+
+--- configure.in
++++ configure.in
+@@ -100,7 +100,8 @@
+
+ dnl Check for OpenAL
+ AC_CHECK_HEADER(AL/al.h,[CXXFLAGS="$CXXFLAGS -DAP_AUDIO_OPENAL"])
+-AC_CHECK_LIB( openal, alutInit)
++AC_CHECK_LIB( openal, alGetError)
++AC_CHECK_LIB( alut, alutInit)
+
+ KDE_CHECK_EXTRA_LIBS
+ all_libraries="$all_libraries $USER_LDFLAGS"
diff --git a/games-arcade/apricots/files/apricots-0.2.6-ldflags.patch b/games-arcade/apricots/files/apricots-0.2.6-ldflags.patch
new file mode 100644
index 000000000000..5a2a34490b7e
--- /dev/null
+++ b/games-arcade/apricots/files/apricots-0.2.6-ldflags.patch
@@ -0,0 +1,20 @@
+--- apricots/Makefile.am.old 2010-10-11 15:58:18.000000000 +0200
++++ apricots/Makefile.am 2010-10-11 15:59:21.000000000 +0200
+@@ -4,7 +4,8 @@
+ ## INCLUDES were found outside kdevelop specific part
+
+ apricots_SOURCES = SDLfont.cpp shape.cpp setup.cpp sampleio.cpp init.cpp game.cpp finish.cpp fall.cpp drawall.cpp drak.cpp collide.cpp apricots.cpp all.cpp ai.cpp
+-apricots_LDADD =
++apricots_LDADD = $(all_libraries)
++
+
+ SUBDIRS = docs
+
+@@ -68,7 +69,3 @@
+ ####### kdevelop will overwrite this part!!! (end)############
+ # set the include path found by configure
+ INCLUDES= $(all_includes)
+-
+-# the library search path.
+-apricots_LDFLAGS = $(all_libraries)
+-
diff --git a/games-arcade/apricots/metadata.xml b/games-arcade/apricots/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/apricots/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>