summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-22 20:15:15 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-22 23:16:48 +0200
commit5c4990aaf5ff5c8a95517d080bdd0a90232dc0df (patch)
tree2bf323b944e78acf398041de8ad3e6e87d4045f1 /games-action
parentgames-arcade/blobby: Drop 1.0 (r0) (diff)
downloadgentoo-5c4990aaf5ff5c8a95517d080bdd0a90232dc0df.tar.gz
gentoo-5c4990aaf5ff5c8a95517d080bdd0a90232dc0df.tar.bz2
gentoo-5c4990aaf5ff5c8a95517d080bdd0a90232dc0df.zip
games-action/astromenace: Depends on media-libs/libsdl2
Dropping media-libs/libsdl2[X] USE-dep on request of games proj. Closes: https://bugs.gentoo.org/732678 Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/astromenace/astromenace-1.4.1-r1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/games-action/astromenace/astromenace-1.4.1-r1.ebuild b/games-action/astromenace/astromenace-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..3723df9b1a5a
--- /dev/null
+++ b/games-action/astromenace/astromenace-1.4.1-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake desktop xdg-utils
+
+DESCRIPTION="Hardcore 3D space scroll-shooter with spaceship upgrade possibilities"
+HOMEPAGE="https://viewizard.com"
+SRC_URI="https://github.com/viewizard/astromenace/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 GPL-3+ CC-BY-SA-4.0 OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ media-libs/freealut
+ media-libs/freetype:2
+ media-libs/libogg
+ media-libs/libsdl2[joystick,video,X]
+ media-libs/libvorbis
+ media-libs/openal
+ virtual/glu
+ virtual/opengl
+ x11-libs/libXinerama"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cmake_src_prepare
+
+ # no messing with CXXFLAGS please.
+ sed -i -e '/-Os/d' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=( -DDATADIR="${EPREFIX}/usr/share/${PN}" )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_install() {
+ dobin "${BUILD_DIR}"/astromenace
+
+ insinto /usr/share/${PN}
+ doins "${BUILD_DIR}"/gamedata.vfs
+
+ newicon -s 128 share/astromenace_128.png ${PN}.png
+ newicon -s 64 share/astromenace_64.png ${PN}.png
+
+ einstalldocs
+
+ make_desktop_entry "${PN}" AstroMenace
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}