summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro_gentoo@matoro.tk>2023-12-06 15:15:02 -0500
committerSam James <sam@gentoo.org>2023-12-14 04:20:53 +0000
commitdde8159d0f8360e336c9263eaaff55e304a5ec02 (patch)
treeed365ace0a65dcbae1a505cfbb880a24dfe800e6 /dev-vcs
parentdev-lang/cfortran: add -fcommon to CFLAGS for tests (diff)
downloadgentoo-dde8159d0f8360e336c9263eaaff55e304a5ec02.tar.gz
gentoo-dde8159d0f8360e336c9263eaaff55e304a5ec02.tar.bz2
gentoo-dde8159d0f8360e336c9263eaaff55e304a5ec02.zip
dev-vcs/fossil: unrestrict tests
It's no longer the case that the tests cannot be run from the build directory. While they do technically fail, the failure is currently nonfatal. But there are plans to fix the remaining tests and also make the test script fatal on failure in 2.24: https://fossil-scm.org/forum/forumpost/353f3117d86a0c52bed174979f41d35fa7d476fda1e3ffc757030366cd9860dd Bug: https://bugs.gentoo.org/914535 Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Closes: https://github.com/gentoo/gentoo/pull/34150 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/fossil/fossil-2.22.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-vcs/fossil/fossil-2.22.ebuild b/dev-vcs/fossil/fossil-2.22.ebuild
index 7ffe54ef6335..8905c6cf1d54 100644
--- a/dev-vcs/fossil/fossil-2.22.ebuild
+++ b/dev-vcs/fossil/fossil-2.22.ebuild
@@ -15,7 +15,8 @@ LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 arm ~ppc ppc64 ~riscv x86"
IUSE="debug fusefs json system-sqlite +ssl static tcl tcl-stubs
- tcl-private-stubs th1-docs th1-hooks"
+ tcl-private-stubs test th1-docs th1-hooks"
+RESTRICT="!test? ( test )"
# Please check sqlite minimum version on every release. This can be done with:
# ./configure --print-minimum-sqlite-version
@@ -40,8 +41,7 @@ DEPEND="${RDEPEND}
)
"
-# Tests can't be run from the build directory
-RESTRICT="test"
+BDEPEND="test? ( dev-lang/tcl )"
PATCHES=(
# fossil-2.10-check-lib64-for-tcl.patch: Bug 690828
@@ -72,6 +72,10 @@ src_configure() {
CC_FOR_BUILD=${CC} ./configure ${myconf} || die
}
+src_test() {
+ emake test
+}
+
src_install() {
dobin fossil
}