summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-03 08:13:15 +0100
committerSam James <sam@gentoo.org>2023-05-03 08:13:15 +0100
commitbb1b8dec137a2f27d6d4a92d2064730c6ad73024 (patch)
tree6289ebe05833654dae1a4130063b1ded76d276df /dev-util
parentsys-firmware/nvidia-firmware: Python 3.11 support (diff)
downloadgentoo-bb1b8dec137a2f27d6d4a92d2064730c6ad73024.tar.gz
gentoo-bb1b8dec137a2f27d6d4a92d2064730c6ad73024.tar.bz2
gentoo-bb1b8dec137a2f27d6d4a92d2064730c6ad73024.zip
dev-util/pkgconf: add 1.9.5
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pkgconf/Manifest1
-rw-r--r--dev-util/pkgconf/pkgconf-1.9.5.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-util/pkgconf/Manifest b/dev-util/pkgconf/Manifest
index 2c24c060f05a..06b8f95f2392 100644
--- a/dev-util/pkgconf/Manifest
+++ b/dev-util/pkgconf/Manifest
@@ -1,3 +1,4 @@
DIST pkgconf-1.8.0.tar.xz 296304 BLAKE2B 6585a855a313406f77d26fba3cc3cef798b27c4b7ece81738bdba12f36ee93fbcaf838e1065406c28adc20852e34e2de14bc5f4837982f9cc35360d9a3ac83a5 SHA512 58204006408ad5ce91222ed3c93c2e0b61c04fa83c0a8ad337b747b583744578dbebd4ad5ccbc577689637caa1c5dc246b7795ac46e39c6666b1aa78199b7c28
DIST pkgconf-1.8.1.tar.xz 302372 BLAKE2B 591961f0b1fd185834fd8e2a672199cffc035139599817b1d56d571300d2aa800a719c9477aac4023dfade597ad3cc3b45360babe57498977568ee57077c7bbe SHA512 7a7d5204c1c9bfb6578bda56f299d1fa0300e69a133a65730b10ad77aefbf26fceb74ae77cecda326b3ed5db5736f27fcce94764b3a56d40f4bb99fecdc80bba
DIST pkgconf-1.9.4.tar.xz 309164 BLAKE2B f0a99f9c7aaf571b14aa24b6dae441fb041d794294e560601232c03254e521a49a5724e41c5ada537f7933bb4831b63482896c8569a9502c8c5d841190e1d091 SHA512 079436244f3942161f91c961c96d382a85082079c9843fec5ddd7fb245ba7500a9f7a201b5ef2c70a7a079fe1aacf3a52b73de5402a6f061df87bcdcf0a90755
+DIST pkgconf-1.9.5.tar.xz 310068 BLAKE2B 196babfccbf34c10bf08eb52fe1a4366273e07fcc97fb42d117295bb1cb141811e6a0453597b4aab31dc2bfc06baf9b2507484c68cd6c7474c94e5676a743d0e SHA512 604853d8bb1c3ca14e696f83ac5b161e2592defb921d53e1c16cc949d4b9ecac2b12983c1fbbb3c89898323bda18c8749bff3946e049c8305a1a39a773265f09
diff --git a/dev-util/pkgconf/pkgconf-1.9.5.ebuild b/dev-util/pkgconf/pkgconf-1.9.5.ebuild
new file mode 100644
index 000000000000..1a62309a9c0d
--- /dev/null
+++ b/dev-util/pkgconf/pkgconf-1.9.5.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2012-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://gitea.treehouse.systems/ariadne/pkgconf.git"
+else
+ SRC_URI="https://distfiles.dereferenced.org/${PN}/${P}.tar.xz"
+ # Per release notes, 1.9.x is a testing/development release.
+ #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="pkg-config compatible replacement with no dependencies other than C99"
+HOMEPAGE="https://gitea.treehouse.systems/ariadne/pkgconf"
+
+LICENSE="ISC"
+SLOT="0/4"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-libs/atf
+ dev-util/kyua
+ )
+"
+RDEPEND="!dev-util/pkgconfig"
+
+src_prepare() {
+ default
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+
+ MULTILIB_CHOST_TOOLS=(
+ /usr/bin/pkgconf
+ /usr/bin/pkg-config$(get_exeext)
+ )
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --with-system-includedir="${EPREFIX}/usr/include"
+ --with-system-libdir="${EPREFIX}/$(get_libdir):${EPREFIX}/usr/$(get_libdir)"
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+ unset PKG_CONFIG_LIBDIR PKG_CONFIG_PATH
+ default
+}
+
+multilib_src_install() {
+ default
+
+ dosym pkgconf$(get_exeext) /usr/bin/pkg-config$(get_exeext)
+ dosym pkgconf.1 /usr/share/man/man1/pkg-config.1
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}