summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-02-26 22:38:17 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-02-26 22:38:34 +0000
commitad924e9c8fd9183b84474c2811e534f5dbaca3ba (patch)
tree99365c344991e2f5d4766fe4f749d726f48cf2e8 /dev-util
parentprofiles/arch/sparc/package.use.mask: mask app-crypt/pinentry[efl] (diff)
downloadgentoo-ad924e9c8fd9183b84474c2811e534f5dbaca3ba.tar.gz
gentoo-ad924e9c8fd9183b84474c2811e534f5dbaca3ba.tar.bz2
gentoo-ad924e9c8fd9183b84474c2811e534f5dbaca3ba.zip
dev-util/poke: make USE=static-libs optional
Reported-by: Agostino Sarubbo Closes: https://bugs.gentoo.org/773121 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/poke/poke-1.0.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/dev-util/poke/poke-1.0.ebuild b/dev-util/poke/poke-1.0.ebuild
index 216d65013db5..0397a46a2393 100644
--- a/dev-util/poke/poke-1.0.ebuild
+++ b/dev-util/poke/poke-1.0.ebuild
@@ -11,7 +11,7 @@ KEYWORDS="~amd64 ~x86"
LICENSE="GPL-3"
SLOT="0"
-IUSE="machine-interface nls test"
+IUSE="machine-interface nls static-libs test"
RESTRICT="!test? ( test )"
@@ -38,5 +38,14 @@ src_configure() {
--disable-gui \
--disable-libnbd \
$(use_enable machine-interface mi) \
- $(use_enable nls)
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
}