summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2022-11-09 15:11:04 +0200
committerJimi Huotari <chiitoo@gentoo.org>2022-11-09 15:45:51 +0200
commit53cd00e3ef7d7e3aa8ae0d72825409cd1f970963 (patch)
tree87f66d1d7727459c4f8ace038cbe109a6f8b7b6b /dev-util
parentapp-shells/fzf: Drop old versions (diff)
downloadgentoo-53cd00e3ef7d7e3aa8ae0d72825409cd1f970963.tar.gz
gentoo-53cd00e3ef7d7e3aa8ae0d72825409cd1f970963.tar.bz2
gentoo-53cd00e3ef7d7e3aa8ae0d72825409cd1f970963.zip
dev-util/lxqt-build-tools: add version 0.12.0
Closes: https://bugs.gentoo.org/876478 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/lxqt-build-tools/Manifest1
-rw-r--r--dev-util/lxqt-build-tools/lxqt-build-tools-0.12.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/lxqt-build-tools/Manifest b/dev-util/lxqt-build-tools/Manifest
index abebc93b5666..21be8a785b3a 100644
--- a/dev-util/lxqt-build-tools/Manifest
+++ b/dev-util/lxqt-build-tools/Manifest
@@ -1,3 +1,4 @@
DIST lxqt-build-tools-0.10.0.tar.xz 25312 BLAKE2B 7ba08ee181353454264685f6ec7407cd4858acd55674213a5f2bab123b400e6caae0eb5e803ca4d0dc30b19ca069c0659c4531ac64ee017fcd619560e09195fd SHA512 ee7282344c6fbf09d85f845c60075b6c343ce6b6f8c233c7d664faff3b570e2836192aa2233b951242b66d86254971011d4d0bc225811344829fdc5bc83b0e5f
DIST lxqt-build-tools-0.11.0.tar.xz 25348 BLAKE2B cf342baf8454ea91dfd7a5206b9c1d02737fa5434e8dfdc681218bcc22bd8d7a47fc85acd3d0f54fd75113a32e4440af23f8536e3a87e0051daccfc026e9eef5 SHA512 d421aaf74b13efa3b603b5c8a998bfd6091f5d3c45e0201d64e0c1f12d93c45fdc12d9232b0ac1c98ccf47007560c5814612162d1ac879bb3173bad57164408d
+DIST lxqt-build-tools-0.12.0.tar.xz 25444 BLAKE2B a3e2d942467d1c2affb957052731f4e4edfa03ed7d84e4ff354b4d501a7f79999ff678538f1c90cff55b6f2f80c172820ed93f036f05cd80c6f982c4bf8bbe54 SHA512 6c8f0d8f04a2ba06c1cff935580a88312f18f87b5da99e53f46c053b842f179bf474b3637ddcb0e9a0007f1d03b9e7cfd92a6552e53082ce34348fcfb6436add
DIST lxqt-build-tools-0.9.0.tar.xz 25296 BLAKE2B 9686a445c75a700a38150b4493f6c019ba0782e219b3482f67c6a324f35ffe252fddc614daefbd8616ee16ef8bc331c7e4302ddf2df870d1c3696a80cfb585a8 SHA512 9a464393ea6d871c5856ebf5b8fa3d31a89c6419ac084e7146aed675f2b20a139bb3eedde017d6ca03167ee6e30a37a62239ab4e8b76f5b6db244d26ab164892
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-0.12.0.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-0.12.0.ebuild
new file mode 100644
index 000000000000..2a46e551aa83
--- /dev/null
+++ b/dev-util/lxqt-build-tools/lxqt-build-tools-0.12.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt Build Tools"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=dev-qt/qtcore-5.15:5
+"
+RDEPEND="${DEPEND}"