summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-12-19 20:54:05 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-12-19 21:44:37 +0100
commit2037667751bb8617d2d74069dcd492a45ee7ce30 (patch)
tree5a2b0c1854868ff2ef629f41bbd65bc3608bb4e3 /dev-util
parentkde-misc/zanshin: drop 23.04.3 (diff)
downloadgentoo-2037667751bb8617d2d74069dcd492a45ee7ce30.tar.gz
gentoo-2037667751bb8617d2d74069dcd492a45ee7ce30.tar.bz2
gentoo-2037667751bb8617d2d74069dcd492a45ee7ce30.zip
dev-util/kdevelop: drop 23.04.3
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/kdevelop/Manifest1
-rw-r--r--dev-util/kdevelop/files/kdevelop-23.04.2-astyle-3.4.patch62
-rw-r--r--dev-util/kdevelop/kdevelop-23.04.3.ebuild133
3 files changed, 0 insertions, 196 deletions
diff --git a/dev-util/kdevelop/Manifest b/dev-util/kdevelop/Manifest
index a37ec4b19f33..c1c7247b6ff9 100644
--- a/dev-util/kdevelop/Manifest
+++ b/dev-util/kdevelop/Manifest
@@ -1,3 +1,2 @@
-DIST kdevelop-23.04.3.tar.xz 8659696 BLAKE2B f5b8459e49f81aaeeceddc2529ba57c3b3d8956cb0562c9a1ae86424f31c0fdce9624e95ddd3bb69b893ff7342863b870377a9e9c76be2c85d54d3c970d24991 SHA512 f6734aada66757f03cf50793b3ba601748e5494c6cc4dbfba928927d7cf5c07a9522c4f506ef908ebe9b2a6f212e2f360b313c32398c1284adb43c43609f581c
DIST kdevelop-23.08.3.tar.xz 8707808 BLAKE2B 8081dde177543854013358a26e4c54ac8c489b0fd74c57e82578ea5041a2847d160f1172d9892df1e9741a06c172653028e8776d3cdcbf63ff6c533a494c775d SHA512 3a2a81ec699fcab8de2788e49dc0a6174c4191bcc6e2f3da8c71f65ab43fea8df11455f9f26141125ffa987c040d366477deb28a03ac16b761f19773afd11daf
DIST kdevelop-23.08.4.tar.xz 8707260 BLAKE2B 4bd88e2165261f771edc36f45b68a86434a252ae2f5ff638641ce8b9c2d76e38eceefb243310dd2c8181e704746985b612d02664db61c83a164a293151ea3f20 SHA512 e5a1bf3b6c46006165a6169fdfe244d02bff945c8dd01d0b5897a0752b4759c03f58ce136e636366b14b3b27e91aa14b29b0f432589a2114f45fbdf2a3cf3135
diff --git a/dev-util/kdevelop/files/kdevelop-23.04.2-astyle-3.4.patch b/dev-util/kdevelop/files/kdevelop-23.04.2-astyle-3.4.patch
deleted file mode 100644
index e5a73298aa19..000000000000
--- a/dev-util/kdevelop/files/kdevelop-23.04.2-astyle-3.4.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From 8ca40a6454f053a262926794b96024bd02e0cdc5 Mon Sep 17 00:00:00 2001
-From: Milian Wolff <mail@milianw.de>
-Date: Wed, 31 May 2023 09:31:02 +0200
-Subject: [PATCH] Fix compile with newer astyle
-
-astyle::streamoff was always just an alias for std::streamoff,
-see also the upstream commit [1] that removed the
-`using namespace std` in the `astyle` namespace which breaks this
-code of our here now.
-
-[1]: https://gitlab.com/saalen/astyle/-/commit/0add646b21ee329b231ef7c5ab6963a94fb8935b
----
- plugins/astyle/astyle_stringiterator.cpp | 4 ++--
- plugins/astyle/astyle_stringiterator.h | 5 +++--
- 2 files changed, 5 insertions(+), 4 deletions(-)
-
-diff --git a/plugins/astyle/astyle_stringiterator.cpp b/plugins/astyle/astyle_stringiterator.cpp
-index 02f8fb4264..a611869581 100644
---- a/plugins/astyle/astyle_stringiterator.cpp
-+++ b/plugins/astyle/astyle_stringiterator.cpp
-@@ -22,7 +22,7 @@ AStyleStringIterator::~AStyleStringIterator()
- {
- }
-
--astyle::streamoff AStyleStringIterator::tellg()
-+std::streamoff AStyleStringIterator::tellg()
- {
- return m_is.pos();
- }
-@@ -59,7 +59,7 @@ void AStyleStringIterator::peekReset()
- m_peekStart = -1; // invalid
- }
-
--astyle::streamoff AStyleStringIterator::getPeekStart() const
-+std::streamoff AStyleStringIterator::getPeekStart() const
- {
- // NOTE: we're not entirely sure if this is the correct implementation.
- // we're trying to work-around https://bugs.kde.org/show_bug.cgi?id=399048
-diff --git a/plugins/astyle/astyle_stringiterator.h b/plugins/astyle/astyle_stringiterator.h
-index f63a59c611..713800c0f3 100644
---- a/plugins/astyle/astyle_stringiterator.h
-+++ b/plugins/astyle/astyle_stringiterator.h
-@@ -21,13 +21,14 @@ public:
- explicit AStyleStringIterator(const QString &string);
- ~AStyleStringIterator() override;
-
-- astyle::streamoff tellg() override;
-+ std::streamoff tellg() override;
- int getStreamLength() const override;
- bool hasMoreLines() const override;
- std::string nextLine(bool emptyLineWasDeleted = false) override;
- std::string peekNextLine() override;
- void peekReset() override;
-- astyle::streamoff getPeekStart() const override;
-+ std::streamoff getPeekStart() const override;
-+
- private:
- QString m_content;
- QTextStream m_is;
---
-GitLab
-
diff --git a/dev-util/kdevelop/kdevelop-23.04.3.ebuild b/dev-util/kdevelop/kdevelop-23.04.3.ebuild
deleted file mode 100644
index e14fe774bc7f..000000000000
--- a/dev-util/kdevelop/kdevelop-23.04.3.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ECM_HANDBOOK="forceoptional"
-ECM_TEST="true"
-KDE_ORG_CATEGORY="kdevelop"
-KFMIN=5.106.0
-LLVM_MAX_SLOT=16
-QTMIN=5.15.9
-VIRTUALDBUS_TEST="true"
-inherit ecm gear.kde.org llvm optfeature
-
-DESCRIPTION="Integrated Development Environment, supporting KF5/Qt, C/C++ and much more"
-HOMEPAGE="https://www.kdevelop.org/"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="5/$(ver_cut 1-2)"
-KEYWORDS="amd64 arm64 ~ppc64 ~x86"
-IUSE="+gdbui hex +plasma +qmake reviewboard subversion"
-
-# see bug 366471
-RESTRICT="test"
-
-COMMON_DEPEND="
- dev-libs/grantlee:5
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtdeclarative-${QTMIN}:5[widgets]
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qthelp-${QTMIN}:5
- >=dev-qt/qtnetwork-${QTMIN}:5
- >=dev-qt/qttest-${QTMIN}:5
- >=dev-qt/qtwebengine-${QTMIN}:5[widgets]
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=dev-qt/qtxml-${QTMIN}:5
- >=dev-util/astyle-3.1:=
- kde-apps/libkomparediff2:5
- >=kde-frameworks/karchive-${KFMIN}:5
- >=kde-frameworks/kbookmarks-${KFMIN}:5
- >=kde-frameworks/kcmutils-${KFMIN}:5
- >=kde-frameworks/kcodecs-${KFMIN}:5
- >=kde-frameworks/kcompletion-${KFMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kconfigwidgets-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/kcrash-${KFMIN}:5
- >=kde-frameworks/kdeclarative-${KFMIN}:5
- >=kde-frameworks/kguiaddons-${KFMIN}:5
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kiconthemes-${KFMIN}:5
- >=kde-frameworks/kio-${KFMIN}:5
- >=kde-frameworks/kitemmodels-${KFMIN}:5
- >=kde-frameworks/kitemviews-${KFMIN}:5
- >=kde-frameworks/kjobwidgets-${KFMIN}:5
- >=kde-frameworks/knewstuff-${KFMIN}:5
- >=kde-frameworks/knotifications-${KFMIN}:5
- >=kde-frameworks/knotifyconfig-${KFMIN}:5
- >=kde-frameworks/kparts-${KFMIN}:5
- >=kde-frameworks/kservice-${KFMIN}:5
- >=kde-frameworks/ktexteditor-${KFMIN}:5
- >=kde-frameworks/ktextwidgets-${KFMIN}:5
- >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
- >=kde-frameworks/kwindowsystem-${KFMIN}:5
- >=kde-frameworks/kxmlgui-${KFMIN}:5
- >=kde-frameworks/sonnet-${KFMIN}:5
- >=kde-frameworks/threadweaver-${KFMIN}:5
- <sys-devel/clang-$((${LLVM_MAX_SLOT} + 1)):=
- gdbui? ( kde-plasma/libksysguard:5= )
- hex? ( app-editors/okteta:5 )
- plasma? (
- >=kde-frameworks/krunner-${KFMIN}:5
- >=kde-plasma/libplasma-${KFMIN}:5
- )
- qmake? ( dev-util/kdevelop-pg-qt:5 )
- reviewboard? ( >=kde-frameworks/purpose-${KFMIN}:5 )
- subversion? (
- dev-libs/apr:1
- dev-libs/apr-util:1
- dev-vcs/subversion
- )
-"
-DEPEND="${COMMON_DEPEND}
- dev-libs/boost
- >=dev-qt/qtconcurrent-${QTMIN}:5
-"
-RDEPEND="${COMMON_DEPEND}
- >=dev-qt/qdbus-${QTMIN}:*
- >=dev-qt/qtquickcontrols-${QTMIN}:5
- >=dev-qt/qtquickcontrols2-${QTMIN}:5
- dev-util/ninja
- kde-apps/kapptemplate:5
- kde-apps/kio-extras:5
- >=sys-devel/gdb-7.0[python]
- reviewboard? ( kde-apps/ktp-accounts-kcm:5 )
-"
-
-PATCHES=( "${FILESDIR}/${PN}-23.04.2-astyle-3.4.patch" ) # bug 908977
-
-llvm_check_deps() {
- has_version -d "sys-devel/clang:${LLVM_SLOT}"
-}
-
-src_configure() {
- local mycmakeargs=(
- -DLLVM_ROOT="$(get_llvm_prefix ${LLVM_SLOT})"
- $(cmake_use_find_package gdbui KSysGuard)
- -DBUILD_executeplasmoid=$(usex plasma)
- $(cmake_use_find_package plasma KF5Plasma)
- $(cmake_use_find_package hex OktetaKastenControllers)
- $(cmake_use_find_package qmake KDevelop-PG-Qt)
- $(cmake_use_find_package reviewboard KF5Purpose)
- $(cmake_use_find_package subversion SubversionLibrary)
- )
-
- use gdbui || mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_KF5SysGuard=ON )
- use reviewboard || mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_KDEExperimentalPurpose=ON )
-
- ecm_src_configure
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- optfeature "konsole view" kde-apps/konsole
- optfeature "static C++ Qt code analysis" dev-util/clazy
- optfeature "static C/C++ code analysis" dev-util/cppcheck
- optfeature "heap memory profiling" "dev-util/heaptrack[gui]"
- optfeature "meson project manager plugin" dev-util/meson
- optfeature "formatting configurations via customscript plugin" dev-util/indent
- optfeature "formatting configurations via customscript plugin" dev-util/uncrustify
- fi
- ecm_pkg_postinst
-}