summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-09 21:59:01 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-10 00:48:40 -0500
commitbcccc1065cef9551515359072c4c9d1fcdd50fc3 (patch)
tree28d5c8011374e2ef291dbb16bd2e4d77ecb3835f /dev-util/wayland-scanner
parentdev-util/wayland-scanner: Explicitly disable tests (diff)
downloadgentoo-bcccc1065cef9551515359072c4c9d1fcdd50fc3.tar.gz
gentoo-bcccc1065cef9551515359072c4c9d1fcdd50fc3.tar.bz2
gentoo-bcccc1065cef9551515359072c4c9d1fcdd50fc3.zip
dev-util/wayland-scanner: Move .pc file to neutral location
Allows us to drop multilib support too, which only existed to ease the wayland/wayland-scanner package split. Closes: https://bugs.gentoo.org/803533 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/wayland-scanner')
-rw-r--r--dev-util/wayland-scanner/wayland-scanner-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-util/wayland-scanner/wayland-scanner-9999.ebuild b/dev-util/wayland-scanner/wayland-scanner-9999.ebuild
index 465ecbc49959..c0f4e25a4339 100644
--- a/dev-util/wayland-scanner/wayland-scanner-9999.ebuild
+++ b/dev-util/wayland-scanner/wayland-scanner-9999.ebuild
@@ -11,7 +11,7 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
S="${WORKDIR}/wayland-${PV}"
fi
-inherit meson-multilib
+inherit meson
DESCRIPTION="wayland-scanner tool"
HOMEPAGE="https://wayland.freedesktop.org/ https://gitlab.freedesktop.org/wayland/wayland"
@@ -22,11 +22,11 @@ SLOT="0"
BDEPEND="virtual/pkgconfig"
RDEPEND="
!<dev-libs/wayland-${PV}
- >=dev-libs/expat-2.1.0-r3:=[$MULTILIB_USEDEP]
+ >=dev-libs/expat-2.1.0-r3:=
"
DEPEND="${RDEPEND}"
-multilib_src_configure() {
+src_configure() {
local emesonargs=(
-Ddocumentation=false
-Ddtd_validation=false
@@ -36,3 +36,9 @@ multilib_src_configure() {
)
meson_src_configure
}
+
+src_install() {
+ meson_src_install
+
+ mv "${ED}"/usr/$(get_libdir)/pkgconfig "${ED}"/usr/share/pkgconfig
+}