summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-11 03:44:02 +0100
committerSam James <sam@gentoo.org>2023-04-11 03:44:42 +0100
commitda3b75e6e0ebc97ff9bc926756aee926fa44d328 (patch)
tree5da9844f5f4a1dd849e16d5b200c5312909bcb22 /dev-util/perf
parentapp-editors/pluma: fix crash w/ FORTIFY_SOURCE=3 (diff)
downloadgentoo-da3b75e6e0ebc97ff9bc926756aee926fa44d328.tar.gz
gentoo-da3b75e6e0ebc97ff9bc926756aee926fa44d328.tar.bz2
gentoo-da3b75e6e0ebc97ff9bc926756aee926fa44d328.zip
dev-util/perf: BDEPEND on setuptools
It's always needed in util/*, even for USE=-python. Closes: https://bugs.gentoo.org/879161 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/perf')
-rw-r--r--dev-util/perf/perf-5.19-r1.ebuild (renamed from dev-util/perf/perf-5.19.ebuild)4
-rw-r--r--dev-util/perf/perf-6.0-r1.ebuild (renamed from dev-util/perf/perf-6.0.ebuild)4
-rw-r--r--dev-util/perf/perf-6.2-r1.ebuild (renamed from dev-util/perf/perf-6.2.ebuild)4
3 files changed, 9 insertions, 3 deletions
diff --git a/dev-util/perf/perf-5.19.ebuild b/dev-util/perf/perf-5.19-r1.ebuild
index 129012be23f9..ea6fd7e11d61 100644
--- a/dev-util/perf/perf-5.19.ebuild
+++ b/dev-util/perf/perf-5.19-r1.ebuild
@@ -37,8 +37,11 @@ IUSE="audit babeltrace clang crypt debug +doc gtk java libpfm lzma numa perl pyt
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# setuptools (and Python) are always needed even if not building Python bindings
BDEPEND="
${LINUX_PATCH+dev-util/patchutils}
+ ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
sys-devel/bison
sys-devel/flex
virtual/pkgconfig
@@ -48,7 +51,6 @@ BDEPEND="
app-text/xmlto
sys-process/time
)
- ${PYTHON_DEPS}
"
RDEPEND="audit? ( sys-process/audit )
diff --git a/dev-util/perf/perf-6.0.ebuild b/dev-util/perf/perf-6.0-r1.ebuild
index 611ca8224448..be9dbc82a5f9 100644
--- a/dev-util/perf/perf-6.0.ebuild
+++ b/dev-util/perf/perf-6.0-r1.ebuild
@@ -36,8 +36,11 @@ IUSE="audit babeltrace clang crypt debug +doc gtk java libpfm lzma numa perl pyt
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# setuptools (and Python) are always needed even if not building Python bindings
BDEPEND="
${LINUX_PATCH+dev-util/patchutils}
+ ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
sys-devel/bison
sys-devel/flex
virtual/pkgconfig
@@ -47,7 +50,6 @@ BDEPEND="
app-text/xmlto
sys-process/time
)
- ${PYTHON_DEPS}
"
RDEPEND="audit? ( sys-process/audit )
diff --git a/dev-util/perf/perf-6.2.ebuild b/dev-util/perf/perf-6.2-r1.ebuild
index c9df3f9793cf..8dc6385d598e 100644
--- a/dev-util/perf/perf-6.2.ebuild
+++ b/dev-util/perf/perf-6.2-r1.ebuild
@@ -36,8 +36,11 @@ IUSE="audit babeltrace clang crypt debug +doc gtk java libpfm lzma numa perl pyt
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# setuptools (and Python) are always needed even if not building Python bindings
BDEPEND="
${LINUX_PATCH+dev-util/patchutils}
+ ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
sys-devel/bison
sys-devel/flex
virtual/pkgconfig
@@ -47,7 +50,6 @@ BDEPEND="
app-text/xmlto
sys-process/time
)
- ${PYTHON_DEPS}
"
RDEPEND="audit? ( sys-process/audit )