summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-06-27 20:01:00 -0700
committerMatt Turner <mattst88@gentoo.org>2023-06-28 10:33:10 -0700
commitbc44f71acb305cd72377cc0fda48498a6abde848 (patch)
tree1a1dcea553e456e00fcd78b793a4553e252b9176 /dev-util/perf
parentdev-util/perf: Fix dependency for USE=crypt (diff)
downloadgentoo-bc44f71acb305cd72377cc0fda48498a6abde848.tar.gz
gentoo-bc44f71acb305cd72377cc0fda48498a6abde848.tar.bz2
gentoo-bc44f71acb305cd72377cc0fda48498a6abde848.zip
dev-util/perf: Remove IUSE=zlib and always enable support
libbpf support is built unconditionally, and it requires zlib. zlib is on every system anyway, so remove the USE flag. Closes: https://bugs.gentoo.org/839003 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/perf')
-rw-r--r--dev-util/perf/perf-6.3-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-util/perf/perf-6.3-r1.ebuild b/dev-util/perf/perf-6.3-r1.ebuild
index 2aac8aa2ed75..eb28c4419c9b 100644
--- a/dev-util/perf/perf-6.3-r1.ebuild
+++ b/dev-util/perf/perf-6.3-r1.ebuild
@@ -32,7 +32,7 @@ SRC_URI+=" https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/${LINUX_SOURCES}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
-IUSE="audit babeltrace caps clang crypt debug +doc gtk java libpfm lzma numa perl python slang systemtap unwind zlib zstd"
+IUSE="audit babeltrace caps clang crypt debug +doc gtk java libpfm lzma numa perl python slang systemtap unwind zstd"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -72,10 +72,10 @@ RDEPEND="
slang? ( sys-libs/slang )
systemtap? ( dev-util/systemtap )
unwind? ( sys-libs/libunwind:= )
- zlib? ( sys-libs/zlib )
zstd? ( app-arch/zstd:= )
dev-libs/elfutils
sys-libs/binutils-libs:=
+ sys-libs/zlib
"
DEPEND="${RDEPEND}
@@ -220,7 +220,7 @@ perf_make() {
NO_SDT=$(puse systemtap)
NO_SLANG=$(puse slang)
NO_LZMA=$(puse lzma)
- NO_ZLIB=$(puse zlib)
+ NO_ZLIB=
WERROR=0
LIBDIR="/usr/libexec/perf-core"
libdir="${EPREFIX}/usr/$(get_libdir)"