summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2022-06-16 11:09:18 +0200
committerGuilherme Amadio <amadio@gentoo.org>2022-06-16 11:34:08 +0200
commit12fd68f5ccf1ae5ab9d364ca2800fd86c1c4b6d9 (patch)
treeb44f29308cbb9dcf47bb5f5b515989dc11ad9e83 /dev-util/perf
parentdev-python/wrapt: Stabilize 1.14.1 ppc64, #852542 (diff)
downloadgentoo-12fd68f5ccf1ae5ab9d364ca2800fd86c1c4b6d9.tar.gz
gentoo-12fd68f5ccf1ae5ab9d364ca2800fd86c1c4b6d9.tar.bz2
gentoo-12fd68f5ccf1ae5ab9d364ca2800fd86c1c4b6d9.zip
dev-util/perf: use at sign as delimiter in sed commands
Closes: https://bugs.gentoo.org/832165 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'dev-util/perf')
-rw-r--r--dev-util/perf/perf-5.15-r1.ebuild4
-rw-r--r--dev-util/perf/perf-5.17.1.ebuild4
-rw-r--r--dev-util/perf/perf-5.18.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/dev-util/perf/perf-5.15-r1.ebuild b/dev-util/perf/perf-5.15-r1.ebuild
index 21985387f161..9f1e52387618 100644
--- a/dev-util/perf/perf-5.15-r1.ebuild
+++ b/dev-util/perf/perf-5.15-r1.ebuild
@@ -150,10 +150,10 @@ src_prepare() {
# Drop some upstream too-developer-oriented flags and fix the
# Makefile in general
sed -i \
- -e "s:\$(sysconfdir_SQ)/bash_completion.d:$(get_bashcompdir):" \
+ -e "s@\$(sysconfdir_SQ)/bash_completion.d@$(get_bashcompdir)@" \
"${S}"/Makefile.perf || die
# A few places still use -Werror w/out $(WERROR) protection.
- sed -i -e 's:-Werror::' \
+ sed -i -e 's@-Werror@@' \
"${S}"/Makefile.perf "${S_K}"/tools/lib/bpf/Makefile || die
# Avoid the call to make kernelversion
diff --git a/dev-util/perf/perf-5.17.1.ebuild b/dev-util/perf/perf-5.17.1.ebuild
index a2e565d93fcb..773d205044fc 100644
--- a/dev-util/perf/perf-5.17.1.ebuild
+++ b/dev-util/perf/perf-5.17.1.ebuild
@@ -148,10 +148,10 @@ src_prepare() {
# Drop some upstream too-developer-oriented flags and fix the
# Makefile in general
sed -i \
- -e "s:\$(sysconfdir_SQ)/bash_completion.d:$(get_bashcompdir):" \
+ -e "s@\$(sysconfdir_SQ)/bash_completion.d@$(get_bashcompdir)@" \
"${S}"/Makefile.perf || die
# A few places still use -Werror w/out $(WERROR) protection.
- sed -i -e 's:-Werror::' \
+ sed -i -e 's@-Werror@@' \
"${S}"/Makefile.perf "${S_K}"/tools/lib/bpf/Makefile || die
# Avoid the call to make kernelversion
diff --git a/dev-util/perf/perf-5.18.ebuild b/dev-util/perf/perf-5.18.ebuild
index a2e565d93fcb..773d205044fc 100644
--- a/dev-util/perf/perf-5.18.ebuild
+++ b/dev-util/perf/perf-5.18.ebuild
@@ -148,10 +148,10 @@ src_prepare() {
# Drop some upstream too-developer-oriented flags and fix the
# Makefile in general
sed -i \
- -e "s:\$(sysconfdir_SQ)/bash_completion.d:$(get_bashcompdir):" \
+ -e "s@\$(sysconfdir_SQ)/bash_completion.d@$(get_bashcompdir)@" \
"${S}"/Makefile.perf || die
# A few places still use -Werror w/out $(WERROR) protection.
- sed -i -e 's:-Werror::' \
+ sed -i -e 's@-Werror@@' \
"${S}"/Makefile.perf "${S_K}"/tools/lib/bpf/Makefile || die
# Avoid the call to make kernelversion